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Abstract
Andrews, Patricia L.; Bevins, Collin D.; Seli, Robert C. 2008. BehavePlus fire modeling system, version 4.0: 
User's Guide. Gen. Tech. Rep. RMRS-GTR-106WWW Revised. Ogden, UT: Department of Agriculture, Forest 
Service, Rocky Mountain Research Station. 116p.

This publication has been revised to reflect updates made to version 3 of the BehavePlus software, it was 
originally published as the BehavePlus fire modeling system, version 2.0 User’s Guide in June, 2003

The BehavePlus fire modeling system is a program for personal computers that is a collection of mathematical 
models that describe fire and the fire environment. It is a flexible system that produces tables, graphs, and 
simple diagrams. It can be used for a multitude of fire management applications including projecting the behavior 
of an ongoing fire, planning prescribed fire, and training. BehavePlus is the successor to the BEHAVE fire 
behavior prediction and fuel modeling system. Primary modeling capabilities include surface fire spread and 
intensity, crown fire spread and intensity, safety zone size, size of point source fire, fire containment, spotting 
distance, crown scorch height, tree mortality, wind adjustment, and probability of ignition. The User's Guide 
describes operation of the program. Other papers describe the models and application of the system. 
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Preface
This User's Guide explains how to use the BehavePlus fire modeling system software. Other papers will 
describe the models incorporated into the system and application of the predictions.

This is an RMRS online publication. It can be downloaded from the Rocky Mountain Research Station 
publications web page, http://www.fs.fed.us/rm/main/pubs/electronic.html

You can download this User's Guide and the BehavePlus program from the BehavePlus web site, http://
firemodels.org

This User's Guide is also an integral part of the BehavePlus system, serving as online help.

This publication has been revised from its original June, 2003 release. It will continue to be updated as features 
and modeling capabilities are added to the program.

The BehavePlus system is supported by 

US Forest Service
National Fire and Aviation Management Information Systems Team
3833 S. Development Avenue
Boise, ID 83705

(800) 253-5559 or (208) 387-5290

fire_help@fs.fed.us

What’s New
Version 4.0 adds modeling capabilities and features to version 3. A summary of changes can be found in the 
Appendix.

The use of trade or firm names in this publication is for reader information and does not imply
 endorsement by the U.S. Department of Agriculture of any product or service.

http://www.fs.fed.us/rm/main/pubs/electronic.html
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1. Introduction
The BehavePlus fire modeling system is a PC-based program that is a 
collection of models that describe fire and the fire environment. It is a 
flexible system that produces tables and graphs and can be used for a multitude of fire management applications. 
BehavePlus is the successor to the BEHAVE fire behavior prediction and fuel modeling system (Andrews 1986, 
Andrews and Chase 1989, Burgan and Rothermel 1984, Andrews and Bradshaw 1990). It is called the 
BehavePlus fire modeling system to reflect its expanded scope (Andrews 2007, Andrews and Bevins 1999).

This document describes only the operation of the BehavePlus program. The fire models and their application 
are described elsewhere.

Many of the fire models in BehavePlus are the same as those in the FARSITE fire area simulator (Finney 1998) 
and the FlamMap fire behavior mapping and analysis system (Finney 2006). Each system meets a different need. 
Shown below are example outputs from each.

Sample table, graph, and diagram output from BehavePlus:
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Sample fire perimeter output from FARSITE:

Sample landscape fire potential output from FlamMap:
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Version 1.0 of BehavePlus was based primarily on the same fire models that composed the old BEHAVE system. 
Development focus was initially on a new look and feel for the program. This paper describes version 4.0, which 
provides additional models and features. A summary of changes to version 3.0 is given in the Appendix.

The primary modeling capabilities of BehavePlus, version 4.0, include 

• Surface fire spread and intensity

• Safety zone size

• Size of a point source fire

• Fire containment

• Spotting distance

• Crown scorch height

• Tree mortality

• Probability of ignition from fire brands or from lightning

• Transition from surface to crown fire

• Crown fire spread

Other modeling capabilities include

• Tables for fine dead fuel moisture 

• Tables for relative humidity or dew point

• Standard and custom fuel models

• Three methods for weighting two fuel models: two-dimensional expected spread, harmonic mean, area 
weighted 

Key features include

• Diagrams for point source fire shape, shape of a contained fire, fire characteristics chart, wind / slope / fire 
directions

• Shading of table output for acceptable fire conditions

• Distances in map units

• User control of input options and output variables

• Description of each input and output variable

• User control of units and number decimal places displayed

• Multiple values can be entered for almost any input variable
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The help system is an important part of the BehavePlus system. This User's Guide is available with the program 
for help on operation of the program. In addition, a help browser is available in the dialog boxes providing 
immediate information on specific operations and definition of input and output variables as shown below. 

Variable descriptions and input/output tables are also available in a Adobe Acrobat document that is part of the 
help system. That paper (Andrews, 2008) is referred to as the “Variables paper” in this User’s Guide.
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This page blank on purpose.
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2. Operation
This User's Guide addresses only operation of the program. The fire 
models, associated variables, and application are described elsewhere.

2.1. Organization
Organization of material on Operation of the BehavePlus program is different from the organization of the 
program itself. It is designed to help you find the answer to a question. Most users are comfortable with looking 
at menus and dialog boxes and associated information in the program without use of a User's Guide.

This is not a step-by-step operation manual, but a reference guide. The tutorials provide step-by-step 
instructions.

In describing operation of the program, we use the following font and/or conventions in describing menus, 
commands, buttons, tabs, and check boxes:

Configure > Module selection > SURFACE > Options… > Fuel & Moisture > fuel models radio 
button.

For example the sequence of menus, commands, check boxes, buttons, and tabs shown above refers to the 
following actions in BehavePlus:

Each of the above elements would be described in this User’s Guide as

1. Configure menu

2. Module selection command

3. SURFACE check box

4. Options... button

5. Fuel & Moisture tab

6. fuel models radio button
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Other elements used in BehavePlus include

7. Spin box - select the value using the  buttons or enter a value from the keyboard,

8. Text box - click inside the box to enter values from the keyboard,

9. Drop-down list - Choose the value from the list displayed with the  button.

In the interest of saving space and improving readability, we include screen captures of only the portion of 
concern.

2.2. Design

2.2.1. Page Oriented
BehavePlus is meant to be more than just a fire modeling tool. It is meant to be a lesson book with a built-in 
training manual, and a planning tool whose results may be incorporated into management reports. It is meant to 
be a fire behavior assessment aid whose tables and graphs can be shared with others in briefings and in written 
documentation.

Because of these expectations, the BehavePlus user interface is designed around the concept of the standard 8.5 
x 11 printed page.

Given input information BehavePlus can generate documentation, diagrams, tables, and graphs. Fortunately, 
BehavePlus has a variety of methods for saving and displaying your work. Six months later when you need to 
review the work, the What, How, and Why of each Run is considerably less obscure than it would have been 
otherwise.

The page on which you enter input information appears first (page 1) and is called the Worksheet. A complex 
Worksheet may span several pages. Once the Calculate button is pressed, BehavePlus generates additional 
pages containing output tables, graphs, and diagrams. These too are deigned to fit neatly on the printed page. 
Navigation buttons on the Tool Bar let you move to the first page, last page, next page, or previous page. The 
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Pages menu lets you jump directly to any diagram, table, or graph. The “Print” dialog box lets you print 
selected pages.

2.2.2. Highly Configurable
BehavePlus is a repository of many mathematical models related to fire behavior and effects. These models may 
have alternate input sets and can produce many output variables. Individual models may be linked together so 
that outputs from one module automatically become inputs for another module. Input and output variables may 
have user-specified units of measure. Outputs may be in the form of diagrams, tables, and/or graphs.

BehavePlus may be used for fire behavior training, for fire planning, or for real-time fire behavior assessment. It 
may be used to assess fire behavior, fire effects, and the link between them.

2.2.3. Self Documenting
Configurability must be balanced with complexity. The input Worksheet automatically documents all Modules in 
use, all input variables and units of measure, all output variables and units of measure, and pertinent notes on 
the current configuration. The Worksheet also allows you to enter a Run description (and possibly additional 
training or fire incident information) and offers a notes field for free-field entry of expository text.

2.2.4. User Manual and Help

The Guide Button  next to each entry field opens a dialog box containing a help browser pane with valid 
inputs. The help browser pane describes input and output variables and program operation with tables, 
photographs, and figures to help you select inputs. Variable descriptions with input and output tables are also 
available in a Adobe Acrobat document by selecting the Help > Variable Help command.

In addition, this User’s Guide is available as part of BehavePlus with the Help > User’s Guide command. 

2.2.5. Not Boring
Finally, every attempt has been made to keep BehavePlus from becoming yet another boring program with a 
gray personality. If you prefer you can eliminate the pictures for the entire session by clearing the Show 
picture pane check box on the Configure > Appearance preferences > Application tab.



Operation  BehavePlus v4.0 User’s Guide

10 USDA Forest Service General Technical Report RMRS-GTR-106WWW Revised. 2008

You can also choose to show the art work or not in the dialog boxes with the Picture check box

2.2.6. Borders
The border color and thickness on the Worksheet and output pages can be 
changed on the Configure > Appearance preferences > 
Application tab using the Border Color drop-down list and the Border 
Width spin box. The border can be eliminated by entering a Border 
Width of 0.

2.3. Features

2.3.1. Fire Models
A listing of the fire models in BehavePlus, with citations, is given in Andrews (2007) and in the Variables paper 
(Andrews 2008), which is available by selecting the Help > Variable Help command.

BehavePlus contains models to estimate

• Surface fire rate of spread, intensity, and flame length

• Direction of maximum spread

• Wind adjustment factor

• Rate of spread through two fuel models

• Crown fire spread rate, critical thresholds, and fire type

• Safety zone size

• Point source fire shape, area, and perimeter

• Success or failure of suppression resources to build line around a fire

• Spotting distance from a burning pile, from torching trees, or a wind-driven surface fire

• Crown scorch height

• Fire-induced tree mortality

• Probability of fire ignition from firebrands or from lightning
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2.3.2.  Operation
BehavePlus has the following operational features:

• Multiple Worksheets may be open at one time.

• Worksheets may be overlaid, tiled, cascaded, and resized.

• Modules (collections of related fire models) may be individually toggled on/off.

• Modules may have alternate input options available through the Configure > Module selection > 
Options… > Input Options tab.

• Module output variables can be selected via the Configure > Module selection > Options… > Out-
put Variables tab.

• Modules may be linked so the outputs from one module are automatically input into another module.

• Distance outputs may be scaled to map units.

• Input and output units of measure may be modified by the user.

• Custom Worksheet configurations may be saved and re-used.

• Custom sets of units of measure may be saved and re-used.

• The Guide Button next to each Worksheet entry field displays a help browser pane with context-specific 
text and either a list of valid choices (for discrete variables) or fields for generating a range of input values.

• Zero, one, or two input variables may have multiple entry values, producing either a simple result list, a 
single one-way table, or a multi-page two-way table, respectively.

• If one input variable has multiple entry values, a separate graph can be generated for each output variable. 
If two input variables have multiple entry values each output variable graph contains a family of curves.

• The SURFACE, SIZE, and CONTAIN Modules can produce diagrams of their results.

• Help commands make this manual and all associated documentation available in Adobe Acrobat format 
for reading, web browsing, and printing.

• Completed Runs may be saved and re-used.

2.4. Installation

2.4.1. Download
BehavePlus is available for download from www.firemodels.org. 

2.4.2. System Requirements
BehavePlus has modest system requirements.

• Windows 95, 98, ME, NT, 2000, XP, or Vista

• Minimum 800 x 600 video resolution with 256 (8-bit) colors (recommend 1024 x 768 video resolution 
with 64K (16-bit) colors)

• 16 megabytes of available RAM

• 20 megabytes of disk storage

2.4.3. Windows Installation
BehavePlus for Windows is packaged using the Wise Installation System. Simply type the name of the package 
(e.g., bp_4_0_0.exe) at a command prompt (or click on its name in Windows Explorer) and the installation 
wizard will guide you through the process. This mostly consists of pressing the OK button.

http://www.firemodels.org
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2.4.4. File Structure
BehavePlus has a proscribed file system structure; all files must be located in specific subdirectories. The parent 
directory of this file structure and all its subdirectories and files are collectively known as a Workspace. When 
BehavePlus is first installed it has a single Workspace called "DefaultDataFolder" as shown below.

This is the default current Workspace every time BehavePlus is started. 

Workspaces aid file management as you apply BehavePlus to several projects. See the section 17.1, Workspaces, 
for more information.

A list of three letter file extensions used by BehavePlus is shown in the following table. These extensions are 
automatically attached to the files you create in BehavePlus.

2.5. Definitions
A Worksheet is the first page or two containing the input Entry Fields. The content of a Worksheet depends 
upon the specific BehavePlus configuration including module selections, input options, output variables, and 
units of measure. Some Example Worksheets are supplied with the BehavePlus distribution and are included in 
every Workspace. You may develop your own Worksheets and save them for later reuse. A Worksheet does 
not have input values associated with it.

A Run is a Worksheet that has a complete set of valid input values, but no outputs are saved in a Run. You must 
calculate a saved Run to obtain outputs. Runs may be saved for documentation and later use. The BehavePlus 
installation includes Example Runs.

File extension File Type Folder

.bpf Custom fuel models FuelModelFolder

.bpm Moisture scenarios MoistureScenarioFolder

.bpr Runs RunFolder

.bpu Custom Unit Sets UnitsSetFolder

.bpw Worksheets WorksheetFolder
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A Model is a set of equations that estimate one or more output variables from one or more input variables. 
BehavePlus contains many mathematical models which are grouped into Modules.

A Fuel Model is a set of numbers describing a fuel bed used by the surface fire spread model.

A Module is a collection of one or more mathematical models. The IGNITE Module, for example, includes both 
the firebrand ignition model and the lightning strike ignition model.

A Continuous Variable is an input or output variable that has a continuous range of numerical values. 
Continuous variables have a minimum and maximum valid value. Examples include fuel moisture content and 
wind speed.

A Discrete Variable has a finite set of valid values. Examples include Fuel Model and Spotting Source Location.

A Guide Button  is the button with the arrow icon next to each Worksheet entry field. Pressing the Guide 
Button activates an “Input Guide” dialog box containing a help browser pane and input assistance. For 
continuous variables, the dialog facilitates entry of inputs by specifying the minimum input value, maximum input 
value, and increment value. For discrete variables the “Input Guide” dialog box contains a list of all valid inputs 
from which the user may select values.

A Workspace is a complete subdirectory tree containing all required BehavePlus files plus any additional 
Worksheet, Run, Fuel Model, Moisture Scenario, Units Set, or capture files saved by the user. A Workspace can 
be used for a project. Workspaces are created by the File > Workspaces > New workspace and the 
Files > Workspaces > Clone current workspace commands.

2.6. Menus and Toolbar
BehavePlus operations are available from the menu bar.
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The more common operations, such as Module Selection or Calculate, may also be invoked from Toolbar 
buttons. Toolbar buttons and their equivalent Menu commands are shown below:

Toolbar
Buttons

Definitions Equivalent menu operation

Open a new Worksheet File > Open Worksheet

Open a saved Run File > Open Run

Print this Run File > Print

Module selection Configure > Module selection

Calculate this Run File > Calculate

Display first page Pages > then select page #

Display last page Pages > then select page #

Display previous page Pages > then select page #

Display next page Pages > then select page #

Access User’s Guide Help > User’s Guide
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3. Worksheets
A Worksheet is a form on which you enter input. Module selection, input 
options, and output variable selections determine the Worksheet.

BehavePlus initially starts with the BasicStart.bpw example Worksheet. This gives the option of doing a quick 
basic fire behavior Run without having to load or configure a Worksheet.

You also have the option of setting your own startup worksheet as described in section 3.8

3.1. Worksheet layout
A BehavePlus Worksheet is more than just an input form; it is the primary source of documentation about the 
Run. Worksheets include the following components:

Header - The Worksheet header shows the BehavePlus version number, useful for reporting bugs and 
determining if you have the most recent update. The header also includes the date and time of the last 
calculation and the page number, which lets you collate the correct pages after printing and spreading them out 
for further study.

Border - The line surrounding the Worksheet body may be modified with the Configure > Appearance 
preferences > Worksheet tab.

Tabs - Zero, one, or more page tabs with labels along the right-hand margin of the Worksheet may be activated 
with the Configure > Appearance preferences > Page Tabs tab.

Documentation - This section lists all the currently selected modules and contains an entry field for the Run 
description. Additional documentation entry fields are optionally activated on the Configure > Appearance 
preferences > Worksheet tab.

Input - This section contains the required input data entry fields identified by a short phrase and their units of 
measure. Each entry text box also has a Guide  button that may be pressed for input assistance. Entry text 
boxes are grouped under headings such as "Fuel/Vegetation, Surface/Understory", "Fuel/Vegetation, Overstory", 
"Fuel Moisture", "Weather", "Terrain", and “Fire”.

Acceptable Fire Conditions - Used to enter ranges of acceptable fire behavior when using the table shading 
option. Table shading is enabled by selecting the Configure > Table shading for acceptable fire 
conditions check box.

Run Option Notes - This section documents pertinent configuration settings that are selected for the 
Worksheet.

Output Variables - This section lists all the selected output variables and their units of measure. This section 
may be toggled on/off in the Configure > Appearance preferences > Worksheet tab.

Notes - This section permits the user to enter free-field expository text. The user has control of the size of this 
section or whether it is displayed using the Configure > Appearance preferences > Worksheet tab.

3.2. Example Worksheets
A number of predefined example Worksheets are included with the BehavePlus installation in the 
ExampleWorksheets folder. You may use these Worksheets as provided, or use them as starting points for 
your own configuration. Use the File > Open worksheet command to open an example Worksheet and 
proceed to change your module selection, input options, and/or output variables as needed. Once the 
Worksheet is configured the way you want, you may name and save it as a new Worksheet. During subsequent 
BehavePlus sessions you may load your custom Worksheet.
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Shown below is the BasicStart.bpw example Worksheet:

3.3. Worksheet Sections

3.3.1. Page Header
The header of each page includes the version number of the BehavePlus program and the page number. Once a 
Run is calculated the date and time of the calculation is added. The date and time and page number can be used 
to correctly collate printed documents.

3.3.2. Documentation
Documentation is the header information on the Worksheet. The calculation modules that have been selected 
are listed. There is always a Description field.
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Additional documentation lines can be added by selecting the 
Fire behavior projection worksheet header, Training 
worksheet header, and/or Prescribed fire plan 
worksheet header check boxes from the Configure > 
Appearance preferences > Worksheet tab.

Selecting the Fire projection documentation check box adds the following input fields to the Worksheet:

Selecting the Training documentation check box adds the following input fields to the Worksheet:

More than one option can be selected at the same time.

3.3.3. Input section
The required input variables and their units are displayed next to their text boxes. Fuel moisture variables that 
are not required have the text box shaded. In the example below, only 1-h fuel moisture is required for fuel 
model 1, because the other fuel categories are not included in that fuel model.

The Guide  button for each input variable provides access to definitions and input assistance. Input variables 
are organized by logical association (rather than by calculation module). A table of all possible input variables by 
category is given in the Variables paper.
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3.3.4. Input codes
The definition of discrete variable input codes can be displayed by 
selecting two options on the Configure > Appearance > 
Worksheet tab. Selecting the Show description for all discrete 
variable codes check box displays the codes on the Worksheet 
beneath the variable. The Show descriptions only for entered 
discrete variable codes check box displays the codes used in the 
Run on a separate output page when selected.

For example, on the SPOT module with the Show descriptions for all discrete variable codes check 
box selected, all tree species and spotting source location codes are shown.
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With the Show descriptions only for entered discrete variable codes check box selected a page is 
generated at the end of outputs listing the codes and descriptions used in the Run.

3.3.5. Acceptable Fire Conditions
This section is displayed on the Worksheet when the Table shading for acceptable fire conditions 
check box in the “Module Selection” dialog box is selected.

Acceptable Fire Conditions are fully explained in Chapter 7, Table Shading.

3.3.6. Run Option Notes
For clarification, Run options are given after the input variables. The user does not have the option of 
suppressing this information. The module using the option is also listed in brackets.

3.3.7. Output variables
Selected output variables and their units can be displayed at the end of the 
input Worksheet using the Configure > Appearance preferences > 
Worksheet tab. The module calculating the output variable is also listed in 
brackets.

For example:
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3.3.8. Notes
The Notes section of the Worksheet allows the user to enter text to 
describe a Run. The user has the option of changing the number of lines 
provided for notes or even eliminating the notes section on the Configure 
> Appearance preferences > Worksheet tab with the Show notes 
section check box and the Notes Lines spin box.

3.3.9. Page Tabs
Page tabs can be displayed along the right margin of the page. This is useful, for example, to identify Runs for a 
particular fire or training session that are subsequently bound in a three-ring binder or stored in filing folders. 
Page tabs can be added and defined with the Configure > Appearance preferences > Page Tabs tab.

Tabs per page - The size of the tab depends upon the value selected in this spin box. Only one tab is actually 
displayed per page. If tabs per page is 4, the displayed tab occupies one-fourth the page height. If it is 10, the 
displayed tab occupies one-tenth the page height. As this number increases, the displayed tab size decreases.

Tab position - Determines the position of the displayed tab. Tab position 1 is always at the upper edge of the 
right margin.

Tab text - The text to appear on the tab. The text is centered within the tab and will therefore be truncated at 
both ends if it is too long.

Tab text color - A color is selected from the drop-down list.

Tab font size - Font point size is selected using this spin box.
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The above settings create the tab on the Worksheet below:

3.4. Loading a previously saved Worksheet
A previously saved Worksheet can be loaded using

• the File > Open worksheet command,

• or the  toolbar button.

To see the Worksheets in the folder click on the  button to the left of the folder.

To select a Worksheet either

• double click on it,

• or select and click the OK button.

A set of Worksheets is supplied with the program in the "ExampleWorksheets" folder.
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3.5. The 0Startup Worksheet
The 0Startup.bpw Worksheet is used as the starting place for selecting calculation modules and options. It 
shows no input or output variables, but it sets defaults for all settings. The 0Startup.bpw Worksheet was used 
to initialize all of the example Worksheets.

A Worksheet can be designed to meet specific needs by starting with the 0Startup.bpw Example Worksheet, 
selecting the desired modules, and changing options as needed. The startup Worksheet is named 0Startup.bpw 
to assure that it is the first selection of the Example Worksheets folder.

3.6. Changing a Worksheet
A Worksheet can be changed at any time by changing the selected modules and associated options. The changes 
are in effect only for the current session unless the revised Worksheet is saved. If a Worksheet that came with 
the program in the ExampleWorksheets folder is changed, the revised version must be saved in another 
Worksheet folder.

3.7. Saving a Worksheet or a Run
A Worksheet can be saved for later use with the File > saveAs > Worksheet command. The values entered 
onto the Worksheet are not saved. 

Save the Run, which is a Worksheet with the defined input values, with the File > saveAs > Run command.

See the Section 17.4, Save As, for more specific information.

3.8. Setting a Startup Worksheet
BehavePlus initially starts with the BasicStart.bpw Worksheet.You have the option of changing the startup 
Worksheet to one that better meets your needs.

The File > Set startup worksheet command opens a dialog box where you can select any Worksheet from 
the WorksheetFolder. It can be one of the ExampleWorksheets that come with the application or one that you 
have developed and saved.



USDA Forest Service General Technical Report RMRS-GTR-106WWW Revised. 2008 23

4. Modules
Modules are a grouping of mathematical fire models for a Worksheet. 
Selection of modules is made with the Configure > Module command.

The output variables that can be calculated by each module are given in the Variables paper.

Indentation of modules indicates which can be linked, which means that output from one module is used as 
input to the other. For example, if both SURFACE and SAFETY are selected, the modules are linked. Output 
from SURFACE is used as input to SAFETY. If only SAFETY is selected, the Flame Length input appears on 
the Worksheet and must entered by the user. A table of input variables and associated modules is given in the 
Variables paper.

Selection of modules, options, and output variables determines the required input variables shown on the 
Worksheet. The Options… button is used to configure a module’s input options or change the output 
variables calculated. Some module options are very simple, IGNITE for example, has no input options.

The “SURFACE Module Options” dialog box offers the most options, with multiple tabs for both input options 
and output variables.
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4.1. Input options
Some modules offer options on alternate ways of specifying input. For example, clicking the MORTALITY 
Options… button displays the “MORTALITY Module Options” dialog box with the Bark thickness is input 
option:

The bark thickness option affects the input variables included on the Worksheet. If Bark thickness is 
specified on the worksheet is selected, the resulting Worksheet is as follows: 

If Bark thickness is estimated from species and d.b.h. is selected, the Worksheet is as follows:
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The SURFACE module has many input options, which are available on several tabs:

For the “SURFACE Module Options” dialog box the following tabs offer input options;

Fuel & Moisture
Wind Speed
Directions
Slope
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4.1.1. Fuel & Moisture Tab
Fuel models are prepackaged sets of fuel parameters representing 
stylized fuel situations. Using this input option allows you to simply 
enter fuel model codes rather than a dozen fuel model 
parameters. This is the most common way of running BehavePlus 
as it greatly simplifies input. If you have special fuel situations, 
create a custom fuel model and use it. 

The individual fuel parameters are required for fuel bed depth, 
extinction moisture content, heat of combustion, and loading and 
surface area-to-volume ratio by fuel particle size class. Fuel model 
parameters can be initialized to an existing fuel model. This 
method is primarily used to develop custom fuel models which are 
saved and reused. 

The two-fuel model options are useful for areas that clearly 
consist of two different fuel models rather than a single, 
homogenous fuel model. The two fuel models are designated as 
“first” and “second”. The coverage is entered for the “first” fuel 
model only. The coverage of the “second” fuel model is the 
remainder, with the total being 100%. The two fuel model options 
work with standard or custom fuel models, but not with the 
special case or fuel parameters options. The primary purpose of 
the two fuel option is weighted rate of spread. It is not appropriate 
to weight fire intensity values or their derivatives such as flame 
length or scorch height.

A special case palmetto-gallberry fuel model was developed by Hough and Albini (1978). It requires input of the 
age of palmetto-gallberry rough, palmetto coverage, understory height, and overstory basal area.

A special case western aspen fuel model was developed by Brown and Simmerman (1986). It requires selection 
of one of four aspen fuel types and aspen curing level (which is different from the curing level for the dynamic 
standard fuel models).

Dynamic curing load transfer is applicable to dynamic standard or custom fuel models. Seventeen of the 40 fuel 
models developed by Scott and Burgan (2005) are dynamic. Selecting the calculated from live herbaceous fuel 
moisture radio button uses the fuel load transfer model described in that paper. Selecting input directly radio 
button allows the user to specify the curing (fuel load transfer portion) directly.

Selecting the Moisture is entered by individual size class radio button requires you enter the moisture content 
for each fuel size class with fuel present in the fuel models used (1-h, 10-h, and 100-h dead fuels and herbaceous 
and woody live fuels).

The dead and live category option for moisture content is the simplest as you enter just two moisture contents; 
one is applied to all the dead fuels, and the second is applied to all the live fuels.

A moisture scenario is a predefined set of fuel moistures for 1-h, 10-h, and 100-h dead fuel and herbaceous and 
woody live fuel. It is analogous to the fuel model concept in that a single code represents an entire moisture 
situation. Fuel moisture scenarios may be developed, for example, to represent local 90-, 95-, and 97-percentile 
weather situations. More information on moisture scenarios is found in Chapter 13 of the User’s Guide.
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4.1.2. Wind Speed Tab
Wind speed can be entered at three different heights; midflame 
(eye-level), 20-ft. or 10-m. When using a 20-ft. or 10-m windspeed 
you also have the option of entering a wind adjustment factor or 
having BehavePlus calculate one based on tree characteristics of 
the site.

Low intensity fires may not continue to spread faster with 
increasing wind speeds. When the Impose maximum reliable 
effective wind speed limit? Yes radio button is selected the 
maximum wind speed used to calculate rate of spread is based on 
the reaction intensity. If the No radio button is selected, the limit 
is not imposed.

4.1.3. Directions Tab
The simplest direction option is using upslope wind and upslope 
spread. To use this method select the Surface fire spread 
direction is only in the direction of maximum spread radio 
button and the Wind is upslope radio button.

Alternatively the non-head fire spread direction and/or direction of the 
wind can be specified. To more easily examine the relative effect of 
wind and slope on fire spread, select the Wind & slope directions 
are degrees clockwise from upslope radio button. Using this 
option, the wind direction is the direction the wind is pushing the fire.

When fire projection are being done for a specific location on a map 
and weather observations or forecasts are being used, select the Wind 
& slope directions are degrees clockwise from north radio 
button. With this option, the wind direction is the direction from 
which the wind is blowing.

4.1.4. Slope Tab
Slope is specified as either percent or degrees by selecting the appropriate 
radio button.

Selecting the Slope steepness is specified on the worksheet radio 
button allows the user to enter the slope values directly on the Worksheet.
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Selecting the Slope steepness is calculated from map measurements radio button allows the slope 
to be calculated from map measurements and additional inputs are required on the Worksheet.

4.2. Output Variables
Every module has choices for which output variables are calculated. The desired output variables are selected 
through the Options… button associated with each module.The selected output determines the input 
requirements on the Worksheet. For example, input variables on the Worksheet when using the SPOT Module 
will be different for each spotting source.

Most of the modules have just one output tab named Output Variables. The SURFACE module has several 
output tabs.

Basic Outputs
Intermediate Outputs
Fuel Outputs
P-G Outputs
Aspen Outputs
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Outputs can be displayed as tables, graphs, or diagrams and charts. Variable outputs are those most typically 
displayed by the SURFACE module. The top section of output variables can be displayed in tables or graphs. 
Details on each output variable are found in the Variables paper.

In addition to the table and graph variables, charts 
and diagrams are also available for some modules.

For example, for the SIZE Module, a simple Fire 
Shape Diagram for the calculated values is 
available.
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When you select this output a diagram of the relative directions of slope, wind, and fire spread is produced for 
each calculation result. These diagrams are useful for clarifying the selected input options and their resulting 
output values.
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5. Entering input
There are several ways to enter input to the BehavePlus program. Values 
can be typed directly into the input field, choices can be made from a list of 
valid input values, a range of values can be specified, and for some variables, 
a selection can be made from a list of common choices.

5.1. Shaded text boxes
In some cases, input variables depend on values entered elsewhere on the Worksheet. When an input variable 
is not required, its text box is shaded. If a value is entered for a shaded text box, it is not used.

5.2. Direct entry
Values can be typed directly into the variable text boxes and the Enter or Tab keys moves the cursor to the 
next field. The cursor can also be moved to any text box with a mouse click. More than one value can be 
entered for an input variable. Multiple values are separated by a space or comma delimiter. You do not need to 
always specify equal steps. You can enter several independent values separated by delimiters.

For table output a separate row and/or column will be created for each value from the input variable text box. 
For graphs of continuous input variables the curve is drawn between the smallest and largest value entered. 
Graphs of discrete variables will display a separate bar for each input value. See chapter 6, Table output, for 
more on how multiple values affect outputs.

5.3. Input Guide

The “Input Guide” dialog box is opened by clicking the Guide  button to the left of each input variable text 
box.

5.3.1. Continuous variables
Valid input ranges can be viewed in the “Input Guide” 
dialog box.

Single values are entered in just the From text box; a  
second value can be entered in the Thru text box.
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For continuous variables the “Input Guide” dialog box allows definition of a range of values by a constant 
increment. For example, midflame wind speed from 0 to 20 mi/h in steps of 5 enters 0, 5, 10, 15, 20 on the 
Worksheet as shown below.

You can also enter a decreasing range with a negative step. This is useful when you have two input variables, 
such as wind and fuel moisture, that have opposite effect on fire behavior

5.3.2. Discrete variables
When the Guide button is clicked for a discrete variable, the allowed selections are given in the center pane of 
the “Input Guide” dialog box.

Clicking the values selects them; you can select several values. This example shows the fuel model "Input Guide" 
dialog box. The Ok button enters the selected fuel models on the Worksheet.
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5.3.3. Choices button
Although any value in the valid range can be entered for a continuous variable, in some cases common values 
can be entered with the Choices button.

When available on the “Input Guide” dialog box, clicking the Choices button displays commonly used values.

After selecting values in the “Slope Steepness” dialog box, clicking Ok enters them on the Worksheet.
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5.4. Linked input variables
When using the CONTAIN module, with the multiple resources input option selected, some input 
variables are directly associated with each other. This is an exception to the general BehavePlus rule. For 
example, a line production rate, arrival time, and duration are assigned to each resource. Linked input variables 
also allow you to enter multiple values for more than two input variables. In the following example, although 
multiple values are assigned to several input variables, those variables are linked together, so only a single 
calculation is done.
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6. Table output
When more than one value is assigned to one or two input variables, table 
output is produced. Tables are produced by selecting the Display table 
results check box in the "Calculate Results" dialog box that displays after 
selecting a File > Calculate command.

6.1. Single value calculation
When each variable is assigned only one value, a simple list of output is given. No table or graph is possible. For 
example:
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6.2. Table output
When more than one value is assigned to a variable, table output is produced. Each output variable is a specified 
column. For example, these multiple Rate of Spread inputs produce the page 2 table below:

6.3. Two way tables
When more than one value is assigned to two variables, a two way table is produced. A table is produced for 
each selected output variable. Either variable can be specified as the row variable in the "Calculate Results" 
dialog box. 

For example, with the above inputs this dialog 
box appears when you Calculate the Run. 

After selecting the Rate of Spread 
(maximum) option button and clicking the Ok 
button, the following tables are produced:
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Changing the Table Row Variable to the 
Elapsed Time radio button swaps the table 
columns and rows produces the following Area 
table:
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6.4. Table appearance
Table row shading can be enabled with the Configure > Appearance > Tables tab.

Selecting the Shade alternate table rows check box causes all output tables to have alternating rows 
shaded with a background color. This may improve the readability of wide tables. If the check box is cleared, 
tables are displayed without any row background color. This table appearance option is used to improve table 
readability, don’t confuse it with the Table shading for acceptable fire conditions output option. See 
chapter 7, Table shading, for more information.

The table row background color is selected from the Shade drop-down list.

Selecting the Show only acceptable conditions when table shading check box replaces crossed off 
output values with blank cells in the output tables produced with the Table shading for acceptable fire 
conditions option as described in chapter 7.

6.5. Multiple pages
There is essentially no limit on the number of values that can be assigned to an input variable. But the resulting 
table might not fit on a single page. For example, if rate of spread is calculated for values from 2 to 30 in steps 
of 2, and elapsed time is specified as the row variable, the table overlaps onto 3 pages.
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The > or < symbols lined to the right and/or left of the table heading indicates that there are additional results 
for those variables in the indicated direction.

The box diagram at the upper left of the pages shows the relative position of the currently viewed page in the 
multi-page table.
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In this example, however, it would make more sense to specify rate of spread as the row variable since it 
produces a table that fits on a single page as shown below:
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7. Table Shading
Table shading for acceptable fire conditions is designed to display the 
conditions that contribute to acceptable fire behavior, such as in developing 
a prescribed fire prescription. It replaces the RXWINDOW program of the old BEHAVE system (Andrews and 
Bradshaw 1990). RXWINDOW reversed the calculations to determine conditions that corresponded to 
specified fire conditions. As additional fire models have become available, this approach is unfeasible. The 
approach taken in BehavePlus is different from that in RXWINDOW. 

7.1. Activating the Table Shading Option
To implement the table shading option select the Table shading for acceptable fire conditions check 
box in the “Module Selection” dialog box.

Once the Table shading for acceptable fire conditions check box is selected a new section, 
Acceptable Fire Conditions, appears on the Worksheet.

Notice that some of the output variables are listed in the Acceptable Fire Conditions section. Not all the 
output variables are available to be constrained. The output variables that can be used to identify acceptable fire 
conditions are listed in the Variables paper.
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7.2. Entering Acceptable Fire Conditions
In the Acceptable Fire Conditions section each output variable listed has a check box and two text boxes 
for entering the range of acceptable fire conditions. By default the check boxes are cleared. The ranges specified 
in the text boxes are only considered if the output variable check box is selected.

This allows you to view all the output variables you want while only using a subset to define your acceptable fire 
conditions. Of course if an output variable is of no interest then clear it from the Outputs tab for the 
appropriate module and it appears in neither the Acceptable Fire Conditions or Output Variables 
section.

After selecting the output variables to define acceptable fire conditions enter the acceptable ranges in the 
corresponding text boxes.

When you clear a check box in the Acceptable Fire Conditions section there is no need to zero out the 
range text boxes. Ranges are ignored if the check box is cleared.
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7.3. Viewing Results
After calculating the Run the table output will look like this. Rate of Spread values less than 3.0 ch/h or greater 
than 5.0 ch/h are crossed off.

The corresponding cells are also crossed off on the fireline intensity table,

Once you have developed a prescription window that you want, you can produce a table with blanks in place of 
the crossed-off values. Select the Configure > Appearance preferences > Tables tab and select the 
Show only acceptable conditions when table shading check box.
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The table now looks like this.

If Fireline Intensity is also selected to define acceptable fire conditions all output tables will change.

For the above ranges using the same fuel, weather, and topography inputs the table outputs looks like this;

Now acceptable output must meet both ranges of acceptable conditions which further constrains the fuel 
moisture and wind conditions that give desired results. Selecting two or more variables in the Acceptable 
Fire Conditions section give results that should be interpreted carefully.
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8. Graph output
When more than one value is entered for one or two input variables, 
graphs can be produced. Graphs are viewed by selecting the Display 
Graph Results check box in the "Calculate Results" dialog box that 
displays after Calculate is requested. The form of the graph depends on whether the variables are continuous or 
discrete. The program automatically takes care of the differences for the user.

8.1. Single variable graph
When a range of values is entered for a single continuous variable, a graph is produced by calculating a fixed 
number of points (which can be changed in the Configure > Appearance > Graph Elements tab) over 
the entered range. Intermediate values entered on the Worksheet are ignored. For example, rate of spread 
entry of 5, 7, 9, 11, 13, 15 produces the same graph as rate of spread entry of 5, 15:
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When a range of values is assigned to a discrete variable, a bar graph is produced. For example, the following is 
a comparison of surface fire spread rates for the standard 13 fire behavior fuel models:

8.2. Two variable graph
When a range of values is assigned to two variables, a graph is produced. If both variables are continuous, the 
variable used for the X-axis can be selected from the "Calculate Results" dialog box. For example:
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In the "Calculate Results" dialog box clear the Display table results check box and accept the defaults in the 
Display graph results section:

With Dead Fuel Moisture(%) as the X-Axis Variable a seperate line is produced for each of the other 
multiple input worksheet values (Midflame Wind Speed (upslope) in this example).

Changing the X-Axis Variable to the Midflame Wind Speed (upslope) in the "Calculate Results" dialog 
box produces a very different graph:
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If a range is assigned to two variables, one continuous and one discrete, the continuous variable is always on the 
X-axis. For example:

With two variables, one continuous and one 
discrete, you no longer have the option of 
changing the X-Axis Variable in the "Calculate 
Results" dialog box.

A graph is not possible when ranges are selected for two discrete variables.

8.3. Axis scales
Setting axis scales is important for getting the best information from your Runs, and especially for comparing 
graph output from different Runs.
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8.3.1. X-axis
The X-axis variable and scale are the same for all graphs produced by a Run. The maximum for the x-axis is set 
to be the maximum value specified for the variable on the Worksheet. 

X Axis Origin and Y Axis Origin (minimum values) can be set for each as either zero or as the variable's 
minimum value as specified on the input Worksheet. The graph origin is set to (0,0) as the default. 

For example, consider the following Run:

Options to define the origin of the graph are set through the Configure > 
Appearance > Graph Size tab. 

Setting both the X Axis Origin and Y Axis Origin to zero produces the 
following graph:
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In the Configure > Appearance > Graph Size tab select Min Value from the 
X-Axis Origin drop-down list to alter the graph appearance.

8.3.2. Y-axis
The Y-axis scale normally differs between graphs produced by a Run since each graph is for a different output 
variable. For example, fireline intensity and flame length have different ranges of output and require a different 
Y-axis scale. By default the Y-axis is scaled to the maximum calculated output value for the variable to make best 
use of the graph area.

When you want to compare graphs between Runs, different Y-axis scales can obfuscate the comparison. A rate 
of spread graph for fuel model 10, for example, usually has a narrower output range than for fuel model 5 under 
the same conditions. To better compare calculated rate of spread graphs for the two fuel models, you can set 
both graphs to have the same Y-axis scale.
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The following Run is for fuel model 10, which has relatively low rates of spread.

With the X Axis Origin and Y Axis Origin set to zero, the rate of spread graph below is produced:

To compare the results for fuel model 10 with the faster spreading fuel model 5, the scale for the fuel model 10 
Run is changed to match that produced by model 5. The calculated maximums are given for each of the selected 
output variables as a reference.

In the "Calculate Results" dialog box select the 
Specify graph Y axis limits check box if you 
wish to modify the Y-axis ranges of the output 
graphs before they are displayed.
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This displays the "Graph Limits" dialog box, where you can change the Y-axis maximum for the variable Rate of 
Spread (maximum) to 40:

The comparison with the corresponding graph for fuel model 5 is now more straightforward now that the axes 
are the same.



BehavePlus v4.0 User’s Guide  Graph output

USDA Forest Service General Technical Report RMRS-GTR-106WWW Revised. 2008 53

8.4. Graph appearance
The appearance of the graph can be 
changed through the Configure > 
Appearance > Graph Size and 
Configure > Appearance > Graph 
Elements tabs.

8.4.1. Graph Size
The vertical graph height on the page is set with the Graph Size(%) spin box on the 
Configure > Appearance > Graph Size tab.

Graphs are drawn starting at the upper left corner of the page and may occupy 25% to 
100% of the page height. The default is 50%, as shown in the following graph.
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Changing the Graph Size to 100% changes the above to the following graph:

8.4.2. Graph Title
The graph title content is controlled using the Graph Title drop-down list on the 
Configure > Appearance > Graph Size tab.

Selecting Short from the Graph Title drop-down list displays just the contents of 
the Worksheet Description text box as the title. Selecting Long displays the 
Description text box and the graph variables.
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Using the above Run a graph with a short title (the default) looks like the following.

Selecting Long from the 
Graph Title drop-down list 
on the Configure > 
Appearance > Graph Size 
tab adds more information to 
the title.
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8.4.3. Graph colors
Graph colors can be changed with the Configure > Appearance > Graph Elements tab.

Colors are selected from the predefined drop-down lists.

Background is the background color of the graph.

Rainbow Colors sets the number of colors used to display graph lines or bars when Rainbow Colors is 
selected as the curve color. With three rainbow colors, the colors are red, green, and blue. If 4 colors are 
requested, four equally spaced hues from the color spectrum are used to display each graph line or bar in turn. 

Bar Color is used to fill graph bars. Selecting Rainbow Colors fills each bar with its own color. The number of 
rainbow colors is set by the Rainbow Colors spin box discussed above. 

Curve Color is used to draw graph lines. Selecting Rainbow Colors draws each line with its own color. The 
number of rainbow colors is set by the Rainbow Colors spin box discussed above. 

Axis Color is used to draw graph axis lines, tic marks, and axis labels. 

Gridline Color is for the graph grid lines. The default is yellow.
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Changing Rainbow Colors to 10 results in the following graph coloring:

8.4.4. Line widths
Line widths can be changed using the Curve Width, Axis Width, and 
Gridline Width spin boxes on the Configure > Appearance > Graph 
Elements tab.

Curve Width sets the width of graph lines. 0 is the thinnest and 9 thickest.

Axis Width sets the width of axis lines drawn on the graph. 1 is thinnest and 9 
thickest.

Gridline Width sets the width of grid lines drawn on the graph. 1 is thinnest 
and 9 thickest. To prevent the display of any grid lines set Gridline Width to 
0.
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The following graph uses the default line settings.

8.5. Number of curve points
The resolution of the curves can be changed with the Curve Points spin box 
on the Configure > Appearance > Graph Elements tab.

The Curve Points spin box determines the number of points calculated for 
each curve in the graph. A straight-line segment is drawn between each pair of 
points. The default is 100 points. In cases where many curves are plotted and 
the calculation time is slow, reducing the number of curve points will speed 
things up.
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9. Diagram output
In addition to the usual table and graph output, BehavePlus produces 
diagrams for the following output variables. 

• Wind/slope/fire spread direction diagrams from the SURFACE module

• Fire characteristics chart from the SURFACE module

• Shape of a point source fire from the SIZE module

• Shape of a fire after suppression action from the CONTAIN module

Diagram output is selected from the lists on the Configure > Module selection > (module name) > 
Options… > Outputs tab for the corresponding module.

9.1. Wind/slope/spread direction
Direction diagrams can help the user avoid confusion on directions for wind, slope, and spread directions. 
Direction input options are selected on the Configure > Module selection > SURFACE > Options… > 
Directions tab.

Direction diagrams are produced with the Configure > Module selection > SURFACE > Options… > 
Basic Outputs tab and selecting the Wind/Slope/Spread Direction Diagram check box.

The diagrams differ according to the direction Input Options selected from the Configure > Module 
selection > SURFACE > Options… > Directions tab. The following shows the Input Option selection, 
the resulting Worksheet, the outputs table and diagrams.
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The following illustrates the effect of selecting the Wind & spread directions are radio button on the 
variables that are requested on the Worksheet.
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9.2. Fire characteristics chart
A fire characteristics chart diagram plots the relationship of rate of spread, heat per unit area, flame length, and 
fireline intensity. This option is a simplified plot and does not offer the user any display options. Axis scales are 
set automatically and points are labeled with simple numbers. In the future, BehavePlus will provide a Fire 
Characteristics Tool so that the user can customize it for a specific need.

Fire characteristics charts are produced with the Configure > Module selection > SURFACE > 
Options… > Basic Outputs tab and selecting the Fire Characteristics Chart check box.
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It is not necessary to select the four output variables that are plotted on the chart.

The following shows the Worksheet and resulting output table and Fire Characteristics Chart.
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The points labeled 1, 2, and 3 correspond to the three lines of the output table. Point 1 is for fuel model 2, 
point 2 for fuel model 5, and point 3 for fuel model 10.

In the case of two variables with multiple entry values a two-way table is produced:
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The numbers on the chart correspond to the table cells in left-to-right and top-to-bottom order. In this 
example, Points 1 and 2 are for the first row of the result table (3% moisture) at the two wind speeds (7 and 10 
mi/h). Points 3 and 4 are for the second row of the result table (6% moisture) at the two wind speeds. Points 5 
and 6 are for the third row of the result table (9% moisture) at the two wind speeds.

9.3. Shape of a point source fire
The elliptical shape of a point source fire can be plotted 
on the Configure > Module selection > SIZE > 
Options … > Output Variables tab by selecting the 
Fire Shape Diagram check box.

For example, the following shows the Worksheet, output table, and Fire Shape Diagram.
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In addition to the shape diagrams, values for all of the selected output variables are given on each diagram.

A word of caution when using the SIZE module by itself as shown by the above example. The above diagram 
could be wrongly interpreted to show that higher wind speeds result in a smaller fire. But remember the 
surface rate of spread (10 ch/h) was the same for 0 and 6 m.p.h. winds, which is not realistic if all other fire 
environment conditions were the same. In this example the wind speed only determines the shape of a fire for 
a given forward spread distance. 
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When the SIZE Module is linked to the SURFACE Module, the wind vector is also shown on the diagram.
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9.4. Containment shape
The Containment Diagram shows fire perimeter at time of report, at initial attack, and constructed fireline at 
the time the fire was successfully contained or when it escaped initial attack (all resources exhausted before 
containment). 

The Containment Diagram is displayed by 
selecting the Containment Diagram check 
box from the Configure > Module 
selection > CONTAIN > Options … > 
Output Variables tab. Also select the 
Contain Status check box to output 
whether the fire was Contained or Escaped 
on the Containment Diagram.
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10. View, print, & capture results
10.1. View size

The View > xx% command changes the size of your 
Worksheet and Run when viewed on screen. It does 
not affect the size of printed output.

10.2. Pages
While each Run has its own window, the window has one or more Pages. The first page(s) contain the 
Worksheet, and subsequent pages contain results tables, graphs, and diagrams.

You can navigate between pages using the following toolbar buttons:

 Go to the first page

 Go to the last page

 Go to the previous page

 Go to the next page

The keyboard navigation arrows will also move you from one page to the next. The Pages > command allows 
you to jump directly to a specific page. Selection can be made from the list of pages with text descriptions and 
an icon indicating whether it is a table, graph, diagram, etc.
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10.3. Windows
When a Worksheet is first opened, the Run it represents 
is assigned a default name such as "unnamed01.bpr", 
"unnamed02.bpr", etc. This name is displayed on the title 
bar at the top of the BehavePlus application window.

When you save a Run with the File > saveAs > Run command you should rename the Run. The name of the 
Run is then displayed in the title bar of the BehavePlus window. The complete path name for the Run is shown 
at the bottom of the BehavePlus application window.

BehavePlus allows you to have any number of Runs open 
at once. Each Run has its own display window containing a 
Worksheet and possibly containing calculation results. 
Only one Run window is active at a time. The Windows 
menu item allows you to switch between Runs. It also 
allows you to cascade or tile the Runs within the 
BehavePlus window area with the Windows > Cascade 
or Windows > Tile commands. By default the Run 
windows are stacked on top of each other, so you only see 

the active Run. If your Run windows are already cascaded or tiled, you can make a Run active by clicking it.

The following is a "tiled" display of the two Runs, one English, one metric. The English Run (unnamed01.bpr) is 
the active Run.
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10.4. Print
You can print all pages or selected pages with the File > Print command. Alternatively, select Print from the 
shortcut menu when you right click inside a page.

Whenever an output page is printed, it is good practice to print the associated input Worksheet pages to avoid 
confusion on conditions for the Run. Printed pages are numbered and the date and time of the Run are included 
on the page header.

10.5. Saving Output
You can save BehavePlus results in several ways. Each page can be saved as an image of the screen display using 
BehavePlus features. Another way is to use the Alt-Print Screen key stroke combination available on all personal 
computers. In addition, table output with associated input values can be exported to an HTML file, which can 
be viewed with a web browser or spreadsheet application.

10.5.1. Saving a screen image
The currently displayed page can be captured and saved as a file in bmp, jpg, or png format with the File > 
Save as an image command. In the "Save As" dialog box enter a file name in the Capture File text box and 
select a file type from the Capture Type drop-down list. The file extension will be automatically added to the 
file name

In addition to the File > Save as an image command, you can use the ALT-Print Screen keystroke 
combination or a screen capture utility (e.g. FullShot) to insert results from BehavePlus into other documents. 
This is a quick and efficient method. There is no need to save the image in a file of its own. The following steps 
are an example and do not constitute endorsement of specific software.

• Startup BehavePlus and Microsoft Word software

• Make BehavePlus the active window

• Use the Alt-Print Screen keystroke combination to copy the image of the BehavePlus window

• Make Microsoft Word the active window

• Paste the BehavePlus image into the Word document

• Select the BehavePlus image you just pasted into the WORD document

• Now you can use the Word picture tools to manipulate the BehavePlus image, you may need to display 
Word’s Picture Toolbar by selecting the View > Toolbars > Picture.

10.5.2. Saving an HTML File
Once you have calculated a Run you can save the Run as an HTML file. In addition to the table outputs the 
HTML file also contains the Input Variables and Run Option Notes sections of the Worksheet. Select the 
File > Export results command to open a standard Windows “Save As” dialog box. You can save this file 
anywhere, it does not have to be in a BehavePlus Workspace. The HTML file extension will be automatically 
added to your file name.
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Simply double-clicking your saved file will display your Run in your Web browser.

You can also open the HTML file with a spreadsheet application. The column widths may need to be changed to 
make the values readable. A useful technique is to copy the output table to another worksheet so the results 
can be reformatted or graphed as desired.
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11. Error checking
When you do something in error, the program will tell you what the 
problem is and give you a chance to fix it.

If you do something that causes the program to crash or freeze, it is a program bug.  First check the Known 
Bugs page at  www.firemodels.org. If you find the issue has not already been reported, please report it to the 
Help desk at (800) 253-5559 or (208) 387-5290, fire_help@fs.fed.us.

http://firemodels.org/
mailto:fire_help@fs.fed.us
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This page blank on purpose.
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12. Fuel models
A fuel model is a set of values that describe a fuel type for the surface fire 
spread model. There are 53 standard fire behavior fuel models. The original 
standard fuel models are numbered 1 through 13. An expanded set of 40 fuel models is also available. 
Additionally Custom Fuel Models, can be developed, tested, saved, used in BehavePlus, and exported for use in 
other applications.

12.1. 53 Standard fire behavior fuel models

The original 13 standard fuel models are always available by using the Fuel Model Input Guide  Button or 
entering the fuel model code directly into the text box from the keyboard. A complete description of the 13 
standard fuel models is found in the publication Aids to Determining Fuel Models For Estimating Fire Behavior. 
Gen. Tech. Rep. INT-122. Anderson, 1982. These fuel models are found at the top of the list in the Fuel Model 
“Input Guide” dialog box.

The expanded set of 40 fuel models is also always available in BehavePlus. These fuel models are also selected 
from the Fuel Model Input Guide or entered directly in the Fuel Model text box on the Worksheet. They 
are listed after the original 13 in the “Input Guide” dialog box, but they use an alpha-numeric code rather than 
a number for the value on the Worksheet.
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Notice that the expanded models are identified as dynamic or static with a (D) or (S) in the description. See 
Section 12.4 below for more on dynamic fuel models. Example Runs (e.g. FuelCompare.bpr) can be found in the 
ExampleRuns folder to explore the expanded fuel model set and see the effect of dynamic fuel models. A full 
description of the 40 fuel models is found in Scott and Burgan (2005).

12.2. Palmetto-Gallberry special case fuel model
The Palmetto-Gallberry fuel model is not selected from the “Input 
Guide” dialog box like the standard fuel models, but is selected with 
the Special case fuel model, palmetto-gallberry radio 
button on the Configure > Module selection > SURFACE > 
Options… > Fuel & Moisture tab.

The palmetto-gallberry fuel model estimates fuel parameters from vegetation characteristics (Hough and Albini 
1978). Selecting the Special case fuel model, palmetto-gallberry radio button adds different input 
variables to the “Fuel/Vegetation, Surface/Understory” section of the Worksheet.

Fuel parameters are calculated and available for display as output variables 
by selecting them on the Configure > Module selection > 
SURFACE > Options… > P-G Outputs tab.
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12.3. Western Aspen special case fuel model
Like the palmetto-gallberry fuel model, the western aspen fuel 
model is selected with the Special case fuel model, western 
aspen radio button on the Configure > Module selection > 
SURFACE > Options… > Fuel & Moisture tab.

Selecting the special case western aspen fuel model adds additional items to the to the “Fuel/Vegetation, 
Surface/Understory” section of the Worksheet.

The western aspen fuel model estimates fuel parameters from vegetation characteristics (Brown and 
Simmerman 1986).

In addition tree morality is calculated in this model. It is not in the MORTALITY module, because a different 
mathematical model is used for this tree species.

12.4. Dynamic fuel models
Dynamic load transfer of herbaceous fuel is available in BehavePlus. If the Fuel Model Type is identified as 
dynamic, then fuel load is transferred from herbaceous live to dead herbaceous fuel as a function of the Live 
Herbaceous Moisture value entered on the Worksheet. Dynamic fuel models must have a live herbaceous 
fuel load while static fuel models may or may not have a live herbaceous fuel load.
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The original 13 standard fuel models are all static. Seventeen of the expanded 40 standard fuel models are 
dynamic. The dynamic fuel models are identified by a (D) at the end of their description and a Fuel Model Type 
parameter of D.

Additional output variables are available to help uses understand 
dynamic fuel models. The following variables can be selected from 
the Configure > Module selection > SURFACE > 
Options… > Fuel Outputs tab. A full explanation of dynamic 
fuel models is found in Scott and Burgan (2005).

BehavePlus offers the option of user specification of curing level 
(fuel load transfer portion) rather than using the value calculated 
from live herbaceous fuel moisture. This output option is selected 
with the input directly radio button on the Configure > 
Module selection > SURFACE > Options… > Fuel 
&Moisture tab.

An additional input field is added to the “Fuel/Vegetation, Surface/Understory” section of the Worksheet.

12.5. Custom fuel models
In addition to the standard fuel models you can create, save, and reuse custom fuel models in BehavePlus. These 
custom fuel models can be exported in a file format used by FARSITE, NEXUS, and FlamMap.
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12.5.1. Defining and saving custom fuel models
The first step in creating a custom fuel model is to change the Worksheet so that individual fuel parameters are 
entered in place of the fuel model code. Use the Configure > Module selection > SURFACE > 
Options… > Fuel and moisture tab and select the fuel parameters. radio button.

Or you can load the Example Worksheet FuelModeling.bpw, which as been set up to use fuel parameters, using 
the File > Open worksheet command or  toolbar button.

Fuel model parameters can be typed directly into the parameter text boxes. Or they can be initiated with an 
existing fuel model by clicking the Initialize from a Fuel Model button on the Worksheet.

The process of developing a custom fuel model is more complex that just filling in these blanks. It involves a 
process of evaluation and revision which is not covered in this User’s Guide. 
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Once the fuel model parameters are defined, a custom fuel model can be saved for later use with the File > 
saveAs > Fuel model > BehavePlus format command. In the "Save As" dialog box enter a file name in 
the Fuel Model File text box and a short description in the Fuel Model Description text box. If more 
than one value is assigned to a fuel model parameter for testing purposes, the first value in the list is the one 
that is saved.

Fuel models should be grouped in folders named by some logical association of meaning to the user. See Section 
17.4, Save As…, for more information.

12.5.2. Using previously saved custom fuel models
In order to use previously saved custom fuel models, the folder in which they are stored must be attached using 
the Configure > Fuel model set selection command.

Click on a folder's  button to view its fuel 
model files. Each fuel model is stored in a 
separate file.

Fuel model files are available by attaching the 
folder in which they reside. This makes the 
fuel models in that folder accessible for use. It 
is not possible to select and attach individual 
fuel models; the entire folder must be 
attached. For example, all the southern 
California fuel models are attached by 
selecting the SoCalifornia folder in the 
“Fuel Model” dialog box and clicking the Ok 
button. Once a fuel model folder is attached, 

the fuel models appear in the Fuel Model input guide and may be entered as the Fuel Model input variable.

After the SoCalifornia fuel model folder is attached, the 
Fuel Model input Guide  Button gives the following 
valid selections for the Fuel Model text box.

To view the parameters of a particular fuel model, right-
click on its name and select the View parameters 
command from the shortcut menu.
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When viewed in the “Fuel Model” dialog box (opened with the Configure > Fuel model set selection 
command), folders and files with a paper clip icon are currently attached to (i.e., accessible for use by) 
BehavePlus in the current session. Once the Ok button is pressed, only the currently selected folders will have 
their files attached. Unselected folders will NOT have their files attached, even if they are currently marked as 
attached by the paper clip icons. 

Custom fuel models are selected just like the standard models. They can be selected with the Fuel Model input 
guide or entering the fuel model code directly into the text box from the keyboard.
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12.5.3. Exporting custom fuel models
Custom fuel models you create and save in BehavePlus can be exported in the Custom Fuel Model (.fmd) file 
format used by FARSITE, NEXUS, and FlamMap. To avoid confusion, remember the distinction between saving 
and exporting custom fuel models; saving a fuel model lets you reuse it only in another BehavePlus session, 
while exported fuel models can only be used in an application that uses the Custom Fuel Model (.fmd) file 
format. Files with a .fmd extension cannot be used in BehavePlus and .bpf files cannot be used in FARSITE, 
NEXUS, or FlamMap.

Before you can export a BehavePlus custom fuel model it must be saved and attached. See Sections 12.5.2 and 
12.5.1 above for information on saving and attaching custom fuel models.

To export a custom fuel model use the File > saveAs > 
Fuel model > FARSITE format command. In the “Fuel 
Model Export Selection” dialog box the attached custom 
fuel models are found at the end of the standard fuel 
models list.

For custom fuel models both the Sort and Code columns 
in the list display the file name truncated to five characters. 
You select one or more fuel models to export and then 
click the Ok button. Type the filename in the “Save As” 
dialog box and BehavePlus will automatically attach a .fmd 
extension.

The exported .fmd file will look similar to this when viewed in a text editor.

The first field for each fuel model is the fuel model number. Exported fuel models begin with number 14 and 
continue to 90 if you elect to export that many fuel models. If these fuel model numbers do not match the 
landscape file in FARSITE or FlamMap you should change these to match by editing the exported .fmd file. You 
may also want to edit the second field, the fuel model code. The default that is exported is the first five 
characters of the BehavePlus .bpf filename.
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13. Moisture scenarios
A moisture scenario is a set of fuel moistures for 1-h, 10-h, and 100-h dead 
fuel and herbaceous and woody live fuel. It is analogous to the fuel model 
concept in that a single code represents a set of live and dead fuel moisture values. Fuel moisture scenarios may 
be developed, for example, to represent local 90-, 95-, and 97-percentile weather situations. The set of 
moisture scenarios used in the old BEHAVE TSTMDL fuel modeling program and the set used to test the 40 
standard fuel models are provided with the BehavePlus program.

Fuel model scenarios are for developing and comparing fuel models. They are not designed for fire behavior 
prediction, in which case actual fuel moisture values should be assigned directly.

13.1. Using previously saved moisture scenarios
In order to use previously saved moisture scenarios, the folder in which they are stored must be attached. A 
folder of moisture scenarios is attached using the Configure > moisture scenario set selection 
command to open the "Moisture Scenarios" dialog box.

Click on a folder's  to view its moisture scenario files. Each moisture scenario is stored in a separate file. The 
details of a moisture scenario can be viewed or printed by right-clicking and selecting the appropriate command 
from the shortcut menu.

Moisture scenario files are attached by selecting the folder in which they reside and clicking the Ok button in 
the “Moisture Scenario” dialog box. This makes all the moisture scenarios in that folder accessible for use. It is 
not possible to select and attach individual moisture scenarios; the entire folder must be attached. For example, 
one set of the moisture scenarios that come with the BehavePlus program are attached by selecting the 
FuelModeling folder. Once a moisture scenario folder is attached, its moisture scenarios appear in the 
Moisture Scenario input guide.

Worksheet options also need to be set to use moisture scenarios. Set up the Worksheet to enter fuel 
moistures with moisture scenarios using the Configure > Module selection > SURFACE > Options… > 
Fuel & Moisture tab and select the Moisture is entered by moisture scenario. radio button.
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After the FuelModeling moisture scenario folder is attached, the Moisture Scenario Guide  button on 
the Worksheet shows the following valid selections for moisture scenarios in the “Input Guide” dialog box.

To view the parameters of a particular moisture scenario, right-click on the description and select View 
parameters from the shortcut men.

When viewing folders (and files) in the "Moisture Scenario" dialog box, those scenarios with a paper clip icon 
are currently attached to (e.g., accessible for use by) the BehavePlus application. Once the Ok button is 
pressed, only the selected folders will have their files attached. Currently attached folders will NOT have their 
files attached if not selected when the Ok button is clicked. Use the Cancel button to maintain the current 
attached sets. 
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This Worksheet creates the following graph. The fuel model used is a dynamic type, and the output graph 
indicates the dramatic effect the live fuel moisture can have when using a dynamic fuel model.

13.2. Defining and saving moisture scenarios
To define a Moisture Scenario first set the Worksheet to require individual fuel moisture values by selecting 
individual size class in the Configure > Module selection > SURFACE > Options… > Fuel & 
Moisture tab.
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Enter values for each size class on the Worksheet, even if that item is shaded. Other input text boxes don't 
matter.

Save the moisture scenario with the File > saveAs > Moisture scenario command. In the "Save As" dialog 
box enter a file name in the Moisture Scenario File text box and a short description in the Moisture 
Scenario Description text box. See Section 18.4, Save As…, for more information on saving moisture 
scenarios.
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14. Map applications
BehavePlus allows the calculation of slope steepness from map 
measurements and conversion of distances to map measurements.

Map scale is given as map representative fraction, which is the ratio of the number of units on the map between 
two points to the distance on the ground between the same two points. For example, if the map representative 
fraction is 1:24,000, then for each inch on the map there are 24,000 inches on the ground.

Although any value can be entered, the "Input Guide" dialog box provides common map scales, available by 
clicking the Choices button.

14.1. Slope from map measurements
To set up a Worksheet to calculate slope steepness from measurements on a topographic map use the 
Configure > Module selection > SURFACE > Options… > Slope tab and select the Slope 
steepness is calculated from map measurements radio button.
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You can add the calculated slope steepness and intermediate values to the output list with the Configure > 
Module selection > SURFACE > Options… > Outputs tab. Select any or all of the Slope Steepness, 
Slope Elevation Change, or Slope Horizontal Distance check boxes.

The Worksheet then includes a Map section with text boxes for data.
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The contour interval is the difference in elevation between adjacent topographic contours on a topographic 
map.

The map distance is the distance between two points on a map generally expressed in inches or centimeters.

Number of contour intervals is a count between two points on a map.

If only slope values are requested as output, then only Map input variables are requested.

14.2. Map distances
To specify that output calculated distances should also be given in map units use the Configure > Module 
selection command and select the Display output distances in map units check box below the list of 
modules.

When a distance is calculated in SURFACE, SIZE, or SPOT and the Display output distances in map 
units check box is selected, a Map Representative Fraction (1:x) text box is added to the Worksheet 
and map distances are added to the list of output variables.
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For example, when the Spread Distance check box is selected in the Configure > Module selection > 
SURFACE > Options… > Outputs tab the following Worksheet results:
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15. Units and Decimals
Default units for BehavePlus are English for use in the United States. It is 
easy to change all units to metric using the Configure > Units set 
selection > Metric command.

If a user wishes to use something other than the units we have selected for English or metric, a custom set of 
units can be defined and saved for later use. 

The Units set also defines the number of decimal places displayed for each variable. 

Note that whenever a Worksheet or Run is saved, its current units of measure and display decimals are saved 
with it. The next time you open the Worksheet or Run, the units and decimal settings are restored.

BehavePlus also provides a quick units conversion tool accessed with the Tools > Units converter 
command.

15.1. English or metric
The units set can be changed using the Configure > Units set selection > English or Metric or 
Custom commands. 

Immediately upon change, the units on the active Worksheet and all values that have been entered are changed.

Because units are stored with a Worksheet or Run, if units are changed to metric and then another Worksheet 
is loaded from the ExamplesWorksheets folder, with the File > Open worksheet command, the new 
Worksheet will use English units.

15.2. Custom units set
Develop and save a custom units set using the “Units Editor” dialog box opened with the Configure > 
Custom units preferences command.

The “Units Editor” dialog box controls the selection of units of measure and decimal places for the input, 
display, and output of variables. The selected units are then applied to the current Worksheet and can be saved 
as a custom units set. 

The units of measure initially displayed by the dialog are those in use for the current Worksheet. 

Select the desired units for each variable set. Rather than repetitiously having to enter units for every variable, 
they are grouped by type of unit of measure. The help window lists the groupings.

Once you have defined and saved a custom units set, you can apply it to a Worksheet or Run with the 
Configure > Units set selection > Custom command that opens the “Select A Units Set” dialog box.

15.3. Number of decimal places
In addition to setting units of measure, the “Units Editor” dialog box also allows you to change the number of 
digits displayed after the decimal place of all input and output variables.
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For example, the variable Fire Area has 1 decimal place as the default. You may want to round area to the 
nearest acre by changing the number of decimals to 0.
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16. Tools
BehavePlus tools are stand-alone utilities. They are not linked with any 
other modules or calculations.

16.1. Fine Dead Fuel Moisture
This tool is an automation of only the daytime tables from Rothermel (1983). Since these tables are not based 
on equations, they can't effectively be linked to any other tools or modules in BehavePlus.

The "Fine Dead Fuel Moisture Tool" dialog box can be accessed with the Tools > Fine dead fuel moisture 
command.

Inputs are made through the drop down lists. As soon as a change is made, the results are displayed.

You can save fine dead fuel moisture inputs and results as a HTML file by clicking the Export button. The 
Description text box at the bottom of the input section allows you to describe a header for the saved results.

When the Export button is clicked, a “Exported Results” dialog box appears.

You may navigate to any drive or directory and select an existing file or specify a new file name. The default 
location for exporting is the ExportFolder. If you haven’t already done so, you should think about your file 
management and design a structure for you project. (see Chapter 17: File Management)
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If you select an existing file, a popup will ask you to confirm overwriting the existing file. If you specify a new file 
without a “.html” or “.htm” extension, a “.html” extension is automatically added. The contents of the “Fine 
Dead Fuel Moisture Tool” dialog box are then written to the file in HTML format.

You may view the results using any web browser such as FireFox, Mozilla, or Internet Explorer. You may also 
attach the file to E-mail, or post it to a web site. You can open the exported HTML file with a spreadsheet 
application.

16.2. Relative Humidity
The “Relative Humidity” dialog box is opened with the Tools > Relative Humidity command.

The “Relative Humidity” dialog box provides three ways to calculate relative humidity depending on available 
inputs, a tab for each method. 

• All three methods require Dry Bulb Temperature as an input.

• The first tab utilizes a Wet Bulb Temperature input, the Dry Temp, Wet Depress, & Elev tab uses the 
Wet Bulb Depression (the difference between Wet and Dry Bulb Temperatures), and the third tab uses the 
Dew Point Temperature.

• The first and second tabs also require the Elevation of the temperature observations.
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On all three tabs the spin boxes are used to enter the required inputs. The plain text boxes display the outputs 
and immediately change with input changes.

Remember the RH Tool is a stand alone utility, it does not link to any other tools or modules.

16.3. Units Converter Tool
For all those times when somebody gives you an observed spread rate in furlongs/fortnight or you just need to 
know what the temperature is at that Canadian RAWS station just across the border, BehavePlus has a utility 
you can reach with the Tools > Units converter command.

In the “Units Conversion Tool” dialog box enter your known observation into the From Amount and From 
Units text boxes (12.3 meters per second in the above example). Then enter the desired units in the Into 
Units text box and click the Convert button to get your results (27.5143 miles per hour in the above 
example).

In the “Help” pane of the “Units Conversion Tool” dialog box there is a list of all the available units.

16.4. Slope vs horizontal map distance
The “Slope vs Horizontal Distance Tool” dialog box is opened by selecting the Tools > Slope vs horizontal 
map distance command.

When you select the Display output distances in map units check box from the “Module Selection” 
dialog box, map distance is found by multiplying slope distance by map scale. This is not technically correct. But 
because of the many variables that exist in the real world, the difference between slope distance and horizontal 
distance is not critical. This tool allows you to do the conversion in case you want to make the correction 
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before you plot the distance on a map. Rather than ask the user to input the direction with respect to the 
direction of steepest slope, several common options are calculated.

16.5. Sun-Moon Calendar
The "Sun-Moon Calendar" dialog box is opened with the Tools > Sun-moon calendar command.

The Location tab allows you to specify any month of any year at a location on the globe. The tool also 
includes a large database of named places within the United States so you can select a location by name rather 
than by coordinates.
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The Contents tab lets you select the outputs you need.

You can generate sun-rise, sun-set, civil dawn, civil dusk, moon-rise, and moon-set times in table or calendar 
format. It can also display a table of equinox, solstice, and moon phases for the year.

Example table of sun-rise, sun-set, civil dawn, civil dusk, moon-rise, and moon-set times.
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                                                           This page blank on purpose.
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17. File management
17.1. Workspaces
BehavePlus has a proscribed file system structure; all files must be located in specific subdirectories. The parent 
directory of this file structure and all its subdirectories and files are collectively known as a Workspace.

A Workspace is a complete subdirectory tree containing all required BehavePlus files plus any additional 
Worksheet, Run, Fuel Model, Moisture Scenario, Units Set, or screen capture files saved by the user. A 
Workspace can correspond to a single BehavePlus project. Workspaces are created with either the File > 
Workspaces > New workspace or Clone current workspace commands.

When BehavePlus is first installed it has a single Workspace called "DefaultDataFolder". This is the default 
current Workspace every time BehavePlus is started.

We recommend you create a new Workspace using the File > Workspaces > New Workspace command 
for every BehavePlus project you're working on. A project can be a collection of fire behavior projections for a 
wildfire or a fuels analysis for an environmental impact statement. The new, “pristine” Workspace is 
automatically populated with all example Worksheets, example Runs, and standard and predefined custom fuel 
models just like the DefaultDataFolder Workspace.

Alternatively, you may clone an existing Workspace with the File > Workspaces > Clone current 
workspace command to copy all of the current Workspace into a new Workspace, including all Run, Units 
Sets, custom Fuel Models, and custom Moisture Scenarios.

The Workspace concept provides the following benefits:

• All files pertaining to a specific training class, fire situation, or other project are segregated into their own 
file structure.

• Workspaces are easily backed up or copied onto removable media using either the File > Workspaces 
> Clone current workspace command or Windows Explorer.

• BehavePlus has self-validation tests and informs you whenever it is missing required files.

• BehavePlus knows where to find all custom Fuel Models and Moisture Scenarios and include them in 
Guide Button dialog boxes.
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We recommend using a compression utility such as WinZip, PKZip, or gzip when E-mailing or moving a 
Workspace over the Internet as compression significantly reduces BehavePlus file sizes.

A list of three letter file extensions used by BehavePlus is shown in the following table. These extensions are 
automatically attached to the files you create in BehavePlus.

17.2. Load a Worksheet
A previously saved Worksheet is loaded with the File > Open worksheet command, which opens the 
“Select a Worksheet” dialog box.

The Worksheet is 'blank' in that none of the input variables have been assigned values. But all of the associated 
options are still part of the Worksheet (e.g., graph appearance). 

17.3. Load a Run
A previously saved Run is loaded through File > Open Run command, which opens the “Select a Run” dialog 
box.

A Run is a Worksheet with valid values assigned to all input variables. Calculated values, tables, graphs, and 
diagrams are not saved. These are generated with the File > Calculate command.

17.4. Save as…
There are five File > saveAs… commands offering several choices of what to save from the active Worksheet 
or Run:

• File > Save as a worksheet - When a Worksheet is saved, it is saved without any values assigned to 
input variables. The Worksheet can be opened at a later time using the File > Open worksheet com-

mand or the  toolbar button. 

• File > Save as a run - A Run can be saved only if all valid values have been assigned to all variables on 

the Worksheet. The Run can be opened at a later time using the File > Open run command or the  
toolbar button.

• File > Save as a fuel model - Fuel models can be saved in either BehavePlus or the FARSITE Custom 
Fuel Model (.fmd) format. Before saving a fuel model make sure the SURFACE module check box is 
selected and the fuel parameters check box is selected in the Fuel is entered as section of the 

File extension File type Folder

.bpf Custom fuel models FuelModelFolder

.bpm Moisture scenarios MoistureScenarioFolder

.bpw Worksheets WorksheetFolder

.bpr Runs RunFolder

.bpu Custom Units Sets UnitsSetFolder

.exe Executable program file BehavePlus

.png Portable network graphic image format MyScreenCaptures

.bmp Bitmap graphic image format MyScreenCaptures

.jpg JPEG graphic image format MyScreenCaptures

.xml Extensible Markup Language Various places
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SURFACE > Options… > Fuel & Moisture tab. Valid values must be assigned to each fuel model 
parameter. Also make sure the Fuel Model Type parameter is correct, dynamic (D) fuel models must 
have a live herbaceous fuel load. (see Section 12.4) To use custom fuel models at a later time they must be 
attached with the Configure > Fuel model set selection command. (see Section 12.5.2)

• File > Save as a moisture scenario - Before saving a moisture scenario make sure the SURFACE 
module is selected and the individual size class check box is selected in the Moisture is entered 
by section of the SURFACE > Options… > Fuel & Moisture tab. Valid values must be assigned to 
each size class, even those that are shaded. To make a moisture scenario available use the Configure > 
moisture scenario set selection command. (See Section 13.2)

• File > Save as an image - Images of table, graph, and diagram screens can all be saved as an image file. 
The image file can then be edited with an image processor or inserted into word processor or layout doc-
uments. (See Section 10.5.1)

The following example saves a Worksheet. The process is similar for other file types. The File > Save as a 
worksheet command requests input of folder name, file name, file description, or file type in the “Save As” 
dialog box.

In this case, the Worksheet Folder text box is initially set to MyWorksheets. To create a new folder, simply 
type a new name into the Worksheet Folder text box: TestFolder in the example below.
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You are asked to enter a Worksheet folder description. The folder description subsequently appears in the file 
selection dialog box as a reminder of its contents. The Worksheet description is initially set to whatever is in 
the Description text box on the Worksheet. When saving a Worksheet, you should assure that it describes 
the blank Worksheet, not the specific Run.

17.5. Deleting Files & Folders
Files and folders in a BehavePlus Workspace are deleted using Windows Explorer. However you should only 
delete files and folders you create, not any of the files and folders BehavePlus automatically creates for the 
Workspace.

17.6. Export Results
Table output can be saved as an HTML file using the File > Export Results command. The default location is 
the ExportFolder, but you can save results to any location.

The HTML file can be viewed with a web browser or used in a web page. It is a compact format to email 
BehavePlus outputs.

HTML files can be opened with a spreadsheet application such as Microsoft Excel. If tables are reformatted, 
plotted, or if additional analysis is done, save the your work in the spreadsheet file format.
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18. Help
The Help system is a primary feature of BehavePlus. The Users Guide and 
Variables paper are available from the menu bar, and all dialogs and wizards 
include a help browser pane. Input fields include a Guide  button for help in entering range inputs or selecting 
one or more discrete choices. 

18.1. Browser pane help
The right-hand pane of many BehavePlus dialog boxes is a help browser. These can be printed by right-clicking in 
the help window to display a shortcut menu and selecting the appropriate command.

It includes a description of input variables when the guide button associated with the variable on the Worksheet 
is clicked. It includes a description of output variables when the cursor is held over a variable name on the list 
of possible output variables for a MODULE, reached through Configure > Module selection > MODULE 
> Options… > Outputs tab.

For each variable, information includes a description of the variable and a table showing the modules that use it. 
Some variables have additional descriptions, diagrams, and tables.

18.2. Guide button

Help on entering a specific Worksheet variable is available by pressing the Guide  button next to each 
Worksheet entry field to activate an "Input Guide" dialog box containing a help browser pane and input 
assistance. For continuous variables, the dialog facilitates entry of a large number of inputs by specifying the 
minimum input value, maximum input value, and increment value.
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Additional values are sometimes displayed by clicking the Choices button where available in the "Input Guide" 
dialog box.

For discrete variables the dialog contains a list of all valid inputs from which the user may select values.

18.3. User's Guide
This User's Guide can either be printed or accessed interactively using a PDF viewer such as Adobe Acrobat 
Reader. It serves as the online help for operation of the BehavePlus application. It can be opened with the Help 
> User’s Guide command. When viewed with the Adobe Acrobat Reader, the contents at the left provide 
access to the section in question.

18.4. Variables paper
The Variables paper (Andrews 2008) can be either printed or accessed interactively using a PDF viewer such as 
Adobe Acrobat Reader. It includes descriptions of the many input and output variables in BehavePlus. It can be 
opened by selecting the Help > Variables command. When viewed on the computer screen, the contents at 
the left provide access to the section in question. There is also an alphabetical list of variables, a table of input 
variables, with the modules that use them, and a table of output variables available from each module. There are 
many hyperlinks in the document, which make it most valuable when viewed using a PDF viewer.
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Appendix: Version Comparison

Summary of changes from the old BEHAVE through each version of BehavePlus
The BEHAVE fire behavior prediction and fuel modeling system was first available to the field in 1984. JFSP 
funded a much-needed redesign and update to the BehavePlus fire modeling system version 1.0, which was 
released in 2002. Version 2.0 was released in 2003, Version 3.0 in 2005, and Version 4.0 in 2008. Each version 
update has offered additional features and fire modeling capabilities. The most significant changes are given here.

BehavePlus version 1 compared to the old BEHAVE 
The old BEHAVE fire behavior prediction and fuel modeling system is a set of five DOS programs, three of 
which were first available in 1984. The whole look and feel of the BehavePlus fire modeling system is different, 
using updated user interface technology. Following are some specific differences that will be of interest to users 
of the old BEHAVE system:

• BehavePlus is one program. The old BEHAVE was 5 programs (FIRE1, FIRE2, RXWINDOW, NEWMDL, 
TSTMDL). The separation was due to computer limitations at the time and an extended development 
period.

• BehavePlus gives the user control of input options that were fixed on the old BEHAVE. For example, the 
BehavePlus SURFACE module allows users to specify the method of entry for fuel moisture, wind speed, 
and directions. In the old BEHAVE:

- The DIRECT module required direct input of fuel moisture by size class, midflame wind speed, and 
direction of wind and spread with respect to upslope.

- The SITE module calculated fine fuel moisture and requested input of 20-ft wind speed, exposure to 
the wind, and direction of wind and spread.

- The DISPATCH module requested dead and live fuel moisture, 20-ft wind speed and wind adjustment 
factor. Calculations were for upslope spread with the wind.

- In the TSTMDL program, fuel moisture was specified by category.

• In BEHAVE only continuous variables could be assigned more than one value for a maximum of 7 values. 
For example, wind speed could be assigned a range of values, but fuel model could not. BehavePlus allows 
multiple input values for every variable and there is essentially no limit to the number of values. Table 
output is carried over to multiple pages if necessary.

• BehavePlus produces graphs and diagrams as well as tables. The primary output of the old BEHAVE was 
tables. Crude graphs were produced using characters.

• The fuel modeling portion of the old BEHAVE consisted of the NEWMDL and TSTMDL programs. The 
features in NEWMDL are not in BehavePlus. The TSTMDL fuel model testing methods are in BehavePlus.

• BehavePlus does not include the fine dead fuel moisture model in MOISTURE and SITE modules in the 
FIRE2 program of BEHAVE. A better moisture model based on hourly weather data has been developed 
and is used in FARSITE and is being incorporated into the National Fire Danger Rating System (NFDRS) 
and the FireFamily Plus program. Eventually it will be available for fire behavior calculations in BehavePlus. 
BehavePlus offers the fuel moisture tables as a tool.

• The CONTAIN module of BehavePlus is different from that used in BEHAVE. The old model had a 
mathematical problem that occasionally surfaced. BehavePlus uses a model by Fried and Fried (1996) that 
offers the application of multiple resources with various productivity rates and arrival times, and direct or 
parallel attack at either the fire head or rear. BehavePlus does not offer the option of reverse calculation 
that was in the old BEHAVE (i.e. given a final fire size, what is the required line production rate).

• The RxWindow program is not and will not be part of BehavePlus. Reverse calculation becomes more 
difficult (essentially impossible) as models are added. The plan is to provide a new method of table shading 
to aid in prescribed fire planning.
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• The equations in the MORTALITY module in BehavePlus have been updated to match those of FOFEM. 
Many new tree species have been added.

• BehavePlus lists input values by category (Fuel/Vegetation, Weather, …) rather than by module (DIRECT, 
SIZE, …) as was done in the old BEHAVE.

• In BehavePlus users select the output variables to be displayed. In BEHAVE the output list was fixed.

• Map distance calculation was a stand-alone feature in BEHAVE. It is integrated into BehavePlus.

• BEHAVE asked users whether they were using a computer with a screen. The program could be run in 
either WORDY or TERSE mode. BehavePlus assumes that it is being run on a 21st century personal 
computer.

BehavePlus version 2 compared to version 1
• Safety zone size model is added as a new SAFETY module.

• Containment model is added as a new CONTAIN module. This is a new model that allows multiple 
resources to make direct or parallel attack.

• Probability of ignition by lightning model is added to the IGNITE module.

• Three methods of weighting two fuel models for rate of spread calculations is added to the SURFACE 
module.

• Dynamic palmetto-gallberry fuel model (Hough and Albini 1978) is added to the SURFACE module.

• Size diagram output is added to SIZE.

• Contain diagram output is in CONTAIN.

• Direction diagram is added to SURFACE.

• Fire characteristics chart diagram output is added to SURFACE.

• Fine dead fuel moisture is added as a new tool.

• A Run Option section is added to the worksheets for clarification.

• The contents of the Notes section on example worksheets is blank. The description of the worksheet 
that was there for version 1 is not necessary, especially with the addition of the Run Options section.

• The 'Standard' worksheet folder that was supplied with version 1 of the program is called the 
ExampleWorksheets folder in version 2 to better reflect what it is. The worksheets in that folder are just 
some that the developers put together. The term 'standard' gave them significance that they didn't deserve.

• The Blank.bpw Worksheet that was in version 1 is called the 0Startup.bpw Worksheet in version 2 to 
better reflect what it is, the worksheet to use as a startup in selecting calculation modules. (The '0' as a first 
character of the file name puts it as the first item on the list for easy selection.)

• The program now automatically loads the 0Startup.bpw worksheet upon initiation. This saves some steps 
if the worksheet is set up by module selection. If a previously saved worksheet is desired, it is selected and 
loaded as before with File > New.

• The Fuel model guide button gives you access to the photographs and descriptions in Anderson (1982) 
"Aids to selecting fuel models" and to the selection key in Rothermel (1983) "How to predict the spread 
and intensity of forest and range fires".

• The Program Help and the Users Guide for version 1 have been replaced by a single, new document-a 
users guide in PDF format that can be both printed and accessed online for specific help.

• A Language option has been added. Portuguese is provided as an example.

• Additional Workspace options aid in file management.

• Graph y-axes are now user-scalable.

BehavePlus version 3 compared to version 2
• A new CROWN module to calculate transition to crown fire and crown fire spread rate is added.

• Calculation of wind adjustment factor (WAF) for fuel sheltered by overstory trees is added to SURFACE.
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• Table shading according to user-specified ranges of acceptable conditions for prescribed fire planning is 
available.

• A CONTAIN option is added for single resource dispatch so tables and graphs can be produced for 
ranges of line construction rate, etc.

• The ability to export table output to a spreadsheet for further analysis or custom display is available.

• RH module is replaced by an RH tool.

• The step function from the calculation of probability of ignition by a firebrand is resolved and removed.

• Forty new surface fuel models, some with dynamic herbaceous live-to-dead fuel load transfer as a 
function of live fuel moisture are available in SURFACE.

• A new moisture scenario set (named "FuelModeling") that was used to develop the new fuel models is 
added.

• Custom fuel models can be exported in the file format required by FARSITE, FlamMap, and NEXUS.

• When the program starts up, a new BasicStart.bpw example worksheet is automatically loaded.

• Module names are included on the Output Variables and Run Options lists for added clarity.

• The Fuel/Vegetation worksheet section has been split into Surface/Understory and Overstory 
sections.

• The Worksheet tab on the “Appearance Options” dialog box has a new option Show descriptions 
only for entered variable codes as well as the Show descriptions for all discrete variable 
codes. The new option is the default for example worksheets.

• A SurfaceCrown.bpw worksheet has been added to the set of example worksheets.

• An updated User's Guide reflects operational changes. An index has been added.

• In-program help screens are updated with variable definitions and explanations.

• Tutorials 1- 4 are updated and reorganized.

• New tutorials focus on new modeling capabilities.

BehavePlus version 4 compared to version 3
• The User's Guide is updated to reflect operational changes.

• A new Variables paper includes variable descriptions from the help windows and input/output tables 
(Andrews 2008). The PDF document is available through the help system and includes many internal 
linkages to make it a useful reference guide.

• As part of a JFSP funded project, the tutorials were updated, new lessons are available, and a plan for 
future training material development was prepared.

• The BehavePlus program and supporting material has been moved to a new web site: 
www.firemodels.org, for fire behavior and fire danger software.

• Photographs and values for canopy cover, stand height, canopy bulk density, and canopy base height are 
available in help windows. The information is taken from Scott and Reinhardt (2005) “Stereo photo guide 
for estimating fuel characteristics in conifer stands.”

• The user has the option of identifying a worksheet to open at startup, rather than the BasicStart.bpw 
worksheet.

• A tool was added to calculate horizontal map distance from ground map distance and direction with 
respect to upslope.

• The option was added to not impose the maximum reliable wind speed limit for the Rothermel surface 
fire spread model. Spread rate increases with increasing wind speed rather than being constant for high 
wind speeds.

• The option was added to input curing level (fuel load transfer portion) for dynamic fuel models rather 
than calculating curing from live herbaceous fuel moisture.

• A special case fuel model was added for western aspen (Brown and Simmerman 1986).



BehavePlus v4.0 User’s Guide  

USDA Forest Service General Technical Report RMRS-GTR-106WWW Revised. 2008 111

• If bark thickness is a user input for the MORTALITY module, Mortality Equation (spruce or not-
spruce) is an input variable on the Worksheet. This clarifies that the 206 species available for mortality 
species is used only to calculate bark thickness.

• Additional output variables are available for SURFACE. Intermediate output values will aid 
understanding of the Rothermel surface fire spread model.

• Fuel model names were changed to specifically mention short and long needle litter and to clarify that the 
fuel models are for surface fuel, not for the overstory.

- 8 “Closed timber litter” to “Short needle litter”

- 9 “Hardwood litter” to “Long needle or hardwood litter”

- 10 “Timber with litter & understory” to “Timber litter & understory”

- TU4 “Dwarf conifer with understory” to “Dwarf conifer understory”

• Output variables were added to help understanding of calculated Wind Adjustment Factor: Crown fill 
portion and WAF calculation (sheltered or unsheltered).

• Crown fire area and perimeter output variables were added, using the equations in Rothermel (1991).

• “Conditional crown fire” was added as a “fire type”. In version 3 if Transition to crown fire? was “no”, 
then the fire type was “surface”, whether Active crown fire? was “yes” or “no”.

• Changes to the main menu are more logical. For example, File > New is now File > Open 
worksheet.

• File > saveAs > Results > Spreadsheet or Html is now File > Export  Results. In version 3, 
save as spreadsheet saved the output table without input values as a .txt file. In version 4, only html files are 
exported. These files can be viewed in a web browser, or they can be opened with spreadsheet software 
and then saved in spreadsheet format.

• An ExportFolder has been added as the default location for Export Results.

• For the option Table shading for acceptable fire conditions, the option is added to produce 
tables with blank cells rather than crossed out values. The option is available in Configure > 
Appearance preferences > Tables tab.

• Values entered in the “Fine dead fuel moisture” tool are remembered the next time the tool is used for 
the current session.

• Another option has been added for worksheet header lines, for prescribed fire planning.

• The Language option was eliminated. Portuguese was available in version 3, as an example of how a 
translated version of BehavePlus could be developed. Due to lack of interest, the option has been disabled 
for now.

• In version 3.0.2, the program sometimes ran slowly or not at all, particularly when installed in the default 
directory of C:/SEM. This has been fixed in version 4.0.
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custom fuel models 84
fine dead fuel moisture 95
HTML file 73, 95
spreadsheet 73
table output 73
text file 73

Export button 95
F
FARSITE 1, 84
file

Custom Fuel Model 84
HTML 73
image 73
spreadsheet 73
tab delimited text 73

file extensions 12, 102
bmp 73
bpf 84
fmd 84
html 73
jpg 73
png 73

file management 101

file structure 12, 101
Fine 95
Fine Dead Fuel Moisture Tool dialog box 95
fire characteristics chart 63
Fire Characteristics Chart check box 63
Fire projection documentation check box 17
fire shape diagram 66
Fire Shape Diagram check box 66
first page toolbar button 71
FlamMap 1, 84
fmd 84
folder

description 104
new 103

folders
delete 104

Fuel Model
dialog box 82
Input Guide 77, 82

Fuel Model Export Selection dialog box 84
fuel models 77

attaching custom sets 82
create custom 81
custom 80
definition 13
dynamic 79
expanded set 77
FARSITE format 84
palmetto-gallberry 78
parameters 81
Save as 102
save custom 81
set selection 82
standard 13 77
type 79

fuel moisture correction 95
fuel parameters 81
FuelModeling.bpw 81
G
Graph Elements tab 53
Graph Size tab 53
graphs 45

appearence 53
axis scales 48
colors 56
curve points 58
image 73
limits 52
line widths 57
title 54
two variable 46
X-axis 49
Y-axis 50
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Guide button 15, 31
definition 13

H
HTML file 73, 95
I
image 73
Initialize from a Fuel Model button 81
input codes 18
Input Guide dialog box 13, 31

Fuel Model 77, 82
Map Representative Fraction 89
Moisture Scenario 86

input section 17
input variables

entering 31
linked 34
multiple values 31, 32
ranges 31, 32

installation
Windows 11

invalid input 75
J
jpg 73
L
last page toolbar button 71
line widths

graphs 57
Linked input variables 34
live herbacous moisture 79
loading

custom fuel models 82
fuel models 77
moisture scenarios 85
Run 102
Worksheet 21, 102

M
map

applications 89
distances 91
representative fraction 89, 91
scale 89

Map Representative Fraction dialog box 89
Model

definition 13
Module Selection dialog box 23, 41
Modules 23

definition 13
input options 24
linking 23
output options 28

moisture scenario 85
attaching sets 85
define 87
save 88
Save as 103
using 85
viewing 86

moon-rise 98
moon-set 98
Mortality Module Options dialog box 24
N
new

folder 103
Workspace 101

next page toolbar button 71
NEXUS 84
notes section 20
number of curve points 58
O
Operation 7
Options button 23
output variables

tab 59, 63
output variables section 19
outputs

diagram - see diagram
graphs - see graphs
image 73
map distances 91
table shading 41
tables 35, 36, 43
two way tables 36
variables 28, 41

P
page buttons 71
page header section 16
page tabs 20
palmetto-gallberry 78
png 73
prescription window 41
previous page toolbar button 71
print 73
R
range of acceptable fire conditions 42
reference fuel moisture 95
Relative Humidity Tool dialog box 96
Run

definition 12
delete 104
load 102
Save as 102
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run option notes section 19
RXWINDOW 41
S
Save as 102

custom fuel model 82, 102
dialog box 103
HTML file 73, 95
image 73
images 103
moisture scenario 88, 103
results 103
Run 22, 102
spreadsheet 73
tab delimited file 73
Worksheet 22, 102

screen capture 73
sections - see Worksheet sections
Select a Run dialog box 102
Select A Units Set dialog box 93
Select a Worksheet dialog box 102
set selection

fuel models 77
moisture scenarios 85
units 93

Shade alternate table rows check box 38
Show description for all discrete variable codes
check box 18, 19
Show descriptions only for entered discrete variable
codes check box 18
size, window 71
slope

from map measurements 89
Slope Elevation Change check box 90
Slope Horizontal Distance check box 90
Slope Steepness check box 90
spreadsheet 73
standard fuel models 77
Startup Worksheet 22
steepness

from map measurements 89
sub-models

list 7, 10
Sun-Moon Calander Tool 98
sun-rise 98
sun-set 98
SurfaceBasicFrom.bpw 16
system requirements 11
T
tab delimited text file 73
table shading

for acceptable fire conditions 41
for readability 38

Table shading for acceptable fire conditions check
box 19, 41
Tables

appearance 38
multiple pages 38
output 35, 36
row shading 38
saving 73, 103

tabs
Directions 59
Gragh Size - see Graph Size tab
Graph Elements 53
Graph Size 53
Output variables 59, 63
Outputs 90
page 20

tiled display 72
time

civil dawn 98
civil dusk 98
moon-rise 98
moon-set 98
sun-rise 98
sun-set 98

title
graphs 54

toolbar button 14
first page 71
last page 71
next page 71
previous page 71

tools
Relative Humidity 95, 96
Sun-Moon Calendar 98

Training documentation check box 17
two variable graph 46
two way tables 36
U
units 93

custom set 93
decimal places 93
English 93
metric 93

Units Editor dialog box 93, 94
V
variables

input-see input variables
output-see output variables

view size 71
viewing

fuel model parameters 82
moisture scenario 86
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W
web browser 74
wet bulb depression 96
wet bulb temperature 96
Wind/Slope/Spread Direction Diagram check box
59
Window 72

cascade 72
size 71
tiled 72

Windows installation 11
Worksheet 15–22

borders 10
definition 12
delete 104
editing 22
example - see example Worksheets
extension 12
layout 15
load 21, 102
Map section 90
Save as 102
saving 22

size 71
startup 22

Worksheet sections 16
acceptable fire conditions 19
documentation 16
input 17
notes 20
output variables 19
page header 16
run option notes 19

Workspace 101
clone 101
definition 13
new 101

X
X-axis 49
X-axis origin 49
Y
Y-axis 50
Y-axis origin 49



  The Rocky Mountain Research Station develops scientific information 
and technology to improve management, protection, and use of the 
forests and rangelands. Research is designed to meet the needs of 
National Forest managers, Federal and State agencies, public and 
private organizations, academic institutions, industry, and individuals. 

Studies accelerate solutions to problems involving ecosystems, 
range, forests, water, recreation, fire, resource inventory, land 
reclamation, community sustainability, forest engineering technology, 
multiple use economics, wildlife and fish habitat, and forest insects 
and diseases. Studies are conducted cooperatively, and applications 
may be found worldwide.

Research Locations

Flagstaff, Arizona Reno, Nevada
Fort Collins, Colorado* Albuquerque, New Mexico
Boise, Idaho Rapid City, South Dakota
Moscow, Idaho Logan, Utah
Bozeman, Montana Ogden, Utah
Missoula, Montana Provo, Utah
Lincoln, Nebraska Laramie, Wyoming

*Station Headquarters, Natural Resources Research Center,
2150 Centre Avenue, Building A, Fort Collins, CO 80526

The U.S. Department of Agriculture (USDA) prohibits discrimination 
in all its programs and activities on the basis of race, color, national 
origin, sex, religion, age, disability, political beliefs, sexual orientation, 
or marital or family status. (Not all prohibited bases apply to all 
programs.) Persons with disabilities who require alternative means for 
communication of program information (Braille, large print, audiotape, 
etc.) should contact USDA’s TARGET Center at (202) 720-2600 (voice 
and TDD).

To file a complaint of discrimination, write USDA, Director, Office of 
Civil Rights, Room 326-W, Whitten Building, 1400 Independence 
Avenue, SW, Washington, DC 20250-9410 or call (202) 720-5964 
(voice or TDD). USDA is an equal opportunity provider and employer.


	Abstract
	Keywords
	The Authors
	Acknowledgments
	Cover Art
	Preface
	What’s New
	Table of Contents
	1. Introduction
	2. Operation
	2.1. Organization
	2.2. Design
	2.2.1. Page Oriented
	2.2.2. Highly Configurable
	2.2.3. Self Documenting
	2.2.4. User Manual and Help
	2.2.5. Not Boring
	2.2.6. Borders

	2.3. Features
	2.3.1. Fire Models
	2.3.2. Operation

	2.4. Installation
	2.4.1. Download
	2.4.2. System Requirements
	2.4.3. Windows Installation
	2.4.4. File Structure

	2.5. Definitions
	2.6. Menus and Toolbar

	3. Worksheets
	3.1. Worksheet layout
	3.2. Example Worksheets
	3.3. Worksheet Sections
	3.3.1. Page Header
	3.3.2. Documentation
	3.3.3. Input section
	3.3.4. Input codes
	3.3.5. Acceptable Fire Conditions
	3.3.6. Run Option Notes
	3.3.7. Output variables
	3.3.8. Notes
	3.3.9. Page Tabs

	3.4. Loading a previously saved Worksheet
	3.5. The 0Startup Worksheet
	3.6. Changing a Worksheet
	3.7. Saving a Worksheet or a Run
	3.8. Setting a Startup Worksheet

	4. Modules
	4.1. Input options
	4.1.1. Fuel & Moisture Tab
	4.1.2. Wind Speed Tab
	4.1.3. Directions Tab
	4.1.4. Slope Tab

	4.2. Output Variables

	5. Entering input
	5.1. Shaded text boxes
	5.2. Direct entry
	5.3. Input Guide
	5.3.1. Continuous variables
	5.3.2. Discrete variables
	5.3.3. Choices button

	5.4. Linked input variables

	6. Table output
	6.1. Single value calculation
	6.2. Table output
	6.3. Two way tables
	6.4. Table appearance
	6.5. Multiple pages

	7. Table Shading
	7.1. Activating the Table Shading Option
	7.2. Entering Acceptable Fire Conditions
	7.3. Viewing Results

	8. Graph output
	8.1. Single variable graph
	8.2. Two variable graph
	8.3. Axis scales
	8.3.1. X-axis
	8.3.2. Y-axis

	8.4. Graph appearance
	8.4.1. Graph Size
	8.4.2. Graph Title
	8.4.3. Graph colors
	8.4.4. Line widths

	8.5. Number of curve points

	9. Diagram output
	9.1. Wind/slope/spread direction
	9.2. Fire characteristics chart
	9.3. Shape of a point source fire
	9.4. Containment shape

	10. View, print, & capture results
	10.1. View size
	10.2. Pages
	10.3. Windows
	10.4. Print
	10.5. Saving Output
	10.5.1. Saving a screen image
	10.5.2. Saving an HTML File


	11. Error checking
	12. Fuel models
	12.1. 53 Standard fire behavior fuel models
	12.2. Palmetto-Gallberry special case fuel model
	12.3. Western Aspen special case fuel model
	12.4. Dynamic fuel models
	12.5. Custom fuel models
	12.5.1. Defining and saving custom fuel models
	12.5.2. Using previously saved custom fuel models
	12.5.3. Exporting custom fuel models


	13. Moisture scenarios
	13.1. Using previously saved moisture scenarios
	13.2. Defining and saving moisture scenarios

	14. Map applications
	14.1. Slope from map measurements
	14.2. Map distances

	15. Units and Decimals
	15.1. English or metric
	15.2. Custom units set
	15.3. Number of decimal places

	16. Tools
	16.1. Fine Dead Fuel Moisture
	16.2. Relative Humidity
	16.3. Units Converter Tool
	16.4. Slope vs horizontal map distance
	16.5. Sun-Moon Calendar

	17. File management
	17.1. Workspaces
	17.2. Load a Worksheet
	17.3. Load a Run
	17.4. Save as…
	17.5. Deleting Files & Folders
	17.6. Export Results

	18. Help
	18.1. Browser pane help
	18.2. Guide button
	18.3. User's Guide
	18.4. Variables paper

	References
	Appendix: Version Comparison
	Summary of changes from the old BEHAVE through each version of BehavePlus
	BehavePlus version 1 compared to the old BEHAVE
	BehavePlus version 2 compared to version 1
	BehavePlus version 3 compared to version 2
	BehavePlus version 4 compared to version 3

	Index
	A
	B
	C
	D
	E
	F
	G
	H
	I
	J
	L
	M
	N
	O
	P
	R
	S
	T
	U
	V
	W
	X
	Y


