
 
How to Create Stream Networks using DEM and TauDEM 

 

 

Take note: 
 
These procedures do not describe all steps.  Knowledge of ArcGIS, DEMs, and TauDEM 
is required.  TauDEM software ( http://hydrology.neng.usu.edu/tauDEM/ ) must be 
installed as an ArcGIS plugin module before proceeding. 
 
We used 4th code Hydrologic Unit Codes (HUCs) for this project.  The use of 
HUC17060208 and the path \Base_Layers\DEM\17060208\ referenced throughout 
these instructions is for illustration purposes only.  Use the HUC number and file path 
that is appropriate for your project.  Bolded text indicates the creation of a new file. 

 

 
 

Preliminary Steps 

• In ArcCatalog, create an ArcInfo Workspace.  For example: 
C:\WorkSpace\TroutProject\Base_Layers\DEM\17060208 

• In ArcMap, open a 4th code HUC layer that is in the Lat/Long projection and select the 
HUC.  Create a new layer of the selected HUC (i.e., export the selection).   

• Buffer the HUC boundary by 250m.  (To add the Buffer Wizard tool in ArcMap, 
Select from the toolbar: Tools > Customize > Commands > Tools > Buffer Wizard.  
Drag the Buffer Wizard tool to a toolbar.  Click Close.) 

• In ArcMap click the Buffer Wizard, choose the HUC > Next 
• select:  At a specified distance > 250 meters > Next 
• select:  Dissolve barriers between buffers? > Yes 
• select:  outside polygon(s) and include inside 
• select:  In a new layer… Save the shapefile to the correct path: 

\Base_Layers\17060208\Buffer_of_17060208.shp > Finish 
• Jot down the Lat/Long coordinates that lie just outside of the HUC boundary, as 

indicated by the red dots/lines (these coordinates will be used for downloading the 
DEM).  Round to the nearest minute.  Example:  

 
 
                45° 24´ 0 N 
 
 

 

         116° 0´ 0 W                115° 13´ 0 W 
 

 
           

          44° 27´ 0 N 
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http://hydrology.neng.usu.edu/taudem/


 

  
 

Step 1. Download the DEM 

Go to http://seamless.usgs.gov/website/seamless/viewer.htm to download 30m DEM 
• On the right side of the screen, click the Download tab 
• Select 1” NED (red arrow) 
• Click on XY coordinates (blue arrow) 

 

 
 

• Type in the  XY (i.e., Lat/Long) coordinates, then click Add Area 
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http://seamless.usgs.gov/website/seamless/viewer.htm


Click Download 
 

 
 
 

File downloading may take several minutes.  However, if the following window appears, click 
“here” and the file download window should appear rapidly.   

 

 
 
• Save the zip file to: \Base_Layers\DEM\17060208 and unzip it.  Be sure that Use  

Folder Names is checked in WinZip 
 

 

 
 

• Re-project the DEMs (step 3) 
• Merge the DEMs (step 4) 
• Clip the merged DEM (step 5) 

Take Note: 
 
The DEM for large 4th code HUCs may be split into two files, if this occurs, (1) be 
sure to download both files, and (2) skip Step 2 and complete steps 3-5: 
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Step 2. Project the DEM (when the DEM is 1 file) 

(If there are 2 files, skip to Step 3)  
 

The DEM should be projected to a rectangular coordinate system such as UTM.  Also, the 
coordinates must be divisible by 30 to ensure proper registration with other grids that may be 
incorporated in the future (this step will be described below).  This example assumes a 
projection of NAD 83 Zone 11.   

  
• Open ArcMap and add a 4th code HUC layer that is projected to NAD 83 Zone 11 
• Zoom to HUC 17060208 
• Add the DEM to ArcMap 
• Place the cursor outside of the DEM boundary and jot down the coordinates of the 

outermost edges of the DEM (e.g., red dots).  For example, the left coordinate (X minimum) 
should be that which is near the point marked YES.  The coordinate values appear at the 
bottom right hand corner of the ArcMap window when the cursor is placed alongside the 
DEM. 

 
 
 
 
 
 
 
 
 
 
 

LEFT: X minimum 

577200     5027454
RIGHT: X maximum 

644206     4923203

BOTTOM: Y minimum 
580121     4919368

TOP: Y maximum
638364     5029828

 
 
 
 

 
 
 

 
 
 
 
 

 
• Convert the yellow highlighted coordinates to new coordinates that are divisible by 30 
 

o Divide the coordinate by 30 and multiply the resulting integer by 30.  The new 
coordinates are highlighted green 

 
1. TOP, Y maximum: 5029828 ÷ 30 =167660.93, 167660 x 30 = 5029800 
2. LEFT, X minimum: 577200 ÷ 30 =19240.00, 19240 x 30 = 577200 
3. BOTTOM, Y minimum: 4919368 ÷ 30 =163978.93, 163978 x 30 = 4919340 
4. RIGHT, X maximum: 644206 ÷ 30 =21473.53,  21473 x 30 = 644190 
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• Now to Project the DEM!  Open ArcToolbox > Data Management Tools > Projections and 

Transformations > Raster > Project Raster 
 

Input raster:     Base_Layers\DEM\17060208\the downloaded raster 

Output raster:   Base_Layers\DEM\17060208\DEM17060208 

Output coordinate system:  NAD_1983_UTM_Zone_11N 

Resampling   BILINEAR 

Output cell size  Change to 30 (delete all digits past the decimal) 

 

 

 
 
 

 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• Click on Environments button (black arrow) > General Settings.   

5 



• Ignore top boxes and move down to: 
 

o Extent: > choose “As Specified Below” 
 
o Type the new coordinates in each box as shown below: 
 
 
 
 
 

 
 

 
 
 
   

644190

5029800

4919340

577200

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• Click OK, (check that output cell size is 30).  Click OK.  Close window. 
   
  Go to Step 5 (clip the DEM). 
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Step 3. Project the DEM (when the DEM is 2 files) 

The DEM should be projected to a rectangular coordinate system such as UTM.  Also, the 
coordinates must be divisible by 30 to ensure proper registration with other grids that may be 
incorporated in the future (this step will be described below).  This example assumes a 
projection of NAD 83 Zone 11. We use HUC 10020001 for this example. 

 
 

• Open ArcMap and add a 4th code HUC layer that is projected to NAD 83 Zone 11 
• Zoom to HUC 10020001 
• Add the 2 DEMs to ArcMap 

 
 
• Only work with one DEM visible at a time (see below). 
• Place the cursor outside of the DEM boundary and jot down the coordinates of the 

outermost edges of the DEM (see Step 2 for more information).  The coordinate values 
appear at the bottom right hand corner of the ArcMap window when the cursor is placed 
alongside the DEM.  Be sure to record coordinates well outside the DEM boundary or a gap 
between the DEMs may result (see yellow box below). 

 
 

 
 
 
 

 
 

 
 
 
 

858775     4916838 

LEFT: X minimum 
765773     5013284 

RIGHT: X maximum

BOTTOM: Y minimum 
772016     4909949 

TOP: Y maximum
851670     5019312
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• Convert the yellow highlighted coordinates to new coordinates that are divisible by 30 
 

o Divide the coordinate by 30 and multiply the resulting integer by 30.  The new 
coordinates are highlighted green 

 
1. TOP, Y maximum: 5019312 ÷ 30 =167310.4, 167310 x 30 = 5019300 
2. LEFT, X minimum: 765773 ÷ 30 =25525.76, 25525 x 30 = 765750 
3. BOTTOM, Y minimum: 4909949 ÷ 30 =163664.96, 163664 x 30 = 4909920 
4. RIGHT, X maximum: 858775 ÷ 30 =28625.83, 28625 x 30 = 858750 

 
 
 
 

Take Note: 
 

If the outermost coordinates are not used when projecting 2 neighboring 
DEMs (especially important when the DEMs are skewed), there will be a gap 
between them (a).  TauDEM will not process correctly if there is a gap in the 
final DEM.  The final merged DEM should be seamless (b). 

a 

b 
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Now to Project the DEM!  Open ArcToolbox > Data Management Tools > Projections and 
Transformations > Raster > Project Raster 

 
Input raster:     Base_Layers\DEM\10020001\the downloaded raster 
 
Output raster:   Base_Layers\DEM\10020001\DEMa10020001 
 
Output coordinate system:  NAD_1983_UTM_Zone_11N 
 
Resampling   BILINEAR 
 
Output cell size  Change to 30 (delete everything past the decimal) 

 

 
 

 
• Click on Environments button (black arrow) > General Settings.  Ignore top boxes and move 

down to: 
 

o Extent: > choose “As Specified Below” 
 
o Override the coordinates in each box in this order: right, top, left, bottom (see Step 2 

for more detail) 
  
 

REPEAT FOR THE 2ND DEM, but Output raster is: DEMb10020001 
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Step 4. Merge 2 DEMs 

• With both DEM’s open in ArcMap, go to tool bar and click Spatial Analyst > Options > 
Extent.  Change Analysis extent to:  Union of inputs > OK 

 
 
 

 
 
 
 

 

 
 
• Again, click Spatial Analyst > Raster Calculator 
• Type the following in the white box: 

Merge( double click> DEMa10020001 type a comma, double click> DEMb10020001 ) 
It should appear as follows: 

 
 

DEMa10020001 
DEMb10020001 

merge([DEMa10020001], [DEMb10020001]) 

 
 
 
 
 
 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

• Click Evaluate 
• In ArcMap, go to the newly formed DEM (it is probably called “Calculation”) 

 
o Right click on the grid and Choose Data > Make Permanent 
o Save as Base_Layers\DEM\10020001\DEM10020001 
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Step 5. Clip the DEM 

• In ArcMap open the buffered HUC 17060208 (for example) and DEM17060208  
• From the tool bar click Spatial Analyst > Options 
• General Tab > Analysis mask:  select Buffer_of_17060208 
• Extent Tab > Intersection of inputs 
• Cell size Tab > Maximum of inputs 
• OK 

 
• Again, click Spatial Analyst > Raster Calculator, double click on DEM17060208 
• Click Evaluate 
 
• In Arc Map, right click on the new layer, choose Data > Make Permanent, Save as: 

\Base_Layers\17060208\DEMC (The DEM file name should contain no more than 7 
characters). 
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Step 6. Run TauDEM to Create Stream Layer 

 

Take Note: 

• The TauDEM procedure works best if the DEM is clipped to a watershed boundary 
that encompasses the study area.  A value of NoData should be present outside 
of the watershed boundary (but within the rectangular grid extent), with valid 
elevation values (units meters) inside the watershed boundary. 

• Use ArcCatalog to create a new ArcInfo workspace for the TauDEM results.  Copy 
the DEM grid to this workspace before beginning.  The DEM should be the only 
GIS layer in the workspace.  The DEM file name should contain no more than 7 
characters (we named ours DEMC, to denote a clipped DEM). 

• Be sure that the DEM workspace is not active (currently being viewed) in 
ArcCatalog when the TauDEM process is running. 

• Run all steps within the same ArcMap window.  For instance, do not close ArcMap 
after any of the steps and re-open a new view to continue the process later.  
Errors will occur!  

• The output grids from the Basic Grid Analysis and Network Delineation steps may 
be removed from the ArcMap viewer after those procedures are completed.   

 
• In a new ArcMap window, add DEMC (the clipped DEM).  On the TauDEM toolbar choose 

Basic Grid Analysis > Select Base DEM grid.   
 
 
 
 
 
 
 
 
 
 
 
 
 
• Select DEMC > OK 
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• Select Basic Grid Analysis > Full River Network Raster.   

 
Under “Stream delineation method”:  select “DEM curvature based…..”  

 Under “Stream delineation parameters and settings”:  Accumulation threshold = 25 
 These default settings should remain the same: 

Weight side .1 
Weight center .4 
Weight diag .05   

UNCHECK : Check for Edge Contamination  
Hit Apply and then Cancel (you don’t want to run it now, you just want to set up the 
parameters) 
 
• Basic Grid Analysis > Do All >  Click Compute. 
Process times will vary depending on the size of the DEM (e.g., from 10 min to 2 hours) 
Do not close ArcMap after this process! 

 
 

• On the toolbar Select Network Delineation > Do All Network and Watershed Delineation 
Steps.   
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Click OK to delete the existing src output file 
 
• Do not use an outlet point 
• Do not do anything else between the previous Basic Grid Analysis and this step 
• After 2-3 minutes, refresh ArcCatalog.  The final TauDEM stream line layer will be called 

DEMCnet.  Close ArcMap. 
 

• Project the new TauDEM stream layer. 
o ArcToolbox > Data Management Tools > Projections and Transformations > Define 

Projection 
 
Input Dataset:  DEMCnet.shp 
Coordinate System: Select > Projected Coordinate Systems > Utm > NAD 1983 > 

Zone 11 > Add > OK 
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