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Material and Programs 

To successfully learn this material you will need to have access to the Essential FVS 
Users Guide (EFVS), the Fire and Fuels Extension Users Guide (FFE) and the FVS 
Variant Overviews documents.  These documents are available on the FVS website. 

This training document contains advanced FVS topics that are an extension of the 
Forest Management Service Center (FMSC) sponsored regional FVS training sessions; 
and therefore, assumes you have a working knowledge of FVS and the Suppose 
interface. This training guide has been designed for use with software and data outlined 
below. Participants using other software versions may obtain slightly different results 
from what is presented in this guide. 

FVS Setup Package compiled on 10/18/2011.   

http://www.fs.fed.us/fmsc/ftp/fvs/docs/gtr/EssentialFVS.pdf
http://www.fs.fed.us/fmsc/ftp/fvs/docs/gtr/EssentialFVS.pdf
http://www.fs.fed.us/fmsc/ftp/fvs/docs/gtr/FFEguide.pdf
http://www.fs.fed.us/fmsc/fvs/documents/userguides.shtml
http://www.fs.fed.us/fmsc/fvs/documents/userguides.shtml
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Introduction 

In the Regional FVS training course, you defined simple custom variables using the 

Model Outputs > Event Monitor (EM) Compute Variables windows.  In this course 

you will expand on that knowledge by learning how to compute complex custom 

variables through writing complex expressions utilizing the Event Monitor’s (EM) 

conditional scheduling, pre-defined variables and functions, and interactions with 

databases. Before you begin the exercises you may need to review how to create 

custom output variables in Suppose.  See exercise 1-3 in the Regional Training Guide 

for a step by step guide on creating custom variables in Suppose.   

The EM model output options used in the regional training course are directly linked to 
the COMPUTE keyword. The following discussion describes the COMPUTE keyword.  

The COMPUTE keyword allows the user to define single or multiple variables 
expressed as mathematical expressions containing constants, operators, EM variables, 
EM functions, and variables previously defined using the COMPUTE keyword. Tables 5-
2 and 5-3 of the Essential FVS Users Guide (EFVS) contains the constants, operators, 
EM variables, and EM functions that may be used in expressions. Variables may be 
computed for all cycles, a single cycle, or conditionally using the EM conditional logic. 

The following segment illustrates how to use the COMPUTE keyword to calculate the 
trees per acre of Douglas-fir and the percentage of Douglas-fir in the stand in 2012. 

....|....|....|....| 

Compute         2012 

DF_TPA = SPMCDBH(1,DF,0) 

DF_PCNT = (DF_TPA/BTPA)*100 

End 

1) The COMPUTE keyword begins in the first column of the keyword record and is 
followed by a timing option right justified in the first field of the keyword (columns 11-20). 
In the above example, the variables will be computed in 2012.  A zero in column 20 
would have FVS calculate the variables every cycle.  

2) Each variable to be calculated is contained in a supplemental record (new line) 
following the COMPUTE keyword. Each supplemental record contains a user-defined 
variable name on the left of the equal sign, and a value or expression on the right of the 
equal sign. In this example, two variables are being calculated (DF_TPA and 
DF_PCNT). DF_TPA is being set to the trees per acre of Douglas-fir in the stand using 
the EM function SpMcDBH. DF_PCNT is being set to the percent of Douglas-fir in the 
stand by dividing DF_TPA by the stand trees per acre (EM variable BTPA) and 
multiplying by 100. Both variables are being computed at the beginning of the cycle 
prior to management activities. 
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3) The list of variables is complete when FVS reads the END keyword. 

COMPUTE keyword expressions may contain a combination of EM variables and 
functions and predetermined user-defined variables. For instance, if you want to 
compute the trees per acre of Douglas-fir and ponderosa pine in a stand, you could add 
two SpMcDBH functions together (TPA_DFPP variable below). Another commonly used 
technique is to use variables and functions within functions. In the variable TPA>70% 
below, the DBHDist function is used to identify the lower end diameter for computing 
trees per acre using the SpMcDBH function.  SpMcDBH(1,All,0,DBHDist(3,4)) would 
return the trees per acre of all trees greater than or equal to the diameter of the 70th 
percentile tree in the stand. Many addfiles in use today use these techniques in 
computing specialized variables. 

....|....|....|....| 

Compute         2012 

TPA_DFPP = SPMCDBH(1,DF,0) + SPMCDBH(1,DF,0) 

TPA>70% = SPMCDBH(1,0,0,DBHDist(3,4),999,0,999,0,0) 

End 

The COMPUTE keyword follows specific formatting.  The following guidelines are 
followed: 

 Variable names must not be longer than eight characters. 

 Variable names may not be names found in Tables 5-2 and 5-3 of EFVS, may 
not be FVS species codes, and may not include an ampersand (&).  

 Resulting variables may represent beginning of cycle values, harvested values, 
or after-harvest values.    

 Each supplemental record (variable expression) may be up to 2000 characters, 
of which only 150 may appear on a given line. Additional lines may be used in a 
single expression by using an ampersand (&) at the end of the line to indicate 
that the expression is continued on the next line.  

 Up to 199 user-defined variables may be calculated in a single stand simulation. 

Results of the calculations are reported in the Activity Summary Section of the 
Summary Statistics Table found in the main output file. Additionally, the results may be 
viewed using the Compute Post Processors or may be sent to an output 
database/spreadsheet using the Database Extension.  
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Exercise 1-1 – Creating Custom Output Variables, Part 1 

Many stand variables that are important to track in analyses are not provided for in 
basic FVS output; however, they may be calculated using the COMPUTE keyword. For 
instance, if wildlife habitat is defined using the number of ponderosa pine snags 
between 10 and 20 inches dbh, the COMPUTE keyword can be used to compute a 
variable that provides the number of ponderosa pine snags between 10 and 20 inches 
dbh. The wildlife habitat could then be rated by creating a rating scale where 1-3 
ponderosa pine snags are considered poor habitat (habitat score = 1), 3-7 is considered 
adequate habitat (habitat score = 2), and >7 is considered ideal habitat (habitat score = 
3). 

In this exercise, the habitat of a fictional wildlife creature called the American Catmar 
will be determined by creating four complex custom variables that describe the habitat 
needs of the species. The COMPUTE keyword will be used to calculate the variables for 
a single stand. At the end of the exercise the quality of the habitat over a 100-year 
period will be rated. 

Background Information 

This set of exercises is based on the habitat requirements of the fictional North 
American Marauding Squirrel Cat, colloquially called the American Catmar. The 
American Catmar is a small mammalian creature seldom seen; however, it is found 
throughout moist forests in North America. It resembles a pine marten but is most often 
confused with the gray squirrel due to its slow spiraling accents into tree tops when 
approached.  This trait is due to its left legs being 10-20% shorter than its right legs. 
This attribute almost led to its extinction following even-aged regeneration harvests 
where Catmars, when threatened, would circle endlessly. Hunters and predators quickly 
learned to stay put and wait for the Catmar to return.   

Renowned wildlife biologist, I. M. Alyer, studied the American Catmar for over 20 years. 
His research yielded much needed information on the life history of this species. He 
specifically developed habitat requirements for resting and foraging activities as well as 
attributes of successful regress (escape) routes. Alyer found that Catmars use their 
enormous “beaverlike” front teeth and jaws to excavate woodpecker cavities and to 
build dens and nests in large live/dead trees. These large teeth also benefit their 
foraging abilities when prey (squirrels, moles, and mice) are scarce. He observed 
Catmars eating the twigs and leaves located in the tree crowns as a supplement to their 
unsteady diet of prey. Finally, Alyer found that tree density and downed woody debris 
(DWD) coverage played a significant role in their safety. Due to their slow surface 
speeds, the American Catmar needs readily accessible escape routes into the canopy 
of the stand (i.e. many small trees).  

The American Catmar is listed as a sensitive species; and as such, forest managers 
need a way to assess the suitability of forests to meet the habitat requirements of this 
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species. In this training guide, the research results of Alyer will be used to compute 
custom FVS variables which describe the quality of American Catmar habitat. These 
variables will then be used to create a custom FVS stand suitability index for American 
Catmars. 

The following stand attributes describe the American Catmar habitat: 

1. Trees per acre of both live and dead trees greater than or equal to 20 inches 
in DBH – used to identify resting habitat 

2. Crown biomass of the 50th percentile trees as defined by merchantable 
volume – used to identify foraging habitat 

3. Trees per acre of live trees less than or equal to 30 feet in height – used to 
identify regress habitat 

4. Percent cover of downed wood greater than three inches in DBH – used to 
indentify hiding and regress habitat 

Custom variables need to be created in order to calculate the stand attributes listed 
above.  Using the operators and pre-defined functions in Table 5-3 of the EFVS, write 
expressions for the four custom variables: 

1. _Tpa20p =  

2. _CrBio =  

3. _TpaMid =  

4. _PCDW3p = 

Running the Simulation 

1) Start Suppose by double-clicking the Suppose icon on your desktop.  
2) Make sure that no previous simulation is in memory. The title bar should say *new 

file* if the memory is clear. If a previous simulation is in memory, click File > New. 
3) Click on the File menu and select “Select Locations File”. 
4) In the Open dialog box, navigate to “C:\Fvsdata\Regional-Training” and open the 

Suppose.loc file. 

Step 1  
Adding the stand to the simulation.   

5) If the Select Simulation Stands window does not open, click on the “Select 
Stands” button on the main page. 
a. In the large “Locations” box select “Regional Training.” 
b. In the large “Groups” box select “Variant=WC.” 
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c. In the large “Stands” box select “060305402956”. 
d. At the bottom left corner, click the “Add 1 Stand” button.  

6) Click on the “Close” button. 

Step 2  
Changing the time scale. 

7) Click on the “Set Time Scale” button. 
a. Change the common starting year from 2006 to 2012.  
b. Change the common ending year to 2112.  

8) Click on the “Ok” button. 

Note: This will grow the stand from 2006 to 2012 before growing the stand cycle by 
cycle. 

Step 3 
Adding the compute variables. 

9) Click on the “Add Keywords” button. 
10) Select Base FVS system > Input/Output Controls > Compute.  
11) Click on the “Accept” button. 
12) In the Compute window do the following: 

a. Change the name to “Compute Catmar Habitat Attributes”. 
b. Change the “Schedule by Year/Cycle” field to a “0”.  
c. Click on the “Use Parms” button. 
d. Click on the “Proceed” button. 
e. Enter the expressions created for the four custom variables between the 

Compute line and the End line. 
13) Click on the “Ok” button. 
14) Click on the “Close” button to close the Use FVS Keywords window.  
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Note: Entering a 0 in the “Schedule by Year/Cycle” input box provides the compute 
variables for all cycles.  The dropdown menu below the FVS Functions dropdown menu 
provides access to predefined functions.  If a predefined function is selected use the 
“Set Function Arguments” button to access the options available for the functions’ 
arguments.  Placing the cursor between the Compute line and the End line and clicking 
on the “Insert” button will place the selected function and its corresponding selected 
arguments in the Compute window.  The Event Monitor (EM) Compute Variables can 
also be accessed using the Select Outputs button.     

Step 4 
Creating the outputs.  

15) Click on the “Select Outputs” button. 
16) Select Fire and Fuels Extension (FFE) Reports > Select Fire and Fuels Reports. 

a. Leave all boxes checked (default option). 
17) Click on the “Ok” button. 
18) Click on the “Close” button to close the Model Outputs window. 

Note: Some of the four custom variables included functions found in the Fire and Fuels 
Extension to the Forest Vegetation Simulator (FFE-FVS). In order to access these 



16 

 

functions the FFE-FVS must be turned on.  To turn FFE-FVS on, an FFE-FVS keyword 
must be added to the simulation which is why the Fire and Fuels Reports were selected.   

Step 5 
Selecting the post processors.   

19) Click on the “Select Post Processors” button. 
a. Highlight the “View the Main Output file using system editor” post processor. 
b. Click on the “Include” button.  
c. Highlight the “Compute1 – Table of Compute Variables (with headers)” post 

processor. 
d. Click on the “Include” button. 

20) Click on the “Close” button to close the Select Post Processors window. 

Note: Many of the post processors require output be created before it can be 
processed, one of the exceptions is “View the Main Output file using system editor” post 
processor.  To know which output to create for a post processor, read the 
Desicription/Notes section in the Select Post Processor window.   

Final Step 
Running the simulation.   

21) Click on the “Run Simulation” button. 
22) Name the keyword file Custom1-1.key. 
23) Click on the “Save” button. 
24) Click on the “Run” button. 

Note: Check the main output file for errors associated with your compute expressions. If 
an expression has a recognized problem, FVS will insert a FVS12 error after the 
expression in the Options Selected by Input section of the main output file. In addition, 
look in the Activity Summary to see that the Activity Disposition says “DONE IN 
<YEAR>” for each custom variable. If the disposition says “NOT DONE”, then you have 
an error in your expression. If your custom variables are not computed, correct your 
expressions in Suppose. A screen capture of the Compute expressions is located in the 
Answer Guide. Once you are satisfied that your expressions are functioning properly, 
rerun the simulation, close the output file.  
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Questions 

 Answer the questions below using the Compute post processor output. 

Use the table below to describe the habitat score of each habitat category in 2012, 
2042, 2072, and 2112. 

Habitat 
Category 

Stand 
Attribute 

No          
Habitat 

(score=0) 

Poor   
Habitat 

(score=1) 

Moderate       
Habitat 

(score=2) 

Ideal       
Habitat 

(score=3) 

Resting 
Large Trees 

(_Tpa20p) < 5  5  – 15 15  – 25 > 25 

Foraging 

Crown 
Biomass 
(_CrBio) < 7.5  7.5  – 12.5 12.5 – 17.5  > 17.5 

Regress 
Routes 

TPA in 
Midstory 

(_TpaMid)   <100 100 – 200  200 – 300 > 300 

Hiding/Regress 
Cover 

Percent 
Cover of 

DWD 
(_PCDW3p)   <5 or > 30 

5 – 10 or     
25 – 30  

10  – 15 or     
20 – 25 15 – 20 

Fill in the table with your results. 

Year Resting Score Foraging Score Regress Score 
Hiding/Regress 

Cover Score 

2012     

2042     

2072     

2102     
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Exercise 1-2 – Rating the Quality of Stand Attributes 

In the previous exercise, custom output variables were computed to describe American 
Catmar habitat.  From these custom variables, the quality of various types of habitat, 
resting, foraging, and regress/hiding habitat were rated using a table.  This exercise will 
build on the previous exercise by using FVS to rate the resting, foraging, and 
regress/hiding habitat.   The rating scale will use the scale found in the table in Exercise 
1-1. 

Background Information 

One method to calculate score values is to use a series of conditional COMPUTE 
keywords for each possible score.  FVS does not contain If-Then-Else options; rather 
each possibility must be created using exclusive If-Then-Endif options.  An example 
using the resting score for the American Catmar habitat would be as follows: 

If                 0 

_Tpa20p LT 5 

Then  

Compute            0 

RestScor = 0 

End 

Endif 

If                 0 

_Tpa20p GE 5 and _Tpa20p LT 15 

Then  

Compute            0 

RestScor = 1 

End 

Endif 

If                 0 

_Tpa20p GE 15 and _Tpa20p LT 25 

Then  

Compute            0 

RestScor = 2 

End 

Endif  
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If                 0 

_Tpa20p GE 25 

Then  

Compute            0 

RestScor = 3 

End 

Note: Using multiple conditional statements can take up memory in FVS and may fill up 
the storage area of the Event Monitor.  This can result in the occurrence of FVS17 and 
FVS18 errors and may in turn cause the variables not to be calculated.   

A second option is to use a single COMPUTE keyword with an expression containing 
the LinInt (linear interpolation) function, a pre-defined event monitor variable.   

The LinInt function is a powerful and versatile function which linearly interpolates 
between two points graphed using x and y coordinates.  The general form is shown 
below, where (x1, y1),( x2, y2), . . . ,( xn, yn) define points using x and y coordinates and X 
is some arbitrary value along the x-axis. 

LinInt (X, x1, x2,..., xn, y1, y2,..., yn) 

The function returns the appropriate value along the Y-axis derived from linear 
interpolation. The line is defined by connecting the points (xi,yi) listed in the arguments 
of the LinInt function. Note that x1 through xn must be in ascending sequence (however, 
two consecutive xi values can be the same). If X is less than or equal to x1, then LinInt 
returns the value of y1, and if X is greater than or equal to xn, LinInt returns the value of 
yn.  For example, the function LinInt (BADBH,5,5,0,1) would return 0 if the QMD is less 
than 5 inches and a 1 if the QMD was greater than or equal to 5 inches. 

At least 2 points must be provided, all arguments must be defined, and the total number 
of arguments must be an odd number. If any of these conditions are violated, the result 
of LinInt is undefined. The maximum number of allowable points depends on the 
specific use within an expression and may vary by computer installation. In any case, up 
to 20 points should be permissible. This function does not have a set number of 
arguments; values for the arguments are required since there are no default values. 

Here are two examples of how the LinInt function can be used to calculate a 
COMPUTE variable. 

In the first example, the linear relationship between the age of the stand and stand 
height is examined within the LinInt function. The first argument of the LinInt function is 
the X variable (stand height); in this example the stand height will be estimated using 
the EM variable BTopHt.  The individual xi,yi data points will be listed as the  remaining 
arguments for the LinInt function such that the individual xi’s (stand heights) are listed 
before the individual yi’s (stand age for a given stand height).  The LinInt function will 
then be used to compute the age of the stand for each cycle.   



20 

 

 

Compute           0 

StandAge = Linint(BTopHt,0,25,45,60,0,20,40,60) 

End 

In the second example, the LinInt function is used to estimate stand size (small, 
medium, or large) from quadratic mean diameter of the stand; this is referred to as a 
step-wise or trigger function. The xi, yi arguments of the LinInt function are set such that 
if the stand diameter (BaDBH) is less than 5, the size class is set to small (SizCls=1); if 
the stand diameter is greater than or equal to 5 and less than 15, the size class is set to 
medium (SizCls =2); and If the stand diameter is greater than or equal to 15, the size 
class is set to large (SizCls =3). 
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Compute           0 

SizCls = Linint(BaDBH,5,5,15,15,1,2,2,3) 

End 

For this exercise, the step-wise LinInt function will be used to rate the four habitat 
variables. The following logic provides an example of how the LinInt function can be 
used to calculate the resting score for the American Catmar: 

 

Compute             0 

RestSc  = LinInt(_Tpa20p,5,5,15,15,25,25,0,1,1,2,2,3) 

End 

Using the table in the previous exercise, write expressions to compute the four habitat 
scores: resting, foraging, regress, and hiding cover. 

RestSc   =  LinInt(_Tpa20p,5,5,15,15,25,25,0,1,1,2,2,3) 

ForagSc =  

RegrsSc =  

HideSc   =  

0

1

2

3

0 5 10 15 20 25 30

RestSC 

_TPA20p 
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Running the Simulation 

1) Make sure that Exercise 1-1 is open. If the exercise is not open, open Exercise 1-1 
by selecting Open from the File dropdown tab and opening Custom1-1.key. 

Step 1 
Adding additional compute variables. 

2) In the “Simulation file contents” window of Suppose, double click on the “Compute 
Catmar Habitat Attributes” option. 

3) Enter the expressions created for the four habitat scores after the existing equations 
and between the Compute and End line. 

4) Click on the “Ok” button.  
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Final Step 
Running the simulation.   

5) Click on the “Run Simulation” button. 
6) Click on the “Save As” button.   
7) Name the keyword file Custom1-2.key. 
8) Click on the “Save” button. 
9) Click on the “Run” button. 

Questions 

Fill in the table with your results. 

Year Resting Score Foraging Score Regress Score 
Hiding/Regress 

Cover Score 

2012     

2042     

2072     

2102     

Do these results match what you wrote down in the previous exercise? If not, check 
both exercises for errors.  
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Exercise 1-3 – Creating Custom Output Variables, Part 2 

In the previous examples, custom variables were calculated based on stand attributes 
computed during a simulation. In addition, compute variable equations may contain 
variables in an auxiliary database using a Database Extension (DB-FVS) – Event 
Monitor (EM) connection.  

DB-FVS supports connections between databases and the EM. This interaction can 
occur for any cycle where an EM’s COMPUTE keyword is processed. At any time 
during the simulation DB-FVS keywords can be used in conjunction with SQL 
statements to connect to an existing database and select data from that database.  The 
SQLIN keyword initiates this process and allows the user to use SQL statements within 
the EM.  The user controls at what time during the simulation the SQL statements are 
executed.  

Using the SQL SELECT statement will produce a new table.  The column names from 
the resultant table will be compared to the names of any user-defined variables within 
the EM.  For any matching variable, the value found in the last row of the result table is 
used to set the value of Event Monitor variable.  For example, if a user-defined variable 
called BATARG is created using the COMPUTE keyword and the resultant table 
created from the SQL statement contains a column called BATARG, the value found in 
the last row of the BATARG column from the resultant table will be assigned to the user-
defined COMPUTE variable.  BATARG could then be used in conditional statements 
and expressions.  

When the SQL statement is a Select statement meant to set the value of an Event 
Monitor variable, the variables must be defined prior to executing the query. Event 
Monitor variables are defined (but not given values) simply by using them in logical 
expressions, compute expressions, or by using parameters on keywords. This exercise 
uses the SQLIN keyword to select a value from the FVS_StandInit table in your input 
database and uses it to create a user-defined variable. 

Background Information 

Wildlife biologist I. M. Alyer recently identified that moisture regime index is a solid 
predictor for identifying forest stands capable of supporting American Catmar 
populations. Moisture regimes range from 0 to 4 and are reported in the MOISTURE 
field for stands on the Gifford-Pinchot forest (603) in your training database. The 
MOISTURE value will be used to create another user-defined variable which reports 
whether or not the forest is capable of supporting American Catmar habitat. MOISTURE 
values less than 2.5 are considered incapable of supporting populations, whereas 
values greater than or equal to 2.5 can support viable populations.  

In this exercise, the EM-DB extension linkage will be used to compute a variable that 
reports the suitability of the forest stand to support a viable population of American 
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Catmar. Suitability scores of 0 will represent an unsuitable stand; suitability scores of 1 
will represent a suitable stand.   

Running the Simulation 

1) Make sure that Custom1-2.key is the open simulation file.  If the exercise is not 
open, open Exercise 1-2 by selecting Open from the File dropdown tab and opening 
Custom1-2.key. 

Step 1 
Opening the database extension.   

2) Click on the “Add Keywords” button. 
3) Select Database Extension > All Keywords > SQLIn. 
4) Click on the “Accept” button.  

a. Change the “Schedule by Year/Cycle” field to a “1”.  
b. Click on the “Use Parms” button. 
c. Click on the “Proceed” button. 
d. Change the SQL statement to select the “MOISTURE” variable from the 

FVS_StandInit table where the current Stand_ID equals ‘%StandID%’. 
5) Click on the “Ok” button.  
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Note: The quotes listed in 7d) are needed in the SQL code.  When the first field is left 
blank, the statement is executed immediately upon being read by the program. When a 
value is entered in the first field, the statement is considered an FVS activity and 
scheduled to be executed during the year or cycle indicated. Like any other FVS 
activity, an SQLIN statement can be scheduled upon a condition using the IF-THEN-
ENDIF construct supported by the EM. 

Step 2 
Computing the variables of interest.   

6) Select Base FVS System > All Keywords > Compute. 
a. Change the name to “Compute MRI Attributes” 
b. Change the “Schedule by Year/Cycle” field to a “1”.  
c. Click on the “Use Parms” button. 
d. Click on the “Proceed” button. 
e. Enter the following expressions between the Compute line and the End line: 

_MRI=MOISTURE 
MRISc = Linint(_MRI,2.5,2.5,0,1) 

7) Click on the “Ok” button. 
8) Click on the “Close” button to close the Use FVS Keywords window. 
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Final Step 
Running the simulation.   

9) Click on the “Run Simulation” button. 
10) Click on the “Save As” button.   
11) Name the keyword file Custom1-3.key. 
12) Click on the “Save” button. 
13) Click on the “Run” button. 

Questions 

Check the main output file to make sure the new custom moisture variables were 
calculated. Close the main output file. The Compute post processor will open and you 
will see the two new moisture variables calculated in the first cycle. Since these 
variables do not change during a simulation, there is no need to calculate them every 
cycle. Once calculated they remain in memory for future use during the simulation. The 
compute variables were calculated then every cycle.  

What are the MRI and MRI score for this stand: ________ _________  
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Exercise 1-4 – Creating a Habitat Suitability Index 

In this exercise, an American Catmar suitability index (CatMrIdx) will be computed 
based on the habitat scores computed in the previous examples. Stands that have a 
MRI value greater than 2.5 are considered suitable habitat (MRISc = 1) for the American 
Catmar. If a stand meets this criterion, the suitability index is equal to the sum of the 
habitat scores using the following guidelines:  

Sum of Habitat 
Values Suitability Index 

<3 0.00 

4 0.25 

8 0.50 

10 0.75 

>11 1.00 
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Once the habitat suitability index has been determined, the American Catmar suitability 
index will be calculated for all stands (not bareground) identified in the Western 
Cascades variant (group code = “Variant=WC) region.  The information will then be 
used to fill in the table below.  There are no new methods being presented in this 
example.  

Stand ID 2012 2052 2112 

060305402956    

060305402995    

060305403015    

060305403020    

060305403030    

060305403055    

Average Value    

Hint: you will need to use conditional COMPUTE keywords or use double LININTs in a 
single COMPUTE keyword to calculate the American Catmar suitability index 
(CatMrIdx). 

Extra credit:  

Reorganize the custom variables so that you use less than 5 custom variables in your 
calculations. 
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Introduction 

In the Regional FVS training course, you were introduced to the concept of scheduling 
management activities based upon a condition.  Thinning may be called for if the stand 
is too dense, or a prescribed burn may be implemented only if certain conditions are 
met.  The Event Monitor feature of FVS allows the user to specify a set of condition that 
must occur or thresholds that must be met.  The user can then specify a set of 
management activities for the model to simulate when that condition occurs.  The Event 
Monitor can evaluate expressions both prior to and after thinning requests.  For more 
information on conditionally scheduling activities see section 5.5 in the Essential FVS 
guide.   

In this course you will expand on the knowledge learned from the regional training to: 

schedule multiple events dependent upon a condition, scheduling a random event, 

scheduling based upon if-then-else conditions, and addition conditions to the Condition 

Library.    
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Exercise 2-1 – Conditionally Scheduling Multiple Management 
Activities 

The scheduling of management activities is often dependent upon other management 
activities.  In this exercise, the conditional scheduling option in FVS will be explored for 
multiple management activities. Conditional scheduling may be used when you want an 
activity to occur based on stand attributes and other considerations as opposed to 
scheduling an activity at a specified time.  In this exercise a thin from below will be 
performed when the stand basal area reaches 100.  One year after thin, a prescribed 
fire will be performed and one year after the fire, natural regeneration will be added to 
the simulation.   

Running the Simulation 

1) Start Suppose by double-clicking the Suppose icon on your desktop.  
2) Make sure that no previous simulation is in memory. The title bar should say *new 

file* if the memory is clear. If a previous simulation is in memory, click File > New. 
3) Click the File menu and select “Select Locations File”. 
4) In the Open dialog box, navigate to “C:\Fvsdata\Regional-Training” and open the 

Suppose.loc file. 

Step 1 
Adding the stand to the simulation.   

5) If the Select Simulation Stands window does not open, click on the “Select 
Stands” button on the main page. 

a. In the large “Locations” box select “Regional Training.” 
b. In the large “Groups” box select “Variant=WC.” 
c. In the large “Stands” box select “06035402995”. 
d. At the bottom left corner, click the “Add 1 Stand” button.  

6) Click the “Close” button. 

Step 2 
Changing the time scale. 

7) Click on the “Set Time Scale” button. 
a. Change the common starting year from 2006 to 2012.  
b. Change the common ending year to 2072.  

8) Click on the “Ok” button. 

Note: This will grow the stand from 2006 to 2012 before growing the stand cycle by 
cycle. 
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Step 3 
Defining the management actions and conditions. 

9) Click on the “Select Management” button. 
10) Select Thinning & Pruning Operations > Thin from below. 

a. Enter the residual density in terms of basal area: 60. 
b. Click the small radio button to the left of “Schedule by Condition”. 
c. Click the “Condition” button. 
d. Click the down arrow on the drop box to the right of the Condition Library. 
e. Select the condition “Specified Basal Area is exceeded.” 
f. Set the basal area to “100”. 
g. Change the “Years before condition can be tested after being found true:” to 

0. 
h. Change the name of the condition to “Condition – BA GT 100”. 

 

11) Click on the “Ok” button to close the Condition window. 
12) Click on the “Ok” button to close the Thin from Below window. 
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Note: The condition library contains a list of useful predefined conditions. Exercise 2-4 
explains how to create a customized library of conditions.   

13) Select Fuel Treatments > Prescribed burn. 
a. Change the moisture level to “3 = Moist”. 
b. Change the temperature to “50”. 
c. Click the small radio button to the left of “Schedule by Condition”.  
d. Change the “years after” field set to “1”. 
e. Click on the “Condition” button. 
f. Click on the “Attach to…” button.  
g. Select the Condition – BA GT 100 condition and click “Ok”. 

14) Click on the “Ok” button to close the Prescribed burn window. 
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15) Select Planting & Natural Regeneration > Plant/Natural with Partial Estab 

Model. 
a. Leave sprouting turned on. This will automatically add sprouts from the 

sprouting species into the simulation.  
b. Change the Planting/Natural done to “0” year(s) after the date of disturbance. 
c. Select the radio button to the left of the “Natural” keyword. 
d. Enter the parameters for the first species: 

Species ........................Western hemlock 
Trees/acre ....................50 
Percent survival ............100 
Ave. height ...................2.0 



36 

 

Shade code ..................Uniform distribution 
Leave all other fields set to default values. 

e. Click on the “Another Plant/Natural” button. 
f. Enter the parameters for the second species: 

Type .............................Natural 
Species ........................Western redcedar 
Trees/acre ....................20 
Percent survival ............100 
Ave. height ...................2.0 
Shade code ..................Uniform distribution 
Leave all other fields set to default values. 

g. Click on the “Another Plant/Natural” button. 
h. Enter the parameters for the third species: 

Type .............................Natural 
Species ........................Douglas-fir 
Trees/acre ....................10 
Percent survival ............100 
Ave. height ...................3.0 
Shade code ..................Most trees placed on sparse plots 
Leave all other fields set to default values. 

i. Click the small radio button to the left of “Schedule by Condition”. 
j. Change the “years after” field to 2. 
k. Click on the “Condition” button. 
l. Click on the “Attach to…” button.  
m. Select the Condition – BA GT 75 condition and click “Ok”. 

16) Click on the “Ok” button to close the Planting and Natural Regeneration window. 
17) Click on the “Close” button to close the Management Actions window. 
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Note: Management actions may be attached to the same conditions.  In this example 
the same condition (when stand basal area reaches 75) prompts thinning of the stand to 
a residual basal area of 60 followed by a prescribed burn and the addition of 
regeneration.  Be warned, If for some reason the thinning does not occur (perhaps the 
residual target cannot be met), the prescribed burn and the addition of regeneration will 
still occur.  In addition, only fire and regeneration keywords operate in the middle of a 
cycle.  Adding other management activities in the middle of a cycle will cause the 
management activity to occur at the beginning of the cycle, unless a new cycle 
boundary is added to the simulation.   
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Step 4 
Selecting the Post Processors.   

18) Click on the “Select Post Processors” button. 
19) Highlight the “View the Main Output file using system editor” post processor. 
20) Click on the “Include” button. 
21) Click on the “Close” button to close the Select Post Processors window.  

Note: Many of the post processors require output be created before it can be 
processed, one of the exceptions is “View the Main Output file using system editor” post 
processor.  To know which output to create for a post processor, read the 
Desicription/Notes section in the Select Post Processor window.   

Final Step 
Running the simulation.   

22) Click on the “Run Simulation” button. 
23) Name the keyword file Conditional2-1.key. 
24) Click on the “Save” button. 
25) Click on the “Run” button. 
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Questions 

Scroll through the Input Summary Table - Options Selected by Input section of the main 
output file. What FVS keywords were added to the simulation to perform the conditional 
thinning, prescribed burn, and natural regeneration? 

From the Summary Statistics Table, how many times was the stand thinned? Did the 
stand get thinned every time basal area exceeded 100? 

From the Activity Summary, when did the natural regeneration get entered into the 
simulation? 

Extra Credit 

Adjust the simulation run so that you have a minimum waiting time of 40 years between 
thinning events and so that thinning does not occur in cycle 1.  Hint: you will have to use 
the free form editor to adjust the code. 

Extra Extra Credit 

Adjust the simulation run so that you base the conditional thinning on basal area in trees 
greater than 5” DBH. 
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Exercise 2-2 – Conditionally Scheduling Based on a Random Event 

Often random events such as fire or insect outbreaks need to be modeled.  In this 
exercise, a stand replacing fire will be randomly scheduled.  Two years after the fire 
regeneration of lodgepole pine will be added to the stand.  

Running the Simulation 

Step 1 
Adding the stand to the simulation.   

1) Make sure that no previous simulation is in memory. The title bar should say *new 
file* if the memory is clear. If a previous simulation is in memory, click File > New. 

2) Click on the “Select Stands” button on the main page. 
a. In the large “Locations” box select “Regional Training.” 
b. In the large “Groups” box select “Variant=WC.” 
c. In the large “Stands” box select “060305402995”. 
d. At the bottom left corner, click the “Add 1 Stand” button.  

3) Click on the “Close” button. 

Step 2 
Changing the time scale.   

4) Click on the “Set Time Scale” button. 
a. Change the common starting year from 2006 to 2012.  
b. Change the common ending year to 2042.  

5) Click on the “Ok” button. 

Step 3 
Creating a random number using Event Monitor Compute Variables. 

6) Click on the “Select Outputs” button. 
7) Select Event Monitor (EM) Compute Variables > Compute Pre-Defined Stand 

Variables 
a. Change the name to “Compute – Random Number”. 
b. Change the Schedule Year to “0”.  
c. Enter the variable name to be “Random”. 
d. Use the drop down tab to select “Rann = Uniform random number”. 

8) Click on the “Ok” button. 
9) Click on the “Close” button to close the Model Outputs window.   
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Note: For more information on using pre-defined event monitor variables see section 
5.5.2.2 in the Essential FVS guide.  

Step 4 
Defining the management actions and conditions. 

10) Click on the “Select Management” button. 
11) Select Fuel Treatments > Prescribed burn.  

a. Change the moisture level to 1 = Very Dry. 
b. Change the wind speed to 50. 
c. Change the percentage of the stand area burned to 100. 
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d. Click on the small radio button to the left of “Schedule by Condition”. 
e. Click on the “Condition” button. 
f. Click on the “Free form” button. 
g. Click on the “Proceed” button.  
h. Change the name to “Condition – Random”. 
i. Enter the conditional statement “Random LT 0.10” expressions between the 

IF line and the Then line. 
j. Change the 0 located after the IF statement to 50.  

12) Click on the “Ok” button. 
13) Click on the “Ok” button to close the Prescribed burn window. 

 

Note: The condition statement will cause a prescribed burn to occur if the random 
number is less than 0.10.  By inserting the value of 50 within the IF statement constrains 
the fire from occurring within 50 years following a fire. The number 50 needs to be in the 
exact location as shown in the figure to work correctly.  

14) Select Planting & Natural Regeneration > Plant/Natural with Partial Estab 
Model. 

a. Turn off sprouting.  
b. Change the Planting/Natural done to “2” year(s) after the date of disturbance. 
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c. Select the radio button to the left of the “Natural” keyword. 
d. Enter the parameters for lodgepole pine: 

Type .............................Natural 
Species ........................Douglas-fir 
Trees/acre ....................700 
Percent survival ............70 
Ave. height ...................3.0 
Shade code ..................Uniform distribution 
Leave all other fields set to default values 

e. Click the small radio button to the left of “Schedule by Condition”. 
f. Click on the “Condition” button.  
g. Click on the “Attach to…” button.  
h. Select the Condition – Random condition and click “Ok”. 

15) Click on the “Ok” button to close the Planting and Natural Regeneration window. 
16) Click on the “Close” button to close the Management Actions window.  

Step 5 
Selecting the Post Processors.   

17) Click on the “Select Post Processors” button. 
18) Highlight the “Compute1 – Table of Compute Variables (with headers)” post 

processor.   
19) Click on the “Include” button. 
20) Highlight the “View the Main Output file using system editor” post processor. 
21) Click on the “Include” button. 
22) Click on the “Close” button to close the “Select Post Processors” window.  

Note: to use the “Compute1 – Table of Compute Variables (with headers)” post 
processor, event monitor variables must be created first.  See the Description/Notes 
section in the Select Post Processors window for more detailed information.   

Final Step 
Running the simulation.   

23) Click on the “Run Simulation” button. 
24) Name the keyword file Conditional2-2.key. 
25) Click on the “Save” button. 
26) Click on the “Run” button. 

  



44 

 

Questions 

The Table of Computed Variables will open.  In which years is the random number 
greater than 0.90? 

Close the Table of Computed Variables.  The main output file will open. Scroll through 
the Input Summary Table - Options Selected by Input section of the main output file. Did 
the conditional statement appear? 

Scroll through the Activity Summary Table.  Did a fire occur?  If so, in what year?  What 
random number caused the fire to occur?  Did regeneration occur 2 years after the fire? 

Extra Credit 

Run the simulation again.  Did you obtain the same results?  Use the RANNSeed 
keyword to change the random number generator and change the results.  

Note: entering a value of 0 for the RANNSeed keyword will cause FVS to produce 
different results for each run.  

Extra Extra Credit 

For the years 2012, 2022, and 2032, create a distribution for the likelihood of a 
catastrophic fire to occur.     

Note: This will require running the exercise (or the stand) multiple times (say 100) and 
exporting the compute variable “Random” to Microsoft Excel.  From there a pivot chart 
can be created using 0.10 classes for the random number. 
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Exercise 2-3 – Scheduling Alternative Management Activities Based 
Upon a Condition 

Perhaps interest lies in creating a condition as an indicator between selecting different 
management activities.  For example if the basal area of a stand is at least 225 square 
feet per acre, less regeneration needs to be modeled than if the stand basal area is less 
than 225.  While condition statements offer great flexibility in scheduling management 
activities, the use of an If-Then-Else statement is not an option in FVS.  As such, each 
condition needs to be modeled separately as an If-Then statement.   

Running the Simulation 

Step 1 
Adding the stand to the simulation.   

1) Make sure that no previous simulation is in memory. The title bar should say *new 
file* if the memory is clear. If a previous simulation is in memory, click File > New. 

2) Click on the “Select Stands” button on the main page. 
a. In the large “Locations” box select “Regional Training.” 
b. In the large “Groups” box select “Variant=WC.” 
c. In the large “Stands” box select “060305402995”. 
d. At the bottom left corner, click the “Add 1 Stand” button.  

3) Click on the “Close” button. 

Step 2 
Changing the time scale.   

4) Click on the “Set Time Scale” button. 
a. Change the common starting year from 2006 to 2012.  
b. Change the common ending year to 2072.  

5) Click on the “Ok” button. 

Step 3 
Defining the management actions and conditions. 

6) Click on the “Select Management” button.  
7) Select Thinning & Pruning Operations > Thin from below. 

a. Enter the residual density in terms of basal area: 100. 
8) Click on the “Ok” button to close the Thin from Below window. 
9) Select Planting & Natural Regeneration > Plant/Natural with Partial 

Establishment Model. 
a. Select the radio button to the left of the “Natural” keyword. 
b. Enter the parameters for lodgepole pine: 

Species ........................Douglas-fir 
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Trees/acre ....................10 
Percent survival ............100 
Ave. height ...................2.0 
Shade code ..................Most trees placed on sparse plots 
Leave all other fields set to default values 

c. Click the small radio button to the left of “Schedule by Condition”. 
d. Click on the “Condition” button.  
e. Change the name of the condition to “Condition – BA GE 225”. 
f. Click the down arrow on the drop box to the right of the Condition Library. 
g. Select the condition “Specified Basal Area is exceeded.” 
h. Set the basal area to 225. 
i. Set the years before the condition can be tested after being true to 0. 
j. Click on the “Free form” button.  
k. Click Proceed.  
l. Change “gt” to “GE”. 

10) Click on the “Ok” button. 
11) Click on the “Ok” button to close the Planting and Natural Regeneration window. 

 

Note: Using the “Free forms” button opens the code behind the scenes which can then 
be edited.  In this example the conditional statement automatically specifies greater 
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than and was changed to greater than or equal to.  The drop down tabs can be used to 
select mathematical operators and functions which can then be used within the 
conditional statements. 

12) Select Planting & Natural Regeneration > Plant/Natural with Partial 
Establishment Model. 

a. Select the radio button to the left of the “Natural” keyword. 
b. Enter the parameters for lodgepole pine: 

Species ........................Douglas-fir 
Trees/acre ....................30 
Percent survival ............100 
Ave. height ...................3.0 
Shade code ..................Most trees placed on sparse plots 
Leave all other fields set to default values 

c. Click the small radio button to the left of “Schedule by Condition”. 
d. Click on the “Condition” button.  
e. Change the name of the condition to “Condition – BA LT 225”. 
f. Click the down arrow on the drop box to the right of the Condition Library. 
g. Select the condition “Specified Basal Area is exceeded.” 
h. Set the basal area to 225. 
i. Change the Years before condition can be tested after being found true to 0. 
j. Click on the “Free form” button.  
k. Click on the “Proceed” button.  
l. Change Change “gt” to “LT”. 
m. Click on the “Ok” button. 

13) Click on the “Ok” button to close the Planting and Natural Regeneration window. 
14) Click the “Close” button to close the Management Actions window. 

Step 4 
Selecting the Post Processors.   

15) Click on the “Select Post Processors” button. 
16) Highlight the “View the Main Output file using system editor” post processor. 
17) Click on the “Include” button.  
18) Click on “Close” to close the Select Post Processors window.  

Final Step 
Running the simulation.   

19) Click on the “Run Simulation” button. 
20) Name the keyword file Conditional2-3.key. 
21) Click on the “Save” button. 
22) Click on the “Run” button. 
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Questions 

 From the Summary Statistics Table, in what year did the basal area first exceed 225? 

From the Regeneration Summary Tables, how many Douglas-fir seedlings were added 
into the simulation for each cycle?   

Extra Credit 

Set up a simulation such that in the year 2012 if the quadratic mean exceeds 7” a thin 

from above to a basal area of 75 is performed else a then from below to a basal area of 

100 and a prescribed burn is performed.   
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Exercise 2-4 – Customized Library of Condition Statements  

It may be useful to create a library of conditions that are used often.  For this exercise a 
library of different conditions will be created using a thinning event.  These conditions 
will then be applied to Exercise 2-1.  

Running the Simulation 

1) Make sure that no previous simulation is in memory.  
2) From the Preferences drop down tab, select “Suppose Preferences”. 
3) Change the default variant to “wc”. 
4) Click the “Apply” button. 
5) Click the “Close” button. 
6) Click File > New. 

Note: there is no need to select a stand for this exercise.  Changing the default variant 
to wc ensures that the condition library will be created for the wc variant.  The condition 
library should not be used with stands from another variant. If a stand is selected from 
another variant prior to adding a condition to the library of conditions, the variant will 
change and the condition will be attached to that variant only.  

Step 1 
Creating a condition.  

7) Click on the “Select Management” button  
8) Select Thinning & Pruning Operations > Thin from below. 

a. Click the small radio button to the left of “Schedule by Condition”. 
b. Click on Condition. 
c. Change the name of the condition to Condition – BA GT 100. 
d. Click the down arrow on the drop box to the right of the Condition Library. 
e. Select the condition “Specified Basal Area is exceeded.” 
f. Enter 100. 
g. Set the basal area to 100. 
h. Change the “Years before condition can be tested after being found true:” to 0. 

9) Click the “Ok” button. 
10) Click the “Ok” button to close the Thin from below window. 
11) Click the “Close” button to close the Management Actions window. 
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Note: This process created a condition for when the basal area is greater than 100 and 
the years before the condition can be tested after found being true equal to 0. 

Step 2 
Saving the condition to a file.   

12) In the Main window, highlight Condition – BA GT 100. 
13) Click on the “Write” button.   
14) Save the file as condlib.kcp.   
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Note: The file condlib.kcp is a special file that Suppose uses to hold user-defined 
condition statements.  This file did not exist until it was just created above. 

Step 3 
Adding conditions to the file.    

15) Open the Thin from Below management action by double clicking on it in the “Main” 
window. 

a. Click on Condition.  
b. Click on the “Free form” button. 
c. Click on the “Proceed” button.   
d. From the drop down tab beneath the FVS Functions select the Snags() 

function.   
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e. Click on the “Set Function Arguments” button.   
f. Change the lower limit DBH to 5. 
g. Leave all other fields set to default values 

 

h. Click on the “Ok” button. 
i. Click on the “Yes” button. 
j. Delete the equation in between the IF and Then statements. 
k. Click on the “Insert” button.   
l. After the Snags equation type GT 10. 
m. Change the name of the condition to Condition – Snags GT 10. 
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16) Click the “Ok” button. 
17) Click the “Ok” button to close the Thin from below window. 
18) In the Main window, highlight Condition – Snags GT 10. 
19) Click on the “Append” button. 
20) Select the condlib.kcp file 
21) Click “open”.    

Note: The new condition has now been added to your library. The “Free form” button 
allows access to the predefined equations found within FVS.  It can also be used in 
conjunction with user-defined event monitor variables.    

Step 4 
Opening a previous simulation. 

22) Make sure that no previous simulation is in memory. The title bar should say *new 
file* if the memory is clear. If a previous simulation is in memory, click File > New. 

23) Open Exercise 2-1 by selecting Open from the File dropdown tab and opening 
Conditional2-1.key. 
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Step 5 
Adding the condition.   

24) In the Main window, double -click the Thin from Below management action. 
25) Click on the “Condition” button.  

a. Change the dropdown tab which currently says Condition library: to Your 
Conditions:.   

b. Select Condition – BA GT 100 using the dropdown tab next to Your 
conditions:.   

c. Click the “Ok” button. 
26) Click “Ok” button to close the Thin from Below window. 

Final Step 
Running the simulation.   

27) Click on the “Run Simulation” button. 
28) Click on the “Save As” button.   
29) Name the keyword file Conditional2-4.key. 
30) Click on the “Save” button. 
31) Click on the “Run” button. 

Questions 

Extra Credit 

Include the following condition statements in your library: 
1- Basal area at the beginning of a cycle is less than 100 square feet per acre 
2- Trees per acre at least 15 inches in DBH at the beginning of a cycle is greater 

than 50 
3- Quadratic mean diameter for trees 10 inches in DBH or larger at the beginning of 

a cycle is greater than 20 inches.   
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Session 3- 
Advanced 

Management 
Activities 
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Introduction 

Often when creating thinning prescriptions they are more complex than just thinning to a 
specific target. More often than not you have to exclude certain trees from thinning 
based on their particular characteristics. For example you may not want to thin trees of 
a particular species or diameter. These exercises will help you create more complex 
management using the PARMS format. 

PARMS Format 

Many keyword records may be coded using the PARMS format.  This is a special form 
of the keyword record.  It is equivalent to the standard form of the keyword record, but it 
allows expressions in place of constant parameters.   

When using the PARMS format for a keyword record, the keyword is coded in the first 
eight columns, and the year/cycle (field 1) is coded right justified in column 20 as is 
done when this feature is not used.  The remainder of the record is coded 

  PARMS (parameter2, parameter3, parameter4, ... , parametern) 

where the word PARMS begins somewhere in columns 21 through 30.  Each 
“parametern” corresponds to the nth field of the keyword.  Its value is represented by an 
expression that uses constants, variables (Event Monitor pre-defined or user-defined), 
and/or Event Monitor functions.  If the keyword record is long, an ampersand (&) is used 
to continue the record on the following line.  

Below are three examples of the THINBBA keyword, the last two using the PARMS 
format. The first two would produce the exact same results of a residual target of 100 
ft2/acre. The last keyword would set the basal area target for the thin at 50% of the pre-
harvest amount. 

                                   columns 

         1         2         3         4         5         6         7         8 

....:....0....:....0....:....0....:....0....:....0....:....0....:....0....:....0 

 

ThinBBA         2012      100.        1.        0.      999.        0.      999. 

ThinBBA         2012     Parms(100., 1., 0., 999., 0., 999.) 

ThinBBA         2012     Parms(BBA*0.50, 1., 0., 999., 0., 999.) 

When using the PARMS format, supply all of the parameters used by the keyword.  
Defaults are not used when parameters are left blank. Ensure that all parameter values 
are within legal limits as FVS does not check for legal values when the PARMS format 
is used.  Also ensure that variables are defined when the activity is called.  If the 
PARMS function references a variable that is not defined when the activity is called, the 
activity is canceled. Additional information on the PARMS format can be found in 
section 6.1 of the EFVS Guide. 
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Exercise 3-1 – Thinning To a Stand Level Target with Diameter Limits 

Thinning to a stand level basal area per acre target such as 100ft2/acre can be done in 
FVS through the use of the THINDBH keyword or within the Management Action button 
and the Thinning & Pruning Operations – Thin throughout a diameter range option. 
More often than not you have to exclude certain trees from thinning based on their 
particular characteristics. For example you may not want to thin trees of a particular 
species or diameter.  

In this exercise, the PARMS format will be added to a thinning to exclude trees of a 
particular diameter class.  

Background Information 

This set of exercises, is based on silvicultural prescriptions for a small watershed with 6 
stands in it. The silviculturist, I.M. Solucky, has developed the future desired condition 
for the watershed and has begun by building some basic FVS simulations that will 
model the first step towards meeting the future desired condition for the watershed. I.M. 
Solucky’s plan was to keep the modeling simple, so she could spend less time behind 
the computer and more time in the woods. Three of the stands will get a thinning 
throughout the diameter distribution to 100 ft2/acre, another three stands will get a 
thinning from below to 90ft2/acre. After the initial Interdisciplinary (ID) Team meeting, 
I.M. Solucky, received significant feedback on her prescriptions from the other resource 
specialist on the team. She realizes that she is going to have to make some changes to 
her prescriptions. The following exercise will walk through adding complexity to thinning 
using the PARMS format and computed variables. 

Three of the stands in this project are to be thinned to 100ft2/acre, however  to avoid 
conflict and create collaboration, the Interdisciplinary Team decided it is necessary to 
reach the stand level target while avoiding the removal of trees greater than or equal to 
20 inches DBH. This adjustment can be easily done in FVS by using the PARMS 
function.  A custom variable will be created to calculate the basal area for trees greater 
than or equal to 20 inches DBH.  This custom variable will then be used within the 
PARMS function to reduce the target basal area for the thinning. 

Use the operators and pre-defined functions in Table 5-3 of the EFVS and the 
associated text following table 5-3 to write the expression for the basal area per acre for 
trees greater than or equal to 20 inches in DBH.  

BigBA = 

This variable will be used in the THINDBH keyword to set the residual basal area.  

residualBA = 100 - BigBA 
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Running the Simulation 

1) Start Suppose by double-clicking the Suppose icon on your desktop.  
2) Make sure that no previous simulation is in memory. The title bar should say *new 

file* if the memory is clear. If a previous simulation is in memory, click File > New. 
3) Click the File menu and select “Select Locations File” 
4) In the Open dialog box, navigate to “C:\Fvsdata\Regional-Training” and open the 

Suppose.loc file. 

Step 1 
Adding the stands to the simulation 

5) If the Select Simulation Stands window does not open, click on the “Select 
Stands” button on the main page. 
a. In the large “Locations” box select “Regional Training”. 
b. In the large “Groups” box select “Variant=WC”. 
c. In the large “Stands” box use the Ctrl Shift button and select 

“060305403015”, “060305403030”, and “060305403055”.  
d. At the bottom left corner, click the “Add 3 Stands” button.  

6) Click the “Close” button. 

Step 2 
Changing the time scale.   

7) Click on the “Set Time Scale” button. 
a. Change the common starting year from 2006 to 2012.  
b. Change the common ending year to 2052.  

8) Click the “OK” button. 

Note: This will grow the stand from 2006 to 2012 before growing the stand cycle by 
cycle. 

Step 3 
Adding the compute variables.   

9) Click the “Add Keywords” button. 
10) Select Base FVS system > Input/Output Controls > Compute. 
11) Click the “Accept” button.  

a. Change the name to “Compute Big Basal Area”. 
b. Change the “Schedule by Year/Cycle” field to “2012”.  
c. Click the “Use Parms” button. 
d. Click the “Proceed” button. 
e. Enter the expression for BigBA. 
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12) Click the “Ok” button.
 

 

Note: Custom variables can be created in the Parms editor window by typing in custom 
expressions directly or through the drop down menus that allow for the selection of a 
pre-defined function.  The “Set Function Arguments” button will walk through the 
functions associated with the selected function.  Compute variables can also be created 
using the “Select Outputs” button and selecting Event Monitor (EM) Compute 
Variables.   

Step 4 
Defining the management actions. 

13) Select Base FVS system > Thinning and Harvesting > THINDBH  
14) Click the “Accept” button.  

a. Change the name to “Thin Throughout 0 to 20 Inches”. 
b. Change the “Schedule by Year/Cycle” field to “2012”.  
c. Change the Largest DBH to be considered for removal to 20. 
d. Click the “Use Parms” button. 
e. Click the “Proceed” button. 
f. In the last argument of the ThinDBH keyword, enter 100-BigBA 

15) Click the “Ok” button.  
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16) Click the “Close” button to close the “Use FVS Keywords” window. 

 

Note: In the Regional Training course the Select Management button was used to 
create thinning management actions.  Many of the thinning management actions found 
in the Select Management button do not provide access to an editor (PARMS option).  
The individual keyword windows allow access to the PARMS format which allows for the 
use of functions and formulas as fields within keywords.  The last field of the THINDBH 
keyword indicates the residual basal area for the specified diameter range of interest. In 
this example, the target stand basal area is 100 which should be met without cutting 
trees greater than 20” DBH.  The basal area for trees greater than 20” DBH needs to be 
included in the stand target basal area of 100.  In other words: 

STANDTARGET-BIGBA= ResidualBA for trees less than 20” 

Step 5 
Selecting the Post Processors. 

 
17) Click on the “Select Post Processors” button. 

a. Highlight the “View the Main Output file using system editor” post processor. 
b. Click on the “Include” button.  
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c. Highlight the “Compute1 – Table of Compute Variables (with headers)” post 
processor. 

d. Click on the “Include” button. 
18) Close the “Select Post Processors” window. 

Final Step 
Running the simulation.   

19) Click on the “Run Simulation” button. 
20) Name the keyword file AdvMgt3-1.key. 
21) Click on the “Save” button. 
22) Click on the “Run” button. 

Note: Check the main output file for errors associated with your compute expressions. If 
an expression has a recognized problem, FVS will insert a FVS12 error after the 
expression in the Options Selected by Input section of the main output file. In addition, 
look in the Activity Summary to see that the Activity Disposition says “DONE IN 
<YEAR>” for the custom variable. If the disposition says “NOT DONE”, then you have 
an error in your expression. If your custom variable is not computed or there is no 
thinning, correct the expressions in Suppose. FVS does not check for legal values when 
the PARMS format is used.  Also ensure that variables are defined when the activity is 
called.  If the PARMS function references a variable that is not defined when the activity 
is called, the activity is canceled. A screen capture of the Compute expressions and 
THINDBH is located in the Answer Guide. Once you are satisfied that your expressions 
are functioning properly, rerun the simulation, close the output file.  
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Questions 

In the Compute post processor, add the before thin stand BA and after thin stand BA 
from the summary statistics table. You can do this by clicking on the “X=” button. On the 
right hand side put a check mark in the BBA and ABA boxes.    

How many stands have trees greater than 20” DBH for the year 2012? ______  

Did the thinning in 2012 produce a residual stand basal area of 100 for each stand? 
_______ 

                

Close the Compute post processor. 

Before you close Suppose save this prescription as an addfile (.kcp).  To do so: 

23) In the Simulation file contents Window, highlight “Compute Big Basal Area”. 
24) Click on the “Write” button. 
25) Name the addfile Rx1.kcp.  
26) Click “Save” button.  
27) Next Highlight “Thin Throughout 0 to 20 Inches”. 
28) Click on the “Append” button. 
29) Highlight Rx1.kcp. 
30) Click “Open”. 

 
The management action from this exercise (Prescription 1) is now saved as an addfile 
called Rx1.kcp. 
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Exercise 3-2 – Thinning, while retaining a hardwood component  

The prescriptions for stands 060305402956, 060305402995, and 060305403020 were 
to thin the stands from below to a target basal area of 90 ft2/acre. In FVS this type of 
thinning can be performed with a THINBBA keyword, or in Management Actions, 
selecting Thinning & Pruning Operations – Thin from Below.  I.M. Solucky’s prescription 
did not mention that some of the stands contained red alder, a species of interest which 
should not be thinned. Her plan was just to inform the marking crew to ignore the red 
alder when they went to mark the stand. The Interdisciplinary Team did not like this, and 
wants the modeling to show that the alder will be maintained, in addition to the 
90ft2/acre. To adjust for red alder in the prescription, a species preference can be 
associated with red alder. In addition, the thinning keywords need to be adjusted using 
the PARMS format. 

In this exercise, conifer species will be thinned from below to a target basal area of 90 
feet2/acre, while leaving the red alder component in the stand.  This will result in a post 
thinning basal area greater than 90 feet2/acre in stands that contain red alder.  A 
custom compute variable will be calculated for the basal area of red alder.  In addition, a 
species preference assigned to red alder will be used in conjunction with a thin from 
below to remove only conifer species in a stand.  

Use the operators and pre-defined functions in Table 5-3 of the EFVS and the 
associated text following table 5-3 to write the expression for the basal area per acre of 
red alder.  

RABA = 

This variable will be used in the THINBBA keyword to set the residual basal area.  

residualBA = 90 + RABA  

Running the Simulation 

1) Make sure that no previous simulation is in memory. The title bar should say *new 
file* if the memory is clear. If a previous simulation is in memory, click File > New. 

Step 1 
Adding the stands to the simulation. 

2) If the Select Simulation Stands window does not open, click on the “Select Stands” 
button on the main page. 
a. In the large “Locations” box select “Regional Training.” 
b. In the large “Groups” box select “Variant=WC.” 
c. In the large “Stands” box use the Ctrl Shift button and select 

“060305402956”, “060305402995”, “060305403020”. 
d. At the bottom left corner, click the “Add 3 Stands” button.  
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3) Click the “Close” button. 

Step 2 
Changing the time scale.   

4) Click on the “Set Time Scale” button. 
a. Change the common starting year from 2006 to 2012. 
b. Change the common ending year to 2052.  

5) Click the “OK” button. 

Step 3 
Adding the compute variables.   

6) Click the “Add Keywords” button. 
7) Select Base FVS system > Input/Output Controls > Compute. 
8) Click the “Accept” button.  

a. Change the name to “Compute Basal Area RA”. 
b. Change the “Schedule by Year/Cycle” field to a “2012”.  
c. Click the “Use Parms” button. 
d. Click the “Proceed” button. 
e. Enter the expressions for the red alder basal area (RABA). 

9) Click on the “Ok” button.  
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Step 4 
Adding a species preference.   

10) Select Base FVS system > All Keywords > SPECPREF 
11) Click the “Accept” button.  

a. Change the name to “Red Alder Species Preference”. 
b. Specify the year to thin to “2012”. 
c. Change the species to “red alder”. 
d.  Change the removal preference to -100  

12) Click on the “Ok” button.   

Note: The species removal priority equation is listed in the Species Preference form. 
This equation is used to determine which tree is cut first when thinning from above or 
below (but not throughout a diameter range).  For example, if a thin from below is 
conducted in a stand with a 5” DBH red alder and a 6” Douglas-fir; the Fd is equal to -1 
and the species removal preferences (P) are -5 and -6 respectively. In this case, red 
alder, the tree with the larger removal preference (-5 is greater than -6) will be cut first.  
If a species preference (SP) of -100 for red alder is added, the removal preferences (P) 
are -105 for red alder and -6 for Douglas-fir.  In this case, Douglas-fir will be cut first. If 
the species preference is negative it decreases the likelihood that the species will be 
cut.   

Step 5 
Defining the management actions. 

13) Select Base FVS system > All Keywords > THINBBA 
14) Click the “Accept” button.  

a. Change the name to “Thin From Below”. 
b. Specify the year to thin to “2012”. 
c. Click on the “Use Parms” button. 
d.  Click on the “Proceed” button. 
e. Enter an equation for the red alder basal area in the first field of the THINBBA 

keyword. 
15) Click the “Ok” button.  
16) Click the “Close” button 
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Note: This window sets the Thinning keyword up in the PARMS format, which allows for 
computations. The first field of the THINBBA keyword specifies the target basal area for 
the specified diameter range.  To obtain a residual basal area of 90 for all trees 
excluding the basal area of red alder, the target basal area is set up as 90+RABA.  This 
adjusts the basal area target for the excess red alder.   

Step 6 
Selecting the Post Processors. 

17) Click on the “Select Post Processors” button. 
a. Highlight the “View the Main Output file using system editor” post processor. 
b. Click on the “Include” button.  
c. Highlight the “Compute1 – Table of Compute Variables (with headers)” post 

processor. 
d. Click on the “Include” button. 

18) Close the “Select Post Processors” window.  
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Final Step 
Running the simulation.   

19) Click on the “Run Simulation” button. 
20) Name the keyword file AdvMgt3-2.key. 
21) Click on the “Save” button. 
22) Click on the “Run” button. 
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Questions 

In the Compute post processor, add the before thin stand BA and after thin stand BA 
from the summary statistics table. You can do this by clicking on the “X=” button. On the 
right hand side put a check mark in the BBA and ABA boxes. 

Fill in the red alder basal area for each stand in 2012? 

060305402956= _________ 060305402995= _________ 060305403020= _________ 

Fill in the post harvest stand basal area in 2012?  

060305402956= _________ 060305402995= _________ 060305403020= _________ 

Can you think of a way to not have to create compute statements for the two variables 
(BigBA and RABA), but still get FVS to do the thinning correctly? 

Close the Compute post processor. 

Before you close Suppose save this prescription as an addfile (.kcp).  To do so: 

23) In the Simulation file contents Window, highlight “Basal Area Red Alder”. 
24) Click on the “Write” button. 
25) Name the addfile Rx2.kcp.  
26) Click on the “Save” button.  
27) In the Simulation file contents Window, highlight “Red Alder Species Preference”. 
28) Click on the “Append” button. 
29) Highlight Rx2.kcp. 
30) Click “Open”. 
31) Next Highlight “Thin From Below”. 
32) Click on the “Append” button. 
33) Highlight Rx2.kcp. 
34) Click “Open”. 

The management action from this exercise (Prescription 2) is now saved as an addfile 
called Rx2.kcp.  
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Exercise 3-3 – Running multiple stand with multiple prescriptions in 
one simulation 

Grouping labels can be used to apply management to groups of stands in a single 
simulation. After writing the base prescriptions found in the previous exercises, the 
Interdisciplinary Team determined that stand 060305402956 should not be thinned. All 
six stands from the previous exercises need to be run in the same simulation, applying 
the stands specific prescription created from Exercises 3-1 and 3-2.  

In this exercise, grouping labels will be applied based on the prescription each stand is 
to receive.   

Stands 060305403015, 060305403030, and 060305403055 will be assigned to the 
grouping label “Rx1: EvenThin”; stands 060305402995, and 060305403020 will be 
assigned to the grouping label “Rx2:ThinBelow”; and stand 060305402956 will be 
assigned to the grouping label” Rx0:NoThin”.  After the stands are grouped, the 
prescriptions created in Exercise 3-1 and Exercise 3-2 will be applied.  Stand level 
compute variables which will describe the pre- and post- thinning stand-level variables 
will also be calculated.  The variables of interest are pre and post basal area, the 
percent basal area removed, harvested volume in board feet, acres, and total volume 
per stand. 

Running the Simulation 

Step 1 
Adding grouping codes to the input database. 

1) Navigate to the “C:\FVSDATA\Regional-Training” folder. 
2) Open the database “FVS_Data.mdb”. 
3) Open the “FVS_StandInit” table.  
4) Select the stands for the WC variant. 

a. In the third column, “Variant”, click on the small black arrow next to column 
heading.  

b. Uncheck “Select All”. 
c. Check “WC”. 
d. Click on the “Ok” button. 

5) Navigate to the “Groups” column.  
6) Add new grouping codes to each stand.  
7) Save the changes to the database. 
 
Note: Use the grouping codes that were listed above in the introduction for Exercise 3-3.  
Remember that grouping codes cannot have spaces in the name. Use the snapshot on 
the next page as a comparison.   



70 

 

 

Step 2 
Adding the stands to the simulation. 

8) Make sure that no previous simulation is in memory. The title bar should say *new 
file* if the memory is clear. If a previous simulation is in memory, click File > New. 

9) Click the File menu and select “Select Locations File” 
10) In the Open dialog box, navigate to “C:\Fvsdata\Regional-Training” and open the 

Suppose.loc file. 
11) If the Select Simulation Stands window does not open, click on the “Select Stands” 

button on the main page. 
a. In the large “Locations” box select “Regional Training.” 
b. In the large “Groups” box select “Variant=WC.” 
c. In the large “Stands” box use the Ctrl Shift button and select 

“060305402956”, “060305402995”, “060305403020”, “060305403015”, 
“060305403030”, “060305403055” 

d. At the bottom left corner, click the “Add 6 Stands” button.  
12) Click the “Close” button. 

Step 3 
Changing the time scale.   

13) Click on the “Set Time Scale” button. 
a. Change the common starting year from 2006 to 2012. 
b. Change the common ending year to 2052.  

14) Click the “OK” button. 

Step 4 
Defining the management actions. 

15) In the Simulation file contents window click on the plus sign next to stand 
“060305403015”.  

16) Under the grouping codes, right click on “Rx1:EvenThin”.  
17) Click on the “Insert From File” button. 
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18)  Navigate to the Rx1.kcp file and highlight it. 
19) Click “Open”. 
20) Click on the plus sign next to stand 060305402995.  
21) Under the grouping codes, right click on “Rx2:ThinBelow”. 
22)  Click on the “Insert From File” button. 
23)  Navigate to the Rx2.kcp file and highlight it. 
24) Click “Open”. 
25) Right click “Group:All” 

Note: Another option for assigning the prescriptions to each stand would be to rebuild 
the prescriptions following the steps in Exercises 3-1 and 3-2.  Because the 
prescriptions were saved to an addfile (.key file), they can instead be applied directly to 
the stands.  When selecting grouping codes, the stands that are affected will be listed in 
the “Affected Stands” box to the right of the “Simulation file contents” window. To set the 
affected groups back to All Stands, right click on the “Group:All” grouping code, this 
insures that any additional selections such as computed variables and post processors 
are applied to all stands. 

Step 5 
Adding the compute variables. 

26) Click on the “Add Keywords” button. 
27) Select Base FVS system > Input/Output Controls > Compute.  
28) Click on the “Accept” button. 

a. Change the name to “Compute Thinning Variables”. 
b. Change the “Schedule by Year/Cycle” field to a “2012”.  
c. Click on the “Use Parms” button. 
d. Click the “Proceed” button. 
e. Enter expressions for pre and post thinning basal area, the percent basal area 

removed, harvested volume in board feet, acres, and total volume per stand. 
29) Click on the “Ok” button.  
30) Click on the “Close” button.  



72 

 

 

Step 6 
Creating the outputs.  

31) Click on the “Select Outputs” button. 
32) Select Base FVS Reports > Delete Base Model Reports. 
33) Check “Delete the stand composition table” and “Delete the selected sample tree 

table”. 
34) Click on the “Ok” button. 
35) Click on the “Close” button to close the Model Outputs window. 

Note: These are two tables in the Main Output file that are rarely looked at and take up 
a large amount of space. 

Step 7 
Selecting the Post Processors. 

36) Click on the “Select Post Processors” button. 
a. Highlight the “View the Main Output file using system editor” post processor. 
b. Click on the “Include” button.  
c. Highlight the “Compute1 – Table of Compute Variables (with headers)” post 

processor. 
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d. Click on the “Include” button. 
37) Click on the “Close” button to close the “Select Post Processors” window. 

Final Step 
Running the simulation.   

38) Click on the “Run Simulation” button. 
39) Name the keyword file AdvMgt3-3.key. 
40) Click on the “Save” button. 
41) Click on the “Run” button. 

Questions 

Fill in the information below for each stand:  

  060305402956 060305402995 060305403020 060305403015 060305403030 060305403055 

Residual 
Basal Area             

Total 
Volume 
Harvested             

Before closing Suppose save your Compute variables to an addfile (.kcp). To do so: 

1) In the Simulation file contents Window, highlight “Compute Thinning Variables”. 
2) Click on the “Write” button. 
3) Name the addfile “HarvCompute.kcp”. 
4) Click on the “Save” button.  

The six compute variables have now been saved as an addfile. 
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Exercise 3-4 – Applying Addfiles Directly to the Input Database 

In this exercise, addfiles and keywords will be applied directly to a database.  This will 
bring in the keywords into FVS along with the stand information.   

The Interdisciplinary Team is finally satisfied with I.M. Solucky’s prescriptions and the 
output provided (obviously not a true story). Since the team is happy, and there is a 
blizzard outside I.M. Solucky decides to try a few shortcuts using some of the database 
functionality. 

Running the Simulation 

Step 1 
Navigating to the input database. 

1) Navigate to the C:\FVSDATA\Regional-Training and open up the database 
FVS_Data.mdb 

2) Open up the FVS_GroupAddfilesAndKeywords table.  

Note: The first column is “Groups”,the second column is “Addfiles: and the third Column 
is Keywords. This table allows a user to apply addfiles (.kcp file extension) or keyword 
based on group codes. We are going to apply both prescription 1 and 2 based on their 
group code. 

Step 2 
Adding the prescriptions. 

3) In the third row, in the Groups column, type “Rx1:EvenThin”, and in the same row in 
the Addfiles column type Rx1.kcp. 

4)  In the fourth row, in the Groups column, type “Rx2:ThinBelow”, and in the same row 
in the Addfiles column type Rx2.kcp. 

Step 3 
Adding the compute variables. 

5) In the fifth row, in the Groups column, type “All_Stands”, and in the same row in the 
Addfiles column type HarvCompute.kcp. 

Note: In addition to the addfiles, the tables requested in Exercise 3-3 will be deleted 
from the Main output file.  An addfile (.kcp file extension) was never created to do this.  
To do this, the keywords that delete the tables will be copied and pasted in to the 
“Keywords” column of the database. 
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Step4 
Deleting the output tables. 

6) Go to Suppose, make sure AdvMgt3-3.key is in the simulation file content window. 
7) Highlight “Delete Base Model Reports”. 
8) In the main dropdown menu bar, select Simulation Preparation > View 

Component Keywords. 
9) Highlight both lines. 
10)  In the main dropdown menu bar, select Edit > Copy 

 

Note: The View Component Keywords lists the keywords Suppose is using in the 
simulation. Rather than typing and formatting the keywords directly into the database, 
copy and paste the keywords to decrease the likelihood of making mistakes.  

11) Navigate back to the FVS_Data.mdb, FVS_GroupAddFIlesAndKeywords table. 
12) In the fifth row, in the Keywords column, paste the two lines. 
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Your database should look like this. 

FVS_GroupAddFilesAndKeywords 

Groups Addfiles FVSKeywords 

All_Plots  Database 
DSNIn 
FVS_Data.mdb 
StandSQL 
SELECT *  
FROM FVS_PlotInit  
WHERE StandPlot_CN= '%Stand_CN%' 
EndSQL 
TreeSQL 
SELECT *  
FROM FVS_TreeInit  
WHERE StandPlot_CN= '%Stand_CN%' 
EndSQL 
END 

All_Stands  Database 
DSNIn 
FVS_Data.mdb 
StandSQL 
SELECT *  
FROM FVS_StandInit  
WHERE Stand_CN= '%Stand_CN%' 
EndSQL 
TreeSQL 
SELECT *  
FROM FVS_TreeInit  
WHERE Stand_CN= '%Stand_CN%' 
EndSQL 
END 

Rx1:EvenThin Rx1.kcp  

Rx2:ThinBelow Rx2.kcp  

All_Stands HarvCompute.kcp DelOTab 1 
DelOTab 2 

13) Save and Close your Database. 
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Step 5 
Adding the stands to the simulation. 

14) Make sure that no previous simulation is in memory. The title bar should say *new 
file* if the memory is clear. If a previous simulation is in memory, click File > New. 

15) Click the File menu and select “Select Locations File” 
16) In the Open dialog box, navigate to “C:\Fvsdata\Regional-Training” and open the 

Suppose.loc file. 
17) If the Select Simulation Stands window does not open, click on the “Select Stands” 

button on the main page. 
a. In the large “Locations” box select “Regional Training.” 
b. In the large “Groups” box select “Variant=WC.” 
c. In the large “Stands” box use the Ctrl Shift button and select 

“060305402956”, “060305402995”, “060305403020”, “060305403015”, 
“060305403030”, “060305403055” 

d. At the bottom left corner, click the “Add 6 Stands” button.  
18) Click the “Close” button. 

Step 6 
Changing the time scale.   

19) Click on the “Set Time Scale” button. 
a. Change the common starting year from 2006 to 2012. 
b. Change the common ending year to 2052.  

20) Click the “OK” button. 

Step 7 
Selecting the Post Processors. 

21) Click on the “Select Post Processors” button. 
a. Highlight the “View the Main Output file using system editor” post processor. 
b. Click on the “Include” button.  
c. Highlight the “Compute1 – Table of Compute Variables (with headers)” post 

processor. 
d. Click on the “Include” button. 

22) Click on the “Close” button to close the “Select Post Processors” window. 

Final Step 
Running the simulation.   

23) Click on the “Run Simulation” button. 
24) Name the keyword file AdvMgt3-4.key. 
25) Click on the “Save” button. 
26) Click on the “Run” button. 
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Note: By applying the addfiles and keywords in the FVS_GroupAddFIlesAndKeywords, 
the addfiles or keywords are automatically included in the simulation whenever the 
stand is added into Suppose. 

Questions 

Do the results in 3-3 match the results in 3-4?    
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Answer Guide 
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Exercise 1-1 – Creating Custom Variables Using Event Monitor 
Variables and Functions 

_Tpa20p  = SpMcDBH(1,All,0,20.,999.,0.,999.,0,0.) + & 

             Snags(1,All,0,20.,999.,0.,999.,0)  

_CrBio   = TreeBio(-1,1,0,All,DBHDist(5,3),999.,0.,999.) 

_TpaMid  = SpMcDBH(1,All,0,0.,999.,0.,30.,0,0.) 

_PCDW3p  = DWDVal(2,0,2,7) 

Custom Variable Expressions: Screen capture of Compute keyword editor window with 
attribute expressions.  
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Fill in the table with your results. 

Year 
Resting      

Score 
Foraging   

Score 
Regress   

Score 
Hiding Cover 

Score 

2012 0 0 2 3 

2042 2 1 1 3 

2072 3 2 0 3 

2102 3 3 0 2 
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Exercise 1-2 – Creating Indices Using Conditional Statements and the 
LinInt Function 

RestSc  = LinInt(_Tpa20p,5,5,15,15,25,25,0,1,1,2,2,3) 

ForagSc = LinInt(_CrBio,7.5,7.5,12.5,12.5,17.5,17.5,0,1,1,2,2,3) 

RegrsSc = LinInt(_TpaMid,100,100,200,200,300,300,0,1,1,2,2,3) 

HideSc  = LinInt(_PCDW3p,5,5,10,10,15,15,20,20,25,25,30,30, & 

                         0, 1, 1, 2, 2, 3, 3, 2, 2, 1, 1, 0) 
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Fill in the table with your results. 

Year Resting      
Score 

Foraging   
Score 

Regress   
Score 

Hiding/Regress 
Cover Score 

2012 0 0 2 3 

2042 2 1 1 3 

2072 3 2 0 3 

2102 3 3 0 2 

Do these results match what you wrote down in the previous exercise? It should.  If not, 
check both exercises for errors.   
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Exercise 1-3 – Adding Custom Variables Using Database – Event 
Monitor Connectivity 

SQLIn keyword logic: 

SQLIn              1    

SELECT MOISTURE 

FROM FVS_StandInit 

WHERE Stand_ID = '%StandID%' 

EndSQL 

What is the MRI and MRI score for this stand: 3.10 and 1.00, respectively. 
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Exercise 1-4 – Sending Custom Variables to a Database 

1st Option: Conditional Compute with LinInt 

IF                 0 

MRISc EQ 1 

Then 

Compute            0 

ScSum = RestSc + ForagSc + RegrsSc + HideSc 

CatMrIdx = Linint(ScSum,3,4,8,10,11,0.00,0.25,0.50,0.75,1.00) 

End 

Endif 

IF                 0 

MRISc EQ 0 

Then 

Compute            0 

CatMrIdx = 0 

End 

Endif 

2nd Option: Compute with LinInt  function 

Compute            0 

ScSum = RestSc + ForagSc + RegrsSc + HideSc 

CatMrIdx = LinInt(MRISc,1,1,0, &           

Linint(ScSum,3,4,8,10,11,0.00,0.25,0.50,0.75,1.00)) 

End 

3rd Option: Single LinInt function 

Compute            0 

CatMrIdx = LinInt(MRISc,1,1,0, & 

           Linint(RestSc + ForagSc + RegrsSc + HideSc, & 

           3,4,8,10,11,0.00,0.25,0.50,0.75,1.00)) 

End 
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American Catmar Suitability Index 

Stand ID 2012 2052 2112 

060305402956 0.31 0.62 0.50 

060305402995 0.25 0.62 0.44 

060305403015 0.00 0.00 0.00 

060305403020 0.44 0.50 0.44 

060305403030 0.00 0.00 0.00 

060305403055 0.00 0.00 0.00 

Average Value 0.17 0.29 0.23 
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Extra credit 

Reorganize the custom variables so that you use less than 5 custom variables. 

Compute            0 

RestSc  = LinInt(SpMcDBH(1,All,0,20.,200.,0.,500.,0,0.) + & 

Snags(1,All,0,20.,999.,0.,999.,0) &  

,5,5,15,15,25,25,0,1,1,2,2,3) 

ForagSc = LinInt(TreeBio(-1,1,0,All, & 

DBHDist(5,3),200.,0.,500.)& 

,7.5,7.5,12.5,12.5,17.5,17.5,0,1,1,2,2,3) 

RegrsSc = LinInt(SpMcDBH(1,All,0,0.,200.,0.,30.,0,0.) &  

,100,100,200,200,300,300,0,1,1,2,2,3) 

HideSc  = LinInt(DWDVal(2,0,2,7), &   

5,5,10,10,15,15,20,20,25,25,30,30, & 

0,1, 1, 2, 2, 3, 3, 2, 2, 1, 1, 0) 

CatMrId2 = LinInt(MOISTURE,2.5,2.5,0, & 

Linint(RestSc + ForagSc + RegrsSc + HideSc, & 

3,4,8,10,11,0.00,0.25,0.50,0.75,1.00)) 

End 
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Exercise 2-1 – Conditionally Scheduling Multiple Management 
Activities 

What FVS keywords were added to the simulation to perform the conditional thinning, 
prescribed burn, and natural regeneration? 

Condition – IF and THEN, Thin from below – THINBBA, Prescribed burn – SIMFIRE 
Natural regeneration – ESTAB, SPROUT, NATURAL, PLANT 

How many times was the stand thinned? Three times 
Did the stand get thinned every time basal area exceeded 100? yes 

When did the natural regeneration get entered into the simulation?  
Natural regeneration - 2006, 2024, 2022, and 2042 

 

  



89 

 

Extra Credit 

To adjust the simulation run so that you have a minimum waiting time of 40 years 
between thinning events and so that thinning does not occur in cycle 1 you will need to 
use the free form button on the condition statement.   

IF                40 
bba gt   100 and cycle GT 1 
Then 
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Extra Extra Credit  

To adjust the simulation run so that you base the conditional thinning on basal area in 
trees greater than 5” DBH you can use the SpMcDBH function found by using the 
dropdown tab located under FVS Functions 

IF                40 

SpMcDBH(2,All,0,5,200.,0.,500.,0,0.) gt 100 and cycle gt 1 

Then 
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Exercise 2-2 – Conditionally Scheduling Based on a Random Event 

In which years is the random number less than 0.10?  2006 

 

Did the conditional statement appear? Yes 

Did a fire occur?  Yes. If so, in what year?  2006. What random number caused the fire 
to occur?  0. Did regeneration occur 2 years after the fire? Yes 
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Extra Credit 

When you ran the simulation again, did you obtain the same results?  Yes.  
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Extra Extra Credit 

To export the compute variable to an excel file:  
1) Click on the “Select Outputs” button. 
2) Select Database Extension > Specify Output Database. 

a. Select a name for your .xls database. 
3) Click on the “Ok” button. 
4) Select Event Monitor (EM) Compute Variables > Build Compute Table in 

Database. 
5) Click on the “Ok” button. 

Here is an example of what the pivot chart might look like.   The chart should show no 
discernable patterns as each value between 0 and 1 has an equal chance of being 
selected.   
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Exercise 2-3 – Scheduling Alternative Management Activities Based 
Upon a Condition 

From the Summary Statistics Table, in what year did the basal area begin to exceed 
225? 2042 

How many lodgepole seedlings were added into the simulation for each cycle?   

2007- 30, 2013- 30, 2023- 30, 2033- 30, 2043- 10, 2053- 10, 2063- 10 
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Exercise 2-4 – Customized Library of Condition Statements 

Extra Credit 

Include the following condition statements in your library: 
1- Basal area at the beginning of a cycle is less than 100 square feet per acre 

BBA LT 100 
2- Trees per acre at least 15 inches in DBH at the beginning of a cycle is greater 

than 50 
SpMcDBH(1,All,0,15,200.,0.,500.,0,0.) GT 50 

3- Quadratic mean diameter for trees 10 inches in DBH or larger at the beginning of 
a cycle is greater than 20 inches.   

SpMcDBH(5,All,0,10,200.,0.,500.,0,0.) GT 20 
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Exercise 3-1 – Thinning To a Stand Level Target with Diameter Limits 

Compute         2012 

BigBA=SpMcDBH(2,All,0,20,200.,0.,500.,0,0.) 

End 

* Arguments: SmDBH, LgDBH, CutEff, Species, ResTPA, ResBA 

ThinDBH         2012     Parms(0., 20, 1., All, 0., 100-BigBA) 

How many stands have trees greater than 20” DBH for the year 2012: 1 

Did the thinning in 2012 produce a residual stand basal area of 100 ft/acre for each 
stand: Yes 
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Exercise 3-2 – Thinning, while retaining a hardwood component  

Compute         2012 

RABA=SpMcDBH(2,RA,0,0.,200.,0.,500.,0,0.) 

End 

* Arguments: ResBA, CutEff, SmDBH, LgDBH, SmHt, LgHt 

ThinBBA         2012     Parms(90+RABA, 1., 0., 999., 0., 999.) 

Fill in the red alder basal area for each stand in 2012? 

060305402956= 6.48 060305402995= 0.00  060305403020= 21.77  

Fill in the post harvest stand basal area in 2012?  

060305402956= 96   060305402995= 90   060305403020=112  

ThinDBH         2012     Parms(0,20,1,All,0, & 

100-SpMcDBH(2,All,0,20,200)) 

ThinBBA         2012   Parms(90+SpMcDBH(2,RA,0),1,0,999,0,999) 
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Exercise 3-3 – Running multiple stand with multiple prescriptions in 
one simulation 

Compute         2012 

PreBA=BBA 

residBA=ABA 

BA%rmvd=100-(ABA/BBA)*100 

HarvVol=SpMcDBH(4,All,0,0.,200.,0.,500.,2,0.) 

ACRES=SampWt 

VOLxACRE=HarvVol*ACRES 

End 
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Exercise 3-4 – Applying Addfiles Directly to the Input Database 

FVS_GroupAddFilesAndKeywords 

Groups Addfiles FVSKeywords 

All_Plots  Database 
DSNIn 
FVS_Data.mdb 
StandSQL 
SELECT *  
FROM FVS_PlotInit  
WHERE StandPlot_CN= '%Stand_CN%' 
EndSQL 
TreeSQL 
SELECT *  
FROM FVS_TreeInit  
WHERE StandPlot_CN= '%Stand_CN%' 
EndSQL 
END 

All_Stands  Database 
DSNIn 
FVS_Data.mdb 
StandSQL 
SELECT *  
FROM FVS_StandInit  
WHERE Stand_CN= '%Stand_CN%' 
EndSQL 
TreeSQL 
SELECT *  
FROM FVS_TreeInit  
WHERE Stand_CN= '%Stand_CN%' 
EndSQL 
END 

Rx1:EvenThin Rx1.kcp  

Rx2:ThinBelow Rx2.kcp  

All_Stands HarvCompute.kcp DelOTab 1 
DelOTab 2 

Do the results in 3-3 match the results in 3-4? YES  
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The U.S. Department of Agriculture (USDA) prohibits discrimination in all its programs 
and activities on the basis of race, color, national origin, sex, religion, age, disability, 
political beliefs, sexual orientation, or marital or family status. (Not all prohibited bases 
apply to all programs.) Persons with disabilities who require alternative means for 
communication of program information (Braille, large print, audiotape, etc.) should 
contact USDA’s TARGET Center at (202) 720-2600 (voice and TDD). 

To file a complaint of discrimination, write USDA, Director, Office of Civil Rights, Room 
326-W, Whitten Building, 1400 Independence Avenue, SW, Washington, DC 20250-
9410 or call (202) 720-5964 (voice or TDD). USDA is an equal opportunity provider and 
employer. 


