USDA Logo and Forest Service Shield
Forest Vegetation Simulator

FVS Technical Support

FVS Technical Support The FVS Staff of the Forest Management Service Center provides technical support for the Forest Vegetation Simulator. You may contact the FVS Helpdesk by telephone or by e-mail. When contacting the FVS Helpdesk be prepared to provide the following information:

  1. Name the program and the version you are using. You can find the FVS version number in the top-center of the Main FVS output file.
  2. Provide a brief description of the problem.
  3. If the problem is reproducible, please list the steps required to cause it. If the problem is not reproducible (only happened once, or occasionally for no apparent reason), please describe the circumstances in which it occurred and the symptoms observed.
  4. Note whether the problem causes any error messages to appear, and note in your message the exact text displayed.
  5. Please provide us with the following contact information:
    1. Name
    2. Organization
    3. Phone/E-mail Address

Telephone Number: (970) 295-5770

E-mail Address: wo_ftcol_fvs@fs.fed.us

Frequently Asked Questions (FAQs)

The FVS Staff has summarized some of the questions most commonly asked regarding its products. Follow one of the links below to the related FAQs page to see if your question has already been answered.

Questions (with link to Answer)

  1. How much hard disk space does the FVS setup package require?
  2. How do I determine which geographic variant to use with my data?
  3. How do I update a geographic variant if I already have FVS on my PC?
  4. How can I find out which variants support which Extensions?
  5. How do I configure Suppose to start in the folder where my data files reside, not in the \Fvsbin folder?
  6. What causes the error message "Suppose cannot open locations file: suppose.loc" when I click the Select Simulation Stands command button from the main Suppose window?
  7. How can I modify an existing simulation file, but keep a copy of the original?
  8. How do I get an existing simulation file back into the Suppose program?
  9. Can I use an existing simulation with a new stand?
  10. Can I modify one part of an existing simulation without rebuilding the entire thing?
  11. Why do I get the warning “stand(s) were not processed because the variants they require are either not available or are blocked from use due to prior selections" when I am trying to add a stand to a simulation?
  12. Why do my simulation results not change when I replace a keyword with one that has different values entered?
  13. What's the difference between "Management Actions" and "Keywords"?
  14. How do I change the default editor in Suppose?
  15. I recently downloaded an FVS Model Extension (e.g., climate or parallel processor) but it does not show up in the "Use FVS Keywords" window in the left text box under Extensions. Why?
  16. Why can't I find the regeneration keywords in the "Use FVS Keywords" window?
  17. What does the warning "Suppose does not insure correct keywords when you use this option" mean?
  18. I included a post processor in my simulation. Why is the output file blank?
  19. What is the difference between the "FVSSTAND Alone" post processor and the "Stand and Stock Tables" post processor?
  20. Are there any additional options for the post processors, like changing the diameter classes in the Stand and Stock Tables, or averaging computed variables by stand acreage?
  21. Why do I get the warning message "Cannot open treelist file... Are you sure the file is an SVS tree list?" when using SVS as a post-processor?
  22. How many growth sample trees does FVS need for local stand/plot calibration?
  23. I am using variants in Region 5 or 6 and I notice growth and mortality are not what I expected, or the stand is growing too much volume. Why?
  24. Why are the residual trees per acre or basal area higher than the value I set on the harvest keyword?
  25. Why is there regeneration in the simulation even though I did not schedule any?
  26. I have included a CFVOLEQU (or BFVOLEQU) keyword; however, my volumes have not changed. Why?
  27. In my keyword set the keywords and parameters seem to be correctly aligned in the correct columns/fields but FVS doesn't seem to run certain keywords.
  28. What does the merchantable cubic feet volume column include in the Summary Statistics Table in the Eastern variants (LS, SN, NE, SE, CS)?
  29. Does tree value class affect volume?
  30. Which damage codes are valid in the base version of FVS?
  31. What causes the Summary Statistics table in the main FVS output file to be filled with all zeros?
  32. Why do I get the warning message “******** FVS08 WARNING: TOO FEW PROJECTABLE TREE RECORDS”?
  33. What causes the error message “*****WARNING, INVALID FOREST TYPE WAS INPUT BY USER, DEFAULT INITIAL FOREST TYPE WILL BE CALCULATED BY MODEL” when using the Southern Variant?
  34. What does the error message “WARNING: THIS LABEL SET IS SHORTER THAN THE ONE YOU SPECIFIED” mean?
  35. What does the warning message “WARNING: INITIAL STAND STOCKING OF x TREES/ACRE IS MORE THAN 5% ABOVE THE UPPER LIMIT OF y TREES/ACRE. UPPER LIMIT IS BASE ON A SDI MAXIMUM OF z , AND AN UPPER BOUND OF xx % OF MAXIMUM. MAXIMUM SDI BEING RESET TO xxx FOR FURTHER PROCESSING” mean?
  36. What causes the message in the output file indicating that the “[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified”?

Questions and Answers

How much hard disk space does the FVS setup package require?
The space required for the installation for a single Region is typically 50 to 100 MB, depending on the Region. Installation for all Regions requires over 200 MB. When you consider you will be using your own data and likely making multiple runs, the space required for data can also become quite large. We suggest there should be at least 100 MB for project data and run results, but this could vary based on the size and scope of the project and the number of runs performed.

Back to Top

How do I determine which geographic variant to use with my data?
If the data files have already been correctly created, Suppose will read the geographic variant information from the Stand List File or the StandInit table of the input database when a stand is added to the simulation. That variant will be used for the entire simulation.

If you are creating the data files yourself, you will need to specify in the Stand List File or StandInit table of the input database which variant you want to use. The What is FVS? page contains a map of the approximate geographic areas covered by the different variants. If you need information that is more specific, look at the descriptions in the Variant Overview documents. If your area falls near the boundary between several variants, you may need to experiment with each to see which most realistically represents your area.

Back to Top

How do I update a geographic variant if I already have FVS on my PC?
To update a variant, go to the Geographic Variant Installer Files web page on the FVS website. Download the desired Variant Installer File. Once downloaded, run it by double-clicking it. The installation process will overwrite any old executables of the same variant in the \Fvsbin folder. Note that only the variant files are updated with this process. The Suppose interface, post processors, etc., are not updated.

Back to Top

How can I find out which variants support which Extensions?
Go to the FVS Variant Key and Included Extensions page on the FVS website.

Back to Top

How do I configure Suppose to start in the folder where my data files reside, not in the \Fvsbin folder?
Go to the Create or Change a Suppose Shortcut page for a detailed explanation of how to create or change the Suppose Windows shortcut.

Back to Top

What causes the error message "Suppose cannot open locations file: suppose.loc" when I click the Select Simulation Stands command button from the main Suppose window?
Suppose uses the suppose.loc file to determine the location of your input data. This message means Suppose can’t find the suppose.loc file in the directory where it is looking. To locate this file manually, click on the File menu and choose Select Locations File. Navigate to where your suppose.loc file resides and open it.

If you want to create or change the Suppose Windows shortcut, so Suppose looks in a particular directory by default, go to the Create or Change a Suppose Shortcut page for a detailed explanation of the process used.

Back to Top

How can I modify an existing simulation file, but keep a copy of the original?
With the Suppose interface program running, click on the File menu and select Open. Open the desired simulation file. Click on the File menu and select Save As. Give the simulation a new name. Modifications will now be made to the new file you just created. The original file will be left unchanged.

Back to Top

How do I get an existing simulation file back into the Suppose program?
Simulations are saved in files with the .key extension. With the Suppose interface program running, click the File menu and select Open. Find the filename of the simulation you would like to open. You may need to navigate to a different directory if the file was saved in a directory other than the current one. Highlight the desired filename and click the Open button to open it.

Back to Top

Can I use an existing simulation with a new stand?
Yes, as long as the new stand uses the same geographic variant as the current stand(s). Open the existing simulation in the Suppose interface program. Click the Select Simulation Stands button. If the current stand(s) are not needed, click the Delete Stand button, delete the currently included stand(s) and close the Delete Stand window. Now include the new stand. In order to leave the original simulation file unchanged, click the File menu and select Save As, then give the new simulation a name different than the original simulation.

When using the Suppose interface program, keywords are invisibly labeled with an indicator of the geographic variant that was being used when they were included in the simulation. Even when all stands in a simulation have been deleted, that invisible label remains. If the stand you intend to use is set up to use a different geographic variant than the original stand(s) you will see the warning message "stand(s) were not processed because the variants they require are either not available or are blocked from use due to prior selections." That stand, as currently configured, will not be able to be used with the existing simulation.

Back to Top

Can I modify one part of an existing simulation without rebuilding the entire thing?
Yes. If you simply need to add new components, open the simulation file in the Suppose interface program, then use the Management Actions or Use FVS Keywords buttons. If you need to delete a component, highlight it and click the Delete button. If you need to change the parameters in an existing component, highlight the component and click the Edit Selection button. That component will open in the same window that was originally used to create it, and all of the specified values will be displayed. Change the desired parameters and click OK.

If you need to move a component to a different place in the sequence of components, highlight the component that you need to move and click the Cut button. That component disappears, and the text on the Paste button changes to show the component that has been cut. Now highlight the component that you want to be right before (or after) the component you are moving. Click the Paste button (which now contains the name of your component), then click either the Before or After button to place the component where needed.

Back to Top

Why do I get the warning “stand(s) were not processed because the variants they require are either not available or are blocked from use due to prior selections" when I am trying to add a stand to a simulation?
When using the Suppose interface program, keywords are invisibly labeled with an indicator of the geographic variant that was being used when they were included in the simulation. The geographic variant is determined when a stand is included in the simulation. Variant information is read from the stand list file or the StandInit table of the input database.

The warning message you are seeing means that the stand that is to be added to the simulation uses a different geographic variant than the current simulation. This happens two ways. The first is that a simulation was created with a stand from one geographic variant, and now a stand from a different variant is being added. The second is that a simulation was created without selecting any stand at all, and now a stand is being added. In this second case, the Suppose program doesn't know which variant to use while building the simulation since no stand was selected. It uses the default variant, which is usually the Inland Empire variant. Stands from any other variant may not be added. To avoid this second situation, always include the stand(s) first, before adding anything else to the simulation.

Another possible cause for this error message, although far less common, is that the selected stand uses a variant that is not available because it has not been installed on your computer. The error can occur before any other stand has been included, and before any keywords have been added. If the variant is missing, an installation package will need to be downloaded and the software installed so the missing variant is included.

Back to Top

Why do my simulation results not change when I replace a keyword with one that has different values entered?
Often, the problem is that the keyword has not been replaced, but rather another keyword has simply been added to the simulation file. FVS will attempt to execute all of the keywords in the simulation file. For example, an existing ThinBTA keyword leaves a residual of 100 trees per acre, and another ThinBTA is added with the intent of leaving a residual of 120 trees per acre. In this case the first ThinBTA will result in 100 trees per acre being left, and the second ThinBTA will be cancelled since there are not enough trees remaining to leave 120. The result is no different than before the second ThinBTA was added.

If a keyword is actually to be replaced by a different keyword, it must be deleted from the simulation. This is done by highlighting the keyword and clicking the Delete button. A new keyword or management action can then be added to the simulation in the usual way. If the same keyword is to be used but the parameters need to be changed, then that keyword does not need to be replaced. It just needs to be edited. Highlight the keyword and click the Edit Selection button. Change the desired parameters and click OK. It is a good practice to look for duplicate keywords before running a simulation.

Back to Top

What's the difference between "Management Actions" and "Keywords"?
Management Actions in the Suppose interface program are simply special uses of regular keywords in disguise. They were developed to be more intuitive and allow for easy use of sets of keywords. The selection links for the Management Actions were written in more "plain English" and do not require as much knowledge of what the keywords do. Anything that is done with a Management Action can also be done with the correct combination of keywords. The keywords that the Suppose program uses to accomplish the management can be seen in the main FVS output file in the "Options Selected by Input" section.

Back to Top

How do I change the default editor in Suppose?
In the Suppose interface program, click the Preferences menu and select Suppose Preferences. In the Default Editor box, type in the full path and filename of the editor. If the path contains any spaces, the entire string must be enclosed in quotation marks. For example, if my editor is called MyEdit.exe and is in the directory C:\Program Files, then the text entered into the Default Editor box would be “C:\Program Files\MyEdit.exe” and would include the quotation marks. When the string is entered correctly, click the Apply button, then the Close button.

Back to Top

I recently downloaded an FVS Model Extension (e.g., climate or parallel processor) but it does not show up in the "Use FVS Keywords" window in the left text box under Extensions. Why?
The Suppose interface only displays the Extensions for the variant selected for the simulation. The variant is selected when a stand is included, so first make sure that you have selected a stand that uses the variant with the Extension you have installed. Then check the “Use FVS Keywords” window again to see if the Extension shows up. If it does not, read on.

Make sure that once you downloaded the installation program off the Web that you also ran the installation. To run it, double-click on the downloaded file and step through the installation process, making the appropriate selections along the way. You can check to see whether the file was installed by confirming that the new Base Model or Model Extension is located in your \Fvsbin folder. The Base Model variants are named FVS__.exe (where “__” is replaced with the 2-letter abbreviation of the variant). Variants with the Pest Extensions are named FVS__x.exe. Variants with the Climate Extension are named FVS__c.exe, and variants with the Parallel Processing Extension are named FVSpp__.exe. Depending on your computer settings, you may not see the “.exe” part of the filenames.

If the Extension has been correctly installed into your \Fvsbin folder, the other possibility is that you need to update the Suppose program. When new Model Extensions are created, the Suppose parameter file also needs to be updated. Consequently, you may have anoutdated version of the Suppose program or its associated parameter file. To update Suppose (including the most recent parameter file), go to the Suppose User Interface web page on the FVS website.

Back to Top

Why can't I find the regeneration keywords in the "Use FVS Keywords" window?
FVS keywords belong to different extensions. Extensions are software components that perform a specific function. The default set of keywords that are displayed in the FVS Keywords window of the Suppose interface program are associated with the Base Model extension. To see the keywords that are associated with other extensions the user must highlight the appropriate extension in the left-hand pane of that window. To see the regeneration keywords, the user must highlight either "Full Establishment Model" or "Partial Establishment Model", depending on the geographic variant being used.

Back to Top

What does the warning "Suppose does not insure correct keywords when you use this option" mean?
This warning message appears whenever Suppose is about to open its free-form editor. This editor is used to allow a user to use options that are not possible through the standard Suppose text boxes and lists. This editor is usually used with the more advanced features of the model, like conditional scheduling, computing values, or using the Parms format on activity keywords. The free-form editor works much like a text editor. The warning means that, once in the editor, Suppose has no way of checking whether the things you type are valid FVS code. It is possible to write code that FVS cannot interpret, or that causes FVS to crash. The introduction in the Keyword Reference Guide for the Forest Vegetation Simulator discusses keyword record syntax and the Parms format.

Back to Top

I included a post processor in my simulation. Why is the output file blank?
Most of the post processors require output that is produced by including a specific keyword in the simulation. Without the correct keyword included, the output from the post processor is not created and the editor opens a blank document. For example, in order for the Average Summary Table post processor to work, the EchoSum keyword must be included in the simulation. The keywords required by the post processors are listed in the Description/Notes box at the bottom of the post processor selection window of the Suppose interface program. For additional information refer to the document User's Guide to the Post Processors for the Forest Vegetation Simulator.

Back to Top

What is the difference between the "FVSSTAND Alone" post processor and the "Stand and Stock Tables" post processor?
Both post processors produce stand and stock tables for live tree, harvest tree, and mortality tree components by tree species by diameter class. Both post processors can run through the Suppose program or run interactively from a DOS prompt or program icon. Both post processors produce stand tables for individual stands or plots. The Stand and Stock Tables post processor allows the user to select the output style and the size of the diameter classes. FVSSTAND Alone provides composite stand tables for many stands or plots. It can also display growth data as well as past and present information arrayed side-by-side for the live tree component. FVSSTAND provides subtotals by size class for easy summarization. It produces associated yield files that can be imported into spreadsheets or databases for further processing. It can also create SVS tree input files for each projection cycle stand table.

Back to Top

Are there any additional options for the post processors, like changing the diameter classes in the Stand and Stock Tables, or averaging computed variables by stand acreage?
Most of the post processors are small stand-alone programs. Many of them have additional options available through their interface. The options are typically accessed through a menu item or a button bar at the top of a main window. For example, the size of the diameter classes in the Stand and Stock Tables post processor is controlled through the Set Diameter Class Size button, which has a picture of a horizontal two-headed arrow. It can also be controlled through the Class Size item in the Table menu. Refer to the document User's Guide to the Post Processors for the Forest Vegetation Simulator for more detailed instructions.

Back to Top

Why do I get the warning message "Cannot open treelist file... Are you sure the file is an SVS tree list?" when using SVS as a post-processor?
The warning message usually means that no SVS treelist files were created by FVS. You must include the “Base FVS Treelists - Build SVS Treelist” model output or the SVS keyword to generate the SVS tree list files.

Back to Top

How many growth sample trees does FVS need for local stand/plot calibration?
If growth/increment information is provided in the FVS Input Tree data, then the large tree diameter model and/or the small tree height model can be scaled to reflect local conditions relative to regional growth trends. In order to compute scale factors, there must be five or more observations supplied per tree species. Diameter growth/increment is accepted for trees greater than a designated threshold diameter, whereas height growth/increment is accepted for trees less than a designated threshold diameter. The threshold diameter varies by variant, but it is generally 3-inches for large tree diameter growth and 5-inches for small tree height growth. Consult the Variant Overview for the threshold limits.

There is also a height-diameter relationship calculated in FVS. At least 3 height observations are required for a species in order to calibrate the height-diameter relationship.

Back to Top

I am using variants in Region 5 or 6 and I notice growth and mortality are not what I expected, or the stand is growing too much volume. Why?
Check the default maximum Stand Density Index (SDI) that FVS is using. For many of these variants, the Potential Vegetation (PV) code determines the SDI maximum. In some cases, the default SDI maximum based on PV code is too high or too low. The SDI maximum determines the rate of density related mortality; therefore, you could have exaggerated mortality or growth depending on the default SDI maximum. SDI maximum can be reset using the SDIMAX keyword.

Back to Top

Why are the residual trees per acre or basal area higher than the value I set on the harvest keyword?
The residual targets specified with the harvest keywords are not stand residuals, but are rather for specific ranges of diameter and height, and in some cases for particular species. Anything not within the specified range is not even considered for removal by that keyword. The stand residual will be the sum of the residual from the harvest keyword and all of the trees not within the range specified on the keyword. Refer to the description of a particular harvest keyword in the document Keyword Reference Guide for the Forest Vegetation Simulator for more detail.

Back to Top

Why is there regeneration in the simulation even though I did not schedule any?
Most of the geographic variants include regeneration from roots or stumps whenever trees of species that exhibit this behavior are cut or killed by fire. Several stems will regenerate from each tree cut or killed by fire. This type of regeneration can be suppressed using the NOSPROUT keyword.

A few of the geographic variants (AK, CI, EM, KT and NI) also have the capability to include regeneration automatically after some types of harvests or after periods during which no regeneration was scheduled by the user. Refer to the document User's Guide to Version 2 of the Regeneration Establishment Model: Part of the Prognosis Model for details. The easiest way to suppress this type of regeneration is with the NOAUTOES keyword.

Back to Top

I have included a CFVOLEQU (or BFVOLEQU) keyword; however, my volumes have not changed. Why?
When using the CFVOLEQU (or BFVOLEQU) keyword, you also need to include the VOLUME (or BFVOLUME) keyword and indicate in field 7 that you were using your own equation. Also if you want FVS to calculate volumes with your equation for the first cycle you must put a zero in field 1 (year). If you use the inventory year FVS will use the default equations for the first cycle and your equation for the rest of the cycles. Refer to the document Keyword Reference Guide for the Forest Vegetation Simulator for more information.

Back to Top

In my keyword set the keywords and parameters seem to be correctly aligned in the correct columns/fields but FVS doesn't seem to run certain keywords.
A common cause of this problem is the use of tabs instead of spaces in the keyword records. To check this open the keyword file in an editor or word processor that can display spaces and tabs as visible characters. For example, Microsoft Word has an option to show what they call “Formatting Marks.” This will show you how the file is formatted and if you used tabs. If you make any edits in a word processor, make sure to save the file as a simple text document or it will not work with FVS.

Back to Top

What does the merchantable cubic feet volume column include in the Summary Statistics Table in the Eastern variants (LS, SN, NE, SE, CS)?
In the Eastern variants only, the merchantable cubic feet volume column in the Summary Statistics Table includes pulpwood volume (to the minimum merchantability specifications) plus sawlog volume. You can calculate the pulpwood volume alone (not including the sawlog volume) by subtracting sawlog cubic foot volume from merchantable cubic foot volume.

When using the Event Monitor to compute volume in the Eastern variants, the BTCUFT variable returns values from the merchantable cubic feet volume column in the Summary Statistics table. The BMCUFT variable returns values from the sawlog cubic feet volume column in the Summary Statistics Table.

Back to Top

Does tree value class affect volume?
Tree value class does not affect volume when you use the default National Volume Estimator Library Equations. However, if you select the volume equations based on the TWIGS model (in LS, CS, and NE only), FVS will not calculate volumes for trees with a value class of 3, and will not calculate sawlog volume for trees with a value class of 2.

You can compute volumes for each of the different value classes using the Event Monitor function SPMCDBH. Refer to the document Essential FVS: A User’s Guide to the Forest Vegetation Simulator for more information.

Back to Top

Which damage codes are valid in the base version of FVS?

  1. Top damage: 96 = missing/broken top, 97 = dead top.
  2. Dwarf mistletoe: 30 = species other than LP, WL, DF, or PP; 31 = lodgepole pine; 32 = western larch; 33 = Douglas-fir; 34 = ponderosa pine; severity ratings of 0-6 indicate the Hawksworth severity code.
  3. Special tree status: 55; the severity rating is a user defined code in the range 1-99.
  4. Percent volume defect: 25 = defect for merchantable cubic and board foot volume; 26 = defect for only merchantable cubic foot volume; 27 = defect for only board foot volume; severity ratings for all three are percentages in the range 1-99.

All other damage codes require the use of an insect or disease extension in order to be useful in a simulation.

Back to Top

What causes the Summary Statistics table in the main FVS output file to be filled with all zeros?
When the Summary Statistics table is filled with zeros (or when the first cycle values are all zeros) it means that there were no projectable tree records in the input tree data file. Projectable tree records are those for live trees with the species and DBH specified. The Options Selected By Input section of the main output file will contain the warning:

******** FVS08 WARNING: TOO FEW PROJECTABLE TREE RECORDS

There are three main causes of this problem. The first is that all of the trees in the input tree data are coded as dead. The second is that the input tree data information is not in the correct format, or it does not contain species codes or DBH values. The third is that the reference to the tree data is incorrect so FVS can’t find the tree data.

If the tree data are in a database, this error usually means the “From” clause in the query that selects the tree data represents a table that is empty, formatted incorrectly, does not exist, or doesn’t contain species or DBH values. This query is either in the FVS_GroupAddFilesAndKeywords table in the input database or in the TREESQL keyword record. Refer to the Users Guide to the Database Extension of the Forest Vegetation Simulator Version 2.0 for more information.

If the tree data are in a text file, this error usually means the "A" record of the stand list file contains the name of a file that is blank, formatted incorrectly, does not exist, or doesn’t contain species or DBH values. This is often due to a misspelling of the filename or an incorrect directory being specified. Refer to the FVS File Format page for a discussion of proper formatting.

Back to Top

Why do I get the warning message “******** FVS08 WARNING: TOO FEW PROJECTABLE TREE RECORDS”?
In order to simulate growth and mortality, FVS requires the input tree data to contain at least one live tree record with species and DBH specified. The warning message means that FVS has not found any live trees in the input data. Refer to the previous item for possible causes.

Back to Top

What causes the error message “*****WARNING, INVALID FOREST TYPE WAS INPUT BY USER, DEFAULT INITIAL FOREST TYPE WILL BE CALCULATED BY MODEL” when using the Southern Variant?

The Southern Variant requires a valid FIA forest type. This is used to set a default maximum Stand Density Index (SDI), which is used in the mortality calculations. If no forest type is specified, FVS prints this error message and calculates an FIA forest type based on stand species composition, stocking, and tree size information.

There are 3 ways to control forest type in the SN variant using the MODTYPE keyword. Refer to the document Keyword Reference Guide for the Forest Vegetation Simulator for more information. Valid values for Field 3 of this keyword are shown below.

  1. If an invalid forest type, or no forest type, or no MODTYPE keyword is entered, the warning message is printed and the model recalculates the forest type each cycle. The maximum SDI is reset when the forest type changes;
  2. If a valid forest type code is entered, the model uses that forest type to set the maximum SDI for the first cycle only. After the first cycle, the forest type is recalculated each cycle and the maximum SDI is reset when the forest type changes;
  3. If a non-zero integer is entered in front of the forest type code on the MODTYPE keyword (e.g., the FIA forest type code 103 is input to indicate Eastern white pine forest) the forest type and corresponding maximum SDI value are locked at FIA code 103 for the entire simulation. Please refer to the SDIMAX keyword description for methods to override the forest type control of the maximum Stand Density Index during simulations.

Back to Top

What does the error message “WARNING: THIS LABEL SET IS SHORTER THAN THE ONE YOU SPECIFIED” mean?

Usually, you do not need to worry about this warning. It appears in the Options Selected by Input section of the main FVS output file. It directly follows the SPLabel keyword description. The things listed in the SPLabel keyword record are called Stand Policy Labels. The Suppose interface program reads these directly from the Grouping Codes contained in the Stand List File. The warning means that there were more grouping codes in that file than FVS can handle. Unless you are using stand management rules with the Event Monitor in FVS, this warning is of no concern. Refer to the document User's Guide to the Event Monitor: Part of Prognosis Model Version 6 for more information.

Back to Top

What does the warning message “WARNING: INITIAL STAND STOCKING OF x TREES/ACRE IS MORE THAN 5% ABOVE THE UPPER LIMIT OF y TREES/ACRE. UPPER LIMIT IS BASE ON A SDI MAXIMUM OF z , AND AN UPPER BOUND OF xx % OF MAXIMUM. MAXIMUM SDI BEING RESET TO xxx FOR FURTHER PROCESSING” mean?

In most variants, mortality is based on Stand Density Index (SDI). Stand density asymptotes at a certain percentage of the maximum SDI. This is generally 85% of maximum SDI, but a user can adjust that level. If the initial stand density is more than 5% above this asymptotic level, the model automatically adjusts the maximum SDI. This warning message indicates one of two things:

  1. The maximum SDI values (either input by the user, or set by model defaults) are too low; or,
  2. There is an error in data input, and stand densities are too high.

In the first case, the solution is to raise the SDI values using the SDIMAX keyword. In the second case, you probably have an error on your DESIGN keyword specifications.

Back to Top

What causes the message in the output file indicating that the “[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified”?

This error first appeared in the spring of 2012 with Microsoft Windows XP and Microsoft Windows 7 Professional operating systems. We determined that this error is related to data transfer issues with Microsoft Office and non-Microsoft Office applications. The fix for the error is to install a set of components that facilitate the transfer of data, regardless of the version of Microsoft Office that you have installed, available from 2007 System Driver: Data Connectivity Components.

Back to Top

US Forest Service
Forest Management Service Center
2150 Centre Avenue, Bldg. A
Fort Collins, CO 80526-1891

Please contact us with questions or comments regarding this website.

USA.gov logo

Last modified: Monday, 30-Jun-2014 16:17:50 CDT