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SECTION I: USING PATHFINDER OFFICE 
 

 This section lists the steps within Pathfinder Office that must be completed before 

any other work is completed. You must transfer the TerraSync rover files into the SSF 

format, then differentially correct those files, creating a new set of files in the COR 

format. The COR files are finally exported as GIS shapefiles, and GRAIP analysis can 

begin. 

 

 

Transferring Files 

 

1. Move or copy all of the relevant raw data into whichever folder your want to use. 

a. Relevant data are all nine TerraSync files for each file name (extensions .car, .dd, 

.gic, .gip, .gis, .giw, .gix, .obs, and .obx.; e.g. R071215A.car, R071215A.dd, etc.). 

b. Keep the raw data separate from the GIS workspace. 

2. In Pathfinder Office, select the project folder. 

a. If the Select Project window does not automatically open, go to File-> Projects…. 

b. If you are working with an already created project, use the Project Name drop-

down menu to select it and click OK. Skip ahead to step 4. 

c. If you do not have a folder set up for the current project, set one up now. Go to 

New…. 

i. Click Browse next to the Project Folder field-> navigate to the location of the 

raw data files and select the folder that contains those files-> click OK. 

ii. The Backup Folder, Export Folder, and Base File Folder are subfolders 

automatically created in the project folder. Check to make sure they will be 

created in the same place by clicking Browse… next to one of those fields. 

iii. In the Project Name field, enter an appropriate name. 
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iv. Click OK to create the project folder. 

 Click Yes if the error message that says, “Folder already exists; Do you 

want to continue?” pops up. 

d. Click OK to select the new project. 

3. Go to the main menu-> Utilities-> Data Transfer… 

a. Pathfinder Office is set up to get data directly from whatever device you use to 

collect field data, but we want to use data already on the hard drive of the 

computer. These methods are un-intuitive because of this. 

b. Ensure that the Receive tab is selected. 

c. If you already have the relevant folder connected, click on the Device drop-down 

to select it and skip to part (c). If you do not already have the relevant folder 

connected, you will need to connect it. Click Devices…. 

i. Click New…. 

ii. Select GIS Folder as the type of device you wish to create-> click OK. 

iii. Click Browse… to navigate to and select the Project Folder (created above)-> 

click Next. 
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iv. Use the drop-down menu next to Type to select TerraSync, and then select the 

Version closest to that used in the field-> click Next. 

v. Give the device a short name (under nine characters) in the Name field-> click 

Finish. Click Close to close the Devices window. 

d. Click the Add drop-down in the Data Transfer window-> wait for Pathfinder to 

connect to the device folder if necessary-> click Data File. Select the relevant 

data files (only those with a .gis extension show up)-> click Open. Those files are 

added to the Files to Receive field. 

e. Click Transfer All. 

f. The Transfer Completed dialog appears. This dialog will tell you if the transfer(s) 

was/were successful. You should check on the location of the transferred files by 

clicking More Details…to access the log file and looking at each file path. The 

files should be transferred to the same directory as the raw data files. The format 

is converted to SSF (extension .ssf). There is a backup of the SSF file saved to the 

Backup folder in the project folder by default. Click Close when satisfied. Click 

Close to close the Data Transfer window. 

4. View the data to ensure that it is what you want. 

a. From the main menu, go to View-> Map. If necessary, select the SSF file(s) that 

you just created-> click OK. 
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Differential Correction 

 

1. With the same project folder open as above, got to Utilities-> Differential 

Correction…. 

2. The Differential Correction wizard appears. 

a. If the correct files do not appear in the Select SSF files to correct field, click the 

plus sign-> navigate to and select the relevant files-> click Open. Remove any 

incorrect files. Click Next when finished. 

i. Below the Select SSF files for correction window, there is some information 

about the file, including whether or not the file was collected using an H-Star 

GPS receiver. 

b. If the data was collected with an H-Star receiver, select Automatic H-Star Carrier 

and Code Processing. If the data was not collected with an H-Star receiver, select 

Automatic Standard Carrier and Code Processing. Click Next. 

c. The settings on the next screen can be adjusted by clicking the Change button. 

Accept the defaults by clicking Next. 

d. Click Select next to the Base Provider Group field. 

i. If you have an appropriate group already, select it from the Base Provider 

Group drop-down menu, check to make sure the selected base station is still 

the best option (plus sign-> Update List), and skip ahead to (iii). If you do not 
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already have an appropriate group, click New… next to the Base Provider 

Group drop-down menu. Name it something obvious-> click OK. 

ii. Click the plus sign. A list of base stations appears, with their distance from the 

data and an integrity index (higher is better).  

 Click the Update List button to acquire the latest list. The Downloading 

base providers… window appears while the download is taking place.  

 Select a nearby base station, with a relatively high integrity index and a 

bias towards CORS stations.  

 Click OK to exit the Select Base Provider window. 

iii. Click OK to exit the Base Provider Group window.  

e. Select Use reference position from base providers in the Reference Position 

section of the window. Check the box next to Confirm base data and position 

before processing. Click Next. 

f. Select where you want the new corrected data file (extension .cor) to be saved and 

how you want it to be named. Click Start. 
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i. If the process stalls, click Close and start again from step 1. 

ii. Click Confirm when required. 

g. When the process is complete, the window will say “Differential correction 

complete.” You should look at the data in the window to confirm that the 

correction was successful. 

i. Useful data includes the number of positions corrected, the number 

uncorrected, which method (carrier or code) was used for how many 

positions, how many positions were thrown out, and estimated accuracies for 

the data. 

ii. When finished, click Close. 

3. Check to ensure that the corrected file contains the same data as the uncorrected file. 

a. From the Pathfinder Office main menu, go to File-> Open…. Navigate to the 

uncorrected SSF file (extension .ssf) and click Open. 

b. If the map viewer is not already open, go to the main menu-> View-> Map. Drag 

the corners of the map until it is as large as possible. Right-click anywhere on the 

map without data-> Zoom To Extents. 

c. On your keyboard, press the Print Screen button (may say Print Scrn, etc.). 

d. Paste the screen print into a new document in a word processor, such as Microsoft 

Word or OpenOffice (which is open source and free). 

e. Repeat, but open the corrected COR (extension .cor) file, and use the same word 

processor document. You may have to resize one or both of the images to get 

them to both fit on a page. 

f. You can compare the SSF and COR either on the screen, or you can print the page 

out. 

g. If there are one or more road sections missing from the corrected file, you will 

have to re-correct the SSF file, starting at step 1. This time, use a different base 

station. 
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Exporting as Shapefiles 

 

The new exported shapefiles are saved to the Export folder in the project folder. 

All of the possible shapefiles are BBASE_DI, END_RD, DIFF_DRA, DTCH_REL, 

GATE, GULLY, LANDSLID, LEAD_OFF, NON_ENGI, PHOTO, Point_ge, REVISIT, 

ROAD, ROAD_CLS, ROAD_HZR, STRM_CRO, SUMP, and WATER_BA. 

 

1. With the same project folder open as before, go to the main menu-> Utilities-> 

Export…. 

2. The Export window appears. 

a. In the Input Files section, click Browse...-> navigate to the location of the 

differentially corrected file or files that you wish to export to shapefiles-> select 

the necessary COR files-> click Open. 

b. You can change the location of the output folder by clicking Browse… next to the 

Output Folder field. 

c. In the Choose an Export Setup section of the window, choose Sample ESRI 

Shapefile Setup from the drop-down menu. 

d. Check the coordinate system in the area under GIS Coordinate System to make 

sure it is correct. If using UTM, make sure the zone is set correctly. 

i. If the coordinate system is not correct, click Properties…-> click the 

Coordinate System tab-> select Use Export Coordinate System-> click 

Change… 
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 Use the drop down menus to select the appropriate coordinate system and 

associated properties-> click OK. 

ii. You can change other export properties in the Properties window if you 

desire. Click OK to exit the Properties window. 

e. Click OK to export the file or files. 

f. The Export Completed window appears when the export is complete. This 

window shows how many features were in the initial COR file(s), and how many 

features were exported. You want there to be the same number of features 

originally as after export. You can click More Details… to see exactly which files 

were created and where they are located, similar to the log file created for the data 

transfer process. This text file is saved to the same folder as the exported files. 

Click Close when you are finished viewing the Export Completed dialog. 

3. Each shapefile is composed of a number of files that are readable by ArcGIS. Use 

ArcCatalog to move or copy the shapefiles into the appropriate GIS workspace. Pre-

processing can now begin. 
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SECTION II: PREPROCESSING 
 

 This section lists the steps that must be completed using ArcMap and the GRAIP 

Preprocessor before the analysis steps can begin, but after the Pathfinder Office steps are 

complete. The DEM must be clipped to the appropriate watershed, and the shapefiles 

must be pre-processed. Any errors within the data must be corrected, and the road lines 

must be straightened. 

 

 

Clipping the DEM 

 

1. Open ArcMap and add the DEM and the HUCs. 

2. Make sure the HUCs and the DEM are in the same projection. It’s good to make 

copies of both with ArcCatalog before changing their attributes. 

a. Open the Layer Properties window for each layer-> Source tab-> scroll down to 

Spatial Reference. If the two layers have the same Spatial Reference, move on to 

step 3. If they do not, or if one is undefined, proceed, even if both layers are 

overlapping as they should. 

3. If the DEM is in the wrong projection, re-obtain it in the correct projection. If the 

HUCs are in the wrong projection, they should be projected or re-projected to the 

same coordinate system as the DEM. 

a. Open ArcToolbox-> Data Management-> Projections and transformations-> 

Feature-> Project. 
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i. From the Project window: 

 Under Input Dataset or Feature Class, select the HUCs shapefile. 

 If there is nothing under Input Coordinate System (optional), select the 

projection that you think the HUCs are in. 

 Under Output Dataset or Feature Class, select the folder in which you 

wish to save the new projected HUC shapefile (probably the same place as 

the original HUCs), and type a new name for the new HUCs. 

 Under Output Coordinate System, import the coordinante system for the 

DEM 

 Click OK. A new shapefile that contains the HUCs and is projected the 

same as the DEM is created. Use this HUC layer for the rest of the steps. 

b. The projected HUCs and DEM should be overlapping properly in the ArcMap 

viewer screen. 

4. Choose which HUCs you need. 

a. Add all of the roads you will be analyzing to ArcMap, overtop of the HUCs 

(which should be overtop of the DEM). If the roads are mis-registered, re-project 

them as you did for the HUCs above.  
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b. Set the transparency of the HUCs layer to 35%. This is useful when determining 

the extents of each watershed and associated flow paths. 

i. From the Layer Properties for the HUCs-> Display-> type 35 in the 

Transparent box. 

c. The HUCs you want are those that encompass the roads, their sub-watersheds, 

and all surface flow paths that water intercepting those roads could take, until all 

of those flow paths are in common with one another. 

5. Delete the rest of the HUCs. 

a. Start editing in the Editor toolbar-> choose the folder with the HUCs if prompted. 

b. Use the Edit tool from the Editor to select all of the HUCs you don’t need. 

ArcMap Main Menu-> Edit-> Delete to delete those. 

c. Editor-> Save edits. 

6. Merge all of the HUCs into one. This is necessary for the buffering step (7). 

a. Select all the remaining HUCs at once. 

b. Editor toolbar-> Target-> HUCs layer. 

c. Editor-> Merge-> any option will do-> click OK. 

d. Save the edits. 

7. Buffer the new single HUC. 

a. Use the Edit Tool from the Editor toolbar to select the single HUC feature. 

b. Editor-> Buffer…-> enter 500 m, or rough equivalent-> hit Enter key. 

8. Extract the DEM. This final step results in a new DEM that is the shape of the 

buffered HUC, ready to be processed in GRAIP. 

a. ArcToolbox-> Spatial Analyst-> Extraction-> Extract by Mask. Enter the DEM as 

Input Raster, the now merged and buffered HUC layer as Input raster or feature 

mask data, and an appropriate location and name for the new extracted DEM 

(probably the same folder as the original DEM; any eight-character or fewer name 

will do, but it should be clear which is the extracted DEM). Click Compute. 
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Using the GRAIP Preprocessor 

 

In total, eight files are created, not including the multiple files that make up the 

shapefiles (FileName.graip, DrainPoints.shp, RoadLines.shp, FileNameDP.log, 

FileNameRD.log, FileName.mdb, FileNameshpdp.txt, and FileNameshprd.txt). 

 

1. In the GRAIP Preprocessor, create a new .graip file 

a. Under Project File, navigate to the folder with your shapefiles or wherever you 

want to save the .graip and other created files. Name the file with something 

relevant. Do not use spaces. 

b. FileName is used here to refer to the .graip, etc. 

2. Select the DEM 

a. Under DEM File, select the desired clipped DEM, referred to here as just “dem” 

(it should be in the same folder in which you intend to save the TauDEM-created 

files). Double-click dem, and select sta.adf. 

b. If you don’t have the DEM, you can still correct errors. For this step, use a 

dummy DEM (any DEM). You will have to re-preprocess the data with the 

correct DEM before running GRAIP. 

3. Add the road shapefile(s), and the drain point shapefiles. 

a. Under Road Shapefiles, navigate to the location of the ROAD shapefile(s), and 

select them. 

b. Under Drain Points Shapefiles, navigate to the location of the drain point 

shapefiles, and select them. There are eight possible drain point shapefiles, but not 
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every study will have them all. They are BBASE_DI, DIFF_DRA, DTCH_REL, 

LEAD_OFF, NON_ENGI, STRM_CRO, SUMP, and WATER_BA. 

c. You can add more than one shapefile with the same name. In this case, the other 

set(s) of shapefiles should be in a separate folder or folders in the same location as 

the rest of the shapefiles. 

4. Under Options, ensure Step by step and Manual resolution of invalid/missing data 

values are selected in the Processing field. 

5. Click Next. At this point, all of the files that are created by the preprocessor have been 

created, except DrainPoints.shp and RoadLines.shp. The next steps import the drain 

points and road shapefiles. 

6. Check to make sure all of the Target and Source fields match up properly. If you have 

the latest version of GRAIP and the latest data dictionary in the field, they should 

match. When you are sure everything matches, click Next. Repeat this process for all 

drain points.  

a. The road lines are similar. 

b. If a property exists in the data dictionary in the field, but not in GRAIP, the 

Define Value dialog appears. 

i. You have three options, Use default value, Reassign this value in definitions 

table, and Add new entry to definitions table. Select the appropriate choice. 

Generally, Add new entry to the definitions table is most appropriate. 
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7. Preprocessing is now complete. The FileNameDP.log and FileNameRD.log files, 

located in the same folder as FileName.graip, contain the errors that the preprocessor 

found, used in the next step. 

8. In the next step, you will locate and fix any errors. When you re-preprocess the data, 

after the errors are corrected, and any time the DEM used does not change (including 

if you change which shapefiles are used, so long as the DEM remains the same), you 

can just select the already created Project File (FileName.graip) on the first screen. 

Click OK when asked if you want to delete the DrainPoints, RoadLines, and 

FileName.mdb files. Proceed as before. If you change the DEM, you must use a new 

.graip (e.g. FileName2.graip). Again, click OK when asked if you want to delete the 

DrainPoints, RoadLines, and FileName.mdb files. If no points have been added or 

deleted from the original shapefiles, the preprocessor assigns the same 

GRAIPDID/GRAIPRID number to each point as it did the first time. 
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Editing Data Errors 

 

An error is logged for a drain point if its CTime/CDate/VehicleID combination is 

not referenced to any road segment. An error is logged for a road line segment if none of 

the entered CTime/CDate/VehicleID combinations correspond to a drain point. 

The fundamental goal of error checking is to ensure that each flow path on each 

road segment drains to the appropriate and valid drain point. The ROAD and the various 

original drain points shapefiles must be edited. The shapefiles generated by the GRAIP 

Preprocessor (DrainPoints.shp and RoadLines.shp) are not edited.  

CTimes in the ROAD layer are in 24-hour format, rounded to the nearest minute, 

and without colons (so, 1537 means 03:37:25, 03:36:48, 03:37:30 etc.). xx:xx:30 rounds 

down, and xx:xx:31 rounds up. The CTimes in the original drain point are in 12-hour 

format, with seconds. The CTimes in the original drain point must be in the format 

xx:xx:xx, or GRAIP won’t know what the CTime means. 

 

 

1. Print the error log files (FileNameDP.log and FileNameRD.log) for easier reference 

(they can be combined into one page). 

2. Add the original shapefiles (ROAD, DIFF_DRA, etc.) to ArcMap. Also add the 

RoadLines and DrainPoints shapefiles generated by the GRAIP Preprocessor and the 

PHOTO shapefile for reference. Arrange the RoadLines and DrainPoints layers under 

the rest of the layers in the Table of Contents window. 

a. Label the RoadLines and DrainPoints layers for easier reference.  

3. Open the attribute table for the DrainPoints. The GRAIPDID and FID columns 

correspond to the “GRAIPDID” column in the error log. This also applies to the 

RoadLines attribute table and error log. 

4. For each point in the drain points error log, find the corresponding point in the 

Attribute Table (same GRAIPDID number). 

a. Find the GRAIPDID number on the error log in the Attribute Table and select that 

point. Zoom in on the selected point. 

b. Use the Identify tool from the ArcMap Tools toolbar to select the drain point from 

the original shapefile (e.g. SUMP) that directly overlays the selected (and labeled) 

point from the DrainPoints layer. 

i. Since the point from the DrainPoints layer is directly underneath the point 

from the original shapefile, and the Identify tool selects the top-most layer by 
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default, the original shapefile is selected. This also applies to the RoadLines 

and its corresponding original shapefile (ROAD). 

5. Now you must decide which type of error is occurring at this point and how to fix it. 

a. If the comment in the Identify box says “orphan,” this is most likely an 

intentionally orphaned point. Note this on the error log hard copy, and move on to 

the next point. 

b. Note the CTIME in the Identify box of the original drain point shapefile. Use the 

Identify tool in the same way to look at the surrounding road segments (in the 

original shapefile; ROAD). Remember that each road segment has two flow 

paths. 

i. If the drain point error is most likely an unlabeled intentional orphan, label it 

as such in the Attribute Table for that drain point. 

 Look in the Identify box of the drain point in question and note its FID. 

Open the attribute table for that drain point type, scroll to the FID. In the 

COMMENT field of the drain point, type “orphan.” 

ii. If both surrounding road segments have CTimes in all used flow paths, but not 

all CTimes are accounted for in nearby drain points, the errant CTime is 

probably supposed to be the CTime from 

the problem drain point. 

 Enter the correctly rounded CTime 

from the drain point into the cell with 

the incorrectly rounded CTime in the 

ROAD attribute table.  
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iii. If both surrounding road segments do not have CTimes in all used flow paths, 

the problem drain point is probably the missing CTime in the ROAD. Check 

to see that the drain point type makes sense with the flow path. 

 Enter the correct CTime into the ROAD table. 

 If some other drain point appears to be the missing CTime from the road 

line, enter it in the missing place in ROAD. The errant drain point may be 

an intentional orphan. 

c. Some other errors include those in CDate and VehicleID. 

i. CDate errors can occur when a drain point from one day is referenced the next 

day. Change the CDate in either the road segment or the drain point, 

whichever is easier. This can get messy if more than one road segment drains 

to that point, or the road segment has two flow paths, because all drain points 

associated with the road segment must have the same 

CTime/CDate/VehicleID combination. 

ii. VehicleID errors can happen if two crews collected a point at the same time 

on the same day, but one of the crews accidentally entered the VehicleID of 

the other crew. 

d. The last kind of error will present itself as a drain point or road line with all 

default properties, as a drain point of the same type, in the same location, and with 
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the same properties as another (except CTime/CDate/VehicleID, which are 

automatically generated), or as a road line in the same place and with the same 

properties as another. There is a possibility that this is intentional, but duplicates 

should be deleted in any case. 

i. Delete duplicate or unintentional drain points. Use the Edit Tool from the to 

select the erroneous point or line, being sure that you have selected the correct 

point or line, and then, from the Main Menu-> Edit-> Delete. 

ii. Be sure to correct any further errors generated by deleting duplicate points, as 

above. 

6. Repeat the above steps for the rest of the errors in the log, noting in the error log hard 

copy what has been done to fix the problem (or if the point is an intentional orphan), 

and saving the edits. 

7. Repeat the above steps 3-6 for the ROAD and RoadLines layer. 

8. When all errors in the error logs have been addressed, save the edits, and then stop 

editing. Open a new map file.  

9. Re-run the GRAIP Preprocessor, as described above. Look at the new error logs to 

verify that the only errors generated for the drain points are intentional orphans (if 

any). There should not be any errors in the road lines error log, because road line 

errors are only generated when the road segment has no associated drain points, 

which cannot happen on the ground. 
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Straightening Road Lines 

 

The most important thing when straightening road lines is that they are consistent. 

A good guideline for editing road lines is to try to create smoothly curving segments that 

have a high frequency amplitude of less than six meters. Remember that roads are 

generally smoothly changing features. 

 

1. Add all original road lines and drain points (ROAD, SUMP, etc.). If you have a 

previous version of the road that has already been corrected (as in pre-and post- 

treatment for the Legacy Roads project), add it as well. 

2. Start editing. Zoom in on the end of a road (1:500 or so is a good scale for this level 

of editing). If there is zigzag that is composed of only a few points, you can delete or 

move those points until the road line is straight again. If there is a rat’s nest at the end 

of a line, or if there is zigzag composed of a lot of points, you can use the Split tool to 

divide the line in two and delete the bad part. See steps 3 to 5 below. 

a. Use the drain pointa to connect one road line to another. 

b. The ends of the road lines should be right on top of the drain point, as viewed at 

the above scale. All drain points should be at the end of the road line, except some 

orphans and diffuse drain points, which may or may not be at the end of the line. 

3. To delete individual vertices: 

a. Using the Edit Tool, double-click the road line to display its vertices.  

b. Right-click an errant vertex. Select Delete Vertex. 

c. You can also insert a vertex on a line from the same menu. 

4. To move a vertex, move the Edit Tool over the vertex that needs to be moved. Click 

and drag it to its new location. 



 

 22 

5. To use the Split Tool to delete a rat’s nest or portion of very bad line: 

a. Select the line with the Edit Tool.  Using the Split Tool, click on the line to one 

side of the rat’s nest or portion of very bad line. You have now divided the single 

line with a certain set of properties and a certain FID number in the Attribute 

Table into two lines with the exact same properties. One line retains the original 

FID number, and the other line is assigned a new number. 

b. Use the Edit Tool to select and delete the rat’s nest or portion of very bad line. 

You can either go to the ArcMap Main Menu-> Edit-> Delete, or use the Delete 

key on the keyboard. 

c. If the road line is very bad, and there is a high frequency of vertices, it may be 

easier to split the road line in two, delete the worse section, and re-construct the 

entire line from the remaining points. 

d. After a section of road is deleted, you must re-construct that portion of the line. 

e. In order to make sure you haven’t deleted anything that shouldn’t have been 

deleted, or left something that should have been deleted, check the Attribute Table 

for the ROADS layer before you begin, and note how many table entries there are 

(in the bottom-middle of the table window, Records (blank out of total Selected). 

6. Add a background aerial photo now. 

a. If you have a 1 m resolution image, 1:1600 or so is a good scale. 

7. Check to make sure the road on the photo is registered the same as the road line from 
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the data. 

8. Check to make sure the road line from the data follows the road on the photo, and is 

contained within the width of the road on the photo. 

9. Check the number of entries in the ROAD Attribute Table, as described in step 5 

above. 

10. When finished, save the edits, stop editing and open a new map file. 

11. Re-run the GRAIP Preprocessor, as described above. This will generate RoadLines 

and DrainPoints shapefiles that reflect the changes made to the road lines. 

a. It is a good idea to look at the error logs once more to ensure nothing has 

changed. 
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SECTION III: RUNNING THE GRAIP MODEL 
 

 This section describes the steps that are taken to run the actual GRAIP model with 

the GRAIP toolbar. TauDEM must first be run to generate files to be used by GRAIP. 

There are some initial steps that must be taken in the GRAIP toolbar and Hawth’s Tools 

before true analysis can begin. There are three main parts of the GRAIP process that must 

be competed in order. SINMAP is used to generate files that are used in the middle step 

of the GRAIP process. 

 

 

Running TauDEM 

 

 There are 13 grid files created by TauDEM (dem stands for the name of the DEM 

used): demfel, demsd8, demp, demang, demslp, demad8, demsca, demgord, demplen, 

demtlen, demsrc, demord, and demw. There are two shapefiles created by TauDEM: 

demnet, demw. The stream network shapefile (demnet) is associated with 

FileName.graip, and is added when the .graip is opened. 

  

1. The projection for the clipped (to the HUC boundary) DEM must be defined if it is 

not already. 

a. In ArcToolbox, go to Data Management-> Projections and Transformations-> 

Define Projection.  

i. Under the Input Dataset or Feature Class, select the DEM. 

ii. Under the Coordinate System field, navigate to the projection that the DEM is 

in, click Add, then Apply and OK. 

iii. Click OK. The projection is now defined. 
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b. Close ArcMap or open a new map file. This will set the ArcMap viewer with the 

correct projection information before TauDEM is run. 

2. If you don’t have one already, create an ArcInfo workspace for the TauDEM (and 

later SINMAP) files with ArcCatalog. Put a copy of the DEM in the workspace. 

a. Close ArcCatalog or navigate away from the new workspace. TauDEM and 

ArcGIS might get confused if the workspace they are modifying is active 

(currently being viewed) in ArcCatalog at the same time. 

3. Open ArcMap and add the clipped DEM with the projection defined from the 

TauDEM workspace to the viewer. 

4. It is best to do the rest of these steps one immediately after another. From the 

TauDEM toolbar-> Basic Grid Analysis-> Select Base DEM grid… 

a. Use the drop-down menu to select the DEM. 

5. Go to Basic Grid Analysis-> Full River Network Raster. You don’t want to run this 

step now, just adjust its parameters. 

a. Uncheck Check for Edge Contamination 

i. This will automatically uncheck Use D-Inf Contributing Area Grid as an edge 

contamination mask. 

b. Change the Threshold to 25 

c. Click Apply twice (to ensure it registers), then Cancel. 

6. Go to Basic Grid Analysis-> Do All. 

a. Double-check the default parameters and click Compute. 
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b. This step produces 11 grids (demfel, demsd8, demp, demang, demslp, demad8, 

demsca, demgord, demplen, demlen, demsrc). 

7. Go to Network Delineation-> Do All Network and Watershed Delineation Steps. 

a. Click OK when asked if it’s OK to delete the existing src output file. 

b. This step creates the last four grids and shapefiles (demord, demw, demnet.shp, 

demw.shp). 

c. Do not use an outlet point. 

8. Before proceeding, close ArcMap or open a new map file. 
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The Preprocessor Menu 

 

 

The first method, for when you plan to do a complete GRAIP study, is as follows: 

 

1. Open the .graip file with the GRAIP toolbar. 

a. GRAIP toolbar-> File-> Open-> navigate to the location of the .graip and select 

it-> click OK. DrainPoints, RoadLines, demnet, and the DEM will be added to the 

map. 

2. GRAIP toolbar-> Preprocessor-> Extract Stream Crossings. 

a. Under Input, ensure the proper DrainPoints shapefile is selected.  

b. Under Output ensure the new shapefile will be saved to the correct place (which 

should be the same place as the rest of the shapefiles, including DrainPoints, etc.) 

and is correctly named (should be StrXingEx). 

3. Hawth’s Tools toolbar-> HawthsTools menu-> Vector Editing Tools-> Intersect Lines 

(make points). 

a. For Line/poly layer, use the drop down to select the RoadLines layer. 

b. For Intersect line/poly layer, select the demnet layer. 

c. For Output, save the new shapefile to the same location as the extracted stream 

crossings, and name the file “StrXingRi.” 

d. The new shapefile is composed of the points at which the road intersects the 

stream network. 

4. Hawth’s Tools toolbar-> HawthsTools menu-> Vector Editing Tools-> Snap Points to 

Lines Tool. 
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a. Under Point feature layer, select the extracted stream crossings layer 

(StrXingEx). 

b. Under Line or polygon feature layer, select the stream network shapefile 

(demnet). 

c. Under Output, save the file as “StrXingSn” in the same place as the other two 

recently created shapefiles.  

d. The new shapefile is not added to ArcMap, so add it in the normal fashion. 

e. There is a known problem with this step that occurs sometimes. The first time you 

attempt to create this shapefile, the tool crashes. The solution is usually to close 

ArcMap (no need to save anything), use ArcCatalog to delete the already created, 

but in error, StrXingSn shapefile, and restart ArcMap. Add the extracted and 

intersected shapefiles, and re-do this step. 

5. GRAIP Toolbar-> Preprocessor-> Filter Stream Crossings. 

a. There are a series of parameters that can be changed in this window. It is not 

generally necessary to do that. 

b. Further discussion of this step can be found in Appendix B of the full length 

Office Manual and in Prasad 2007. 
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c. Ensure that the inputs are correctly located. The Contributing Area Grid is 

demad8, which was produced by TauDEM. 

d. Ensure that the three outputs are correctly located (with the rest of the shapefiles) 

and named (“MergedSX,” “MatchSX,” and “UMatchSX”). 

6. Now you must check to make sure the MatchSX and UMatchSX shapefiles are 

correct. The end result of the Filter Stream Crossings and Create TauDEM Stream 

Network functions is a new stream network shapefile (demnet) that is split at its road-

stream intersections, and a shapefile that contains the stream crossings at those 

intersections (this is MatchSX). During the Filter Stream Crossings step, three 

shapefiles are generated, MatchSX, MergedSX, and UMatchSX. In the end, 

UMatchSX will basically contain surveyed stream crossings that are not on the 

demnet stream network and MatchSX will contain those surveyed stream crossings 

that are on the demnet stream network. 

a. If any UMatchSX points are not OK, you will have to edit the original 

STRM_CRO shapefile, re-run the GRAIP Preprocessor, and re-run the GRAIP 

steps to this point (extract, intersect, snap, and filter the stream crossings). The 

idea is to fool the Filter Stream Crossings tool into thinking that all filter criteria 

are met.  

These two observed stream 

crossings (STRMCRED) are on 

small side streams that do not 

show up in the TauDEM stream 

network shapefile. Their channel 

width is much smaller than the 

channel width of the main channel, 

so the snapped points show up as 

UMatchSX points. 

This is a case where the 

observed stream crossing 

(STRMCRED) is on a small side 

stream that does not show up in 

the TauDEM stream network 

shapefile, and the nearby main 

channel has a similar width. 

There is no real stream crossing 

on the main channel here, and 

so the MatchSX point is 

incorrect. 

In this example, the observed stream width is 

different from the calculated width. The 

UMatchSX point should be a MatchSX point, 

because there is really a stream crossing at 

this location. 
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b. Use ArcCatalog to make a copy of the original STRM_CRO shapefile (don’t edit 

the original!; call it something like STRMCRED). Add the STRMCRED layer to 

the ArcMap file with the rest of the shapefiles and data added and generated so 

far. 

c. For each UMatchSX point, find out why it didn’t pass. 

i. The Note field of the Identify window of the UMatchSX point will say either 

“Fails automated distance criteria,” or “Fails Channel Width Criteria”. For the 

former, nothing should be wrong, but check to make sure that the observed 

crossing is not supposed to be on a demnet stream anyway. 

ii. If the channel width criteria are the problem, find the corresponding observed 

stream crossing on the map from the STRMCRED layer. Note the location of 

the observed crossing and the location of the UMatchSX point. If the 

UMatchSX point is correct (i.e. the observed stream crossing—

STRMCRED—is not located on the same stream as the UMatchSX point), 

move on to the next point. If the UMatchSX point is incorrect (i.e. the 

observed stream crossing is located at the same place on the same stream as 

the UMatchSX point, but the observed and calculated stream widths are too 

different), proceed to the next step. 

d. In the Identify box of the UMatchSX point, note the observed channel width 

(CHAN_WDTH) and the calculated channel width (in the GeoCW field). The two 

numbers should not be close (more than 1 or 2 ft apart). Change the 

CHAN_WDTH field of the observed point in the STRMCRED layer to match the 

GeoCW field from the Identify box of the UMatchSX point (round to the nearest 

integer). 

i. Start editing. 

ii. In the STRMCRED Attribute Table, scroll to the entry for the FID number 

from the STRMCRED point’s Identify box. Type in the rounded GeoCW 

number from the UMatchSX point in the CHAN_WDTH field of that FID 

number. 

iii. Editor-> Save Edits. 
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e. Repeat steps e. and f. for all other incorrect UMatchSX points. Check all 

MatchSX points, repeating the same process, but changing the CHAN_WDTH to 

be dissimilar to the GeoCW from the MatchSX Identify box (usually, more than 2 

ft of difference is enough). 

f. Save the edits and stop editing. Open a new map window.  

g. Run the GRAIP Preprocessor, replacing the STRM_CRO layer with the edited 

STRMCRED layer. 

h. Open the new GRAIP file (the .graip) in ArcMap. Repeat the Extract Stream 

Crossings, Hawth’s Intersect Lines (make points), Hawth’s Snap Points To Lines, 

and Filter Stream Crossings steps. Check to make sure your edits worked, and 

recheck to make sure there are no further UMatchSX or MatchSX problems. 

7. Now you must create an outlet file for the Create TauDEM Stream Network step to 

use. 

a. Use ArcCatalog to create a new shapefile called “Outlets” in the workspace with 

the rest of your shapefiles. 

i. Right-click in the shapefiles folder-> New-> Shapefile… 

ii. Name it “Outlets,” and select Point as Feature Type. 

b. Open the GRAIP file (the .graip) in ArcMap. Add the MatchSX and Outlets 

shapefiles.  

c. Start editing and select the folder with the Outlets shapefile. Set the Target to the 

Outlets layer. 

d. Open the Attribute Table for the MatchSX layer. Click -> Select All. From the 

ArcMap Main Menu-> Edit-> Copy. Close the Attribute Table. 

e. Open the Attribute Table for the Outlets layer. From the ArcMap Main Menu-> 

Edit-> Paste. Save the edits. Notice that there are now Outlets points everywhere 

that there are MatchSX points. 

f. Zoom in as close as possible on a point on the main stream, downstream from all 

of the roads. This should be pretty far downstream. 

i. Use the Sketch Tool to create a point directly over the stream network line. 

g. Save the edits and stop editing. The Outlets shapefile is now populated with all of 

the necessary points for the next step. 
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8. GRAIP toolbar-> Preprocessor-> Create TauDEM Stream Network. Under Select 

Outlets Shapefile, navigate to the location of the Outlets shapefile and select it. When 

asked if it is OK to overwrite files, click Yes (it will ask this four times). 

a. The stream network shapefile that was created by TauDEM has been deleted and 

replaced with this new stream network shapefile that is the same, except that the 

streams are split at the road-stream intersections. 

9. GRAIP toolbar-> Preprocessor-> Resample DEM. 

a. Check to make sure that DEM (under Input) is correctly located. 

b. Check to make sure that DEM Interpolated to a Finer Scale will be saved to the 

right place. 

 

 

The second method, for when you will not complete the habitat segmentation 

analysis. This step replaces steps 2-7, above: 

 

2. Hawth’s Tools toolbar-> HawthsTools menu-> Vector Editing Tools-> Intersect Lines 

(make points). 

i. For Line/poly layer, use the drop down to select the RoadLines layer. 

ii. For Intersect line/poly layer, select the demnet layer. 
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iii. For Output, click the button to the right of the field, navigate to the same 

location as the rest of the shapefiles, name the file “Outlets,” click Save, and 

then OK. 

iv. The new shapefile is composed of the points at which the roads intersect the 

stream network. 

b. Make sure all of the points created are on valid road-stream intersections. 

c. Start editing and select the folder with the Outlets shapefile. Set the Target to the 

Outlets layer. 

d. Zoom in as close as possible on a point on the main stream, downstream from all 

of the roads. This should be pretty far downstream. 

i. Use the Sketch Tool to create a point directly over the stream network line. 

e. Save the edits and stop editing. The Outlets shapefile is now populated with all of 

the necessary points for the next step. 

 

 

The variation on the second method, for use if Hawth’s Tools does not work. This 

step replaces steps 2-7, above: 

 

2. Use ArcCatalog to create a new shapefile called “Outlets” in the workspace with the 

rest of your shapefiles. 

i. Right-click in the shapefiles folder-> New-> Shapefile… 

ii. Name it “Outlets,” and select Point as Feature Type. 

b. Add the Outlets shapefile to ArcMap. Note that it does not have any points in it. 

c. Start editing and select the folder with the Outlets shapefile. Set the Target to the 

Outlets layer. 

d. Zoom in as close as possible on each road-stream intersection. 

i. Use the Sketch Tool to create a point directly over each road-stream 

intersection. 

e. Zoom in as close as possible on a point on the main stream, downstream from all 

of the roads. This should be pretty far downstream. 

i. Use the Sketch Tool to create a point directly over the stream network line. 
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f. Save the edits and stop editing. The Outlets shapefile is now populated with all of 

the necessary points for the next step. 
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The Road Surface Erosion Analysis Menu 

 

The six tools under the Road Surface Erosion Analysis menu must be run from 

top to bottom. 

 

1. Open the GRAIP file. 

2. GRAIP toolbar-> Road Surface Erosion Analysis-> Road Segment Sediment 

Production. 

a. Ensure the RoadLines layer is properly located in the Road Shapefile field. 

b. Ensure that demr is properly located in the DEM Interpolated to a Finer Scale 

field. 

i. If this field is blank, demr has not been added to the map. Navigate to demr 

and select it. 

c. Click Compute. 

d. Open the Attribute Table for the RoadLines layer to ensure that the Length, Slope, 

SedProd1, SedProd2, UnitSed, TotSedProd, TotSedDel, and UnitTotSedProd 

columns are populated. The final two columns (TotSedDel and UnitTotSedProd) 

may have some cells with a zero. 

3. GRAIP toolbar-> Road Surface Erosion Analysis-> Drain Point Sediment 

Accumulation. 

a. Ensure that the RoadLines and DrainPoints shapefiles are correctly located in the 

Road Shapefile and Drain Points Shapefile fields, respectively. 

b. Click Compute. 

c. Ensure that the SedProd, ELength, UnitSed, and SedDel columns are populated in 

the DrainPoints Attribute Table. The SedDel column may be largely zeros. 

4. GRAIP toolbar-> Road Surface Erosion Analysis-> Accumulated Upstream Sediment 

Load. 

a. Ensure that the DrainPoints shapefile is correctly located in the DrainPoints 

Shapefile field, and demp is correctly located in the same folder as the TauDEM 

files in the D8(default)/Dinf Flow Direction Grid field. 

b. Ensure that Use D8 Contributing Area Function and Stream Connected are 

selected. 



 

 36 

c. Check to see that the two outputs (demswt and demsac) will be saved to the 

correct folder. If you have to change the folder, do not change their names. 

d. Click Compute. 

e. Make sure the two grids are reasonable. 

5. GRAIP toolbar-> Road Surface Erosion Analysis-> Accumulated Upstream Specific 

Sediment. 

a. Ensure demsac and demad8 are correctly located in the Accumulated Upstream 

Sediment Load Grid and Upstream Contributing Area Grid fields, respectively. 

b. Ensure the Output grid (demspe, in the Specific Sediment Accumulation Grid 

field) will be saved to the correct folder, as above. 

c. Click Compute. 

d. Ensure that the grid is reasonable. 

6. GRAIP toolbar-> Road Surface Erosion Analysis-> Upstream Stream Sediment Input. 

a.  Ensure demfel, demsac, demad8, and demnet are properly located in their 

respective fields (Pit Filled DEM, Accumulated Upstream Sediment Load Grid, 

Upstream Contributing Area Grid, and Stream Network Shapefile, respectively). 

b. Click Compute. 
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c. Ensure that the SedAccum and SpecSed columns are populated in the stream 

network layer Attribute Table. Both columns may be mostly zeros, depending on 

how many stream network segments are affected by the roads. 

7. GRAIP toolbar-> Road Surface Erosion Analysis-> Direct Stream Sediment Input. 

a. Ensure that the Input fields are correctly populated, as above in step 6a. 

b. Click Compute. 

c. Ensure that the SedDir and SpecSedDir fields are populated in the stream network 

Attribute Table. Both columns may be mostly zeros, depending on how many 

stream network segments are directly affected by the roads. 
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Running SINMAP 

 

 The SINMAPData folder is automatically created in the same directory as the 

DEM you base the analysis on for all of its files and grids. Use the same DEM that has 

been used all along for the GRAIP process, and is therefore the DEM that is located in 

the folder with all of the TauDEM files and grids. 

 

1. Open ArcMap or a new map file. SINAMP toolbar-> Initialization-> Select DEM 

Grid For Analysis. 

a. Navigate to the correct DEM, select it, and click Add. 

b. The selected DEM will be added to ArcMap, and the SINMAPData folder will be 

created under the same directory as the DEM. 

2. SINMAP toolbar-> Initialization-> Make Single Calibration Region Theme 

a. Various parameters can be changed so that the stability index grid is more 

accurate for the specific area being analyzed in this step. The defaults are initially 

fine. 

b. Click OK. 

c. The calibration grid (demcal) and its text file (demcalp) are created, added to 

ArcMap, and saved to the SINMAPData folder. 

3. SINMAP toolbar-> Grid Processing-> Compute All Steps 

a. No further input is necessary. 

b. Four grids are created and added to ArcMap (demfel, demang, demslp, and 

demsca), and saved to the SINMAPData folder. 

4. SINMAP toolbar-> Stability Analysis-> Compute All Steps 

a. No further input is necessary. 

b. The final two grids (demsi and demsat), as well as a series of text files (demrtp, 

demlsf, and demstat) are created and added to ArcMap. A statistics window (S A 

Plot) appears. The grids are saved to the SINMAPData folder. 

i. The S A Plot can be generated easily on its own, so you can close this 

window. Go to Stability Analysis-> SA plots. 



 

 39 

The Mass Wasting Potential Analysis Menu 

 

The eight tools under the Mass Wasting Potential Analysis menu heading must be 

run in order from top to bottom. These steps can be undertaken only after SINMAP has 

been run. 

 

1. Open ArcMap or a new map window and open the GRAIP file (the .graip). 

2. GRAIP toolbar-> Mass Wasting Potential Analysis-> Stability Index 

a. Ensure that the DrainPoints shapefile and stability index grids are correctly 

located, and click Compute. 

b. Check that the SI column has been populated in the DrainPoints Attribute Table. 

There should not be any zero values. 

3. Mass Wasting Potential Analysis-> Select Calibration Region Grid-> navigate to the 

SINMAPData folder created previously-> select the calibration grid (demcal)-> click 

Add. The calibration region grid is added to ArcMap. 

4. Mass Wasting Potential Analysis-> Combined Stability Index 

a. Ensure that the DrainPoints and RoadLines shapefiles are correctly located. 

Ensure that the fields Calibration Parameters Text File, Dinf Slope, Dinf Specific 

Catchment Area, and Calibration Grid are correctly populated and located 
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(demcalp.csv, demslp, and demsca from the TauDEM folder, and demcal from the 

SINMAPData folder, respectively). 

b. The following are default parameters: 

i. Specify Road Width (m) is 5. 

ii. Minimum Terrain Recharge (m/hr) is 0.0009. 

iii. Maximum Terrain Recharge (m/hr) is 0.00135. 

iv. Minimum Additional Road Surface Runoff (m/hr) is 0.001. 

v. Maximum Additional Road Surface Runoff (m/hr) is 0.002. 

c. You can edit additional parameters by clicking on the View/Edit Calibration 

Parameter File button. The defaults are all generally fine. 

d. Ensure that the Combined Stability Index Grid will be saved to the correct place. 

Do not change its name. 

e. Check Add SI combined grid to map and click Compute. 

f. Five grids are created (demsic, demrmin, demrmax, demrdmin, and demrdmax). 

The last four grids are not added to ArcMap and are saved to the same place as 

the TauDEM files. These files are intermediary (i.e. they are used by the 

Combined Stability Index function and nothing else) 

5. Mass Wasting Potential Analysis-> D8 Slope with downslope averaging 

a. Ensure that the Pit Filled DEM (demfel) and D8 Flow Direction Grid (demp) are 

correctly located. 

b. The default value for the Downgradient Trace Distance (m) field is 150. 

c. Ensure that the D8 Slope with Downslope Averaging Grid will be saved to the 

correct place. Do not change the name. 

d. Click Compute. The layer will be added to the map. 

6. Mass Wasting Potential Analysis-> Slope at Drain Point 
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a. Ensure that the Drain Points Shapefile (DrainPoints) and the D8 Slope with 

Downslope Averaging Grid (demslpd) are correctly located. 

b. Click Compute. 

c. Check to make sure the Slope column is populated in the DrainPoints Attribute 

Table. There should not be any zero values. 

7. Mass Wasting Potential Analysis-> Erosion Sensitivity Index 

a. Ensure that the Drain Points Shapefile is correctly located. 

b. The default for the Exponent Alpha field is 2. 

c. Click Compute. 

d. Check to make sure the ESI column in the DrainPoints Attribute Table is 

populated. There may be some zero values, which are orphan drain points. This 

function sometimes takes a few moments to populate the table. 

8. Mass Wasting Potential Analysis-> Length Slope Plot 

a. This generates a graph of effective length vs. slope of the drain points, with ESI 

lines super imposed. Note that the Y-axis is logarithmic. 

b. This figure can be used to pick threshold values of ESI, above which, the risk of 

gullying increases. 

c. Nothing is added to any table, created, or saved in this step. 

9. Mass Wasting Potential Analysis-> Stream Blocking Index 

a. Ensure that the Drain Points Shapefile is correctly located. 
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b. Click Compute. 

c. Ensure that the PipeDiaToChanWidthRatio, PipeDiaToChanWidthScore, 

SkewAngle, SkewAngleScore, and SBI columns in the DrainPoints table are 

populated at stream crossings. Most of the values will likely be zeros, because 

most drain points are not stream crossings. 

10. You can leave this map file open for the next step. 
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The Habitat Segmentation Analysis Menu 

 

There are two tools under the Habitat Segmentation Analysis menu that should be 

run from top to bottom. These steps may not be necessary if you are not conducting a 

watershed-wide study, or if another approach is being used. 

 

1. If ArcMap is not open, open it and open the appropriate .graip. 

2. GRAIP toolbar-> Habitat Segmentation Analysis-> Fish Passage Barrier 

a. Ensure that the DrainPoints shapefile is correctly located in the appropriate Inputs 

box. 

b. You can change the parameters that define a blocked passage. 

i. The following are default parameters: 

 Crossing Slope Sp (%) is 2. 

 Pipe/Channel Width ratio w*p is 0.75. 

 Outlet Drop ODp (ft) is 0.8 

 Outlet Drop to Pool Depth ratio is 1.125. 

c. Click Compute. 

d. Check to make sure that the Barrier column is populated with 0-2 at the stream 

crossings in the DrainPoints Attribute Table. 0 is a blocked passage to all species, 

1 is blocked to some species, and 2 is clear to all species. 

3. Habitat Segmentation Analysis->  Fish Habitat Segmentation 

a. Ensure that the Stream Network Shapefile, Matched Stream Crossings Shapefile, 

and Drain Points Shapefile are properly located. The Matched Stream Crossings 

Shapefile is MatchSX, created in the preprocessing step, above. 

b. In the Barriers to Fish Passage at Stream Crossings field, select whether you 

would like to use both blocked and possibly blocked barriers, or only blocked 

barriers to define when a stream crossing is blocked by selecting the appropriate 

dot. 

c. Click Compute. 

d. Check to make sure that the HabPatchID column is appended and populated in 

the stream network shapefile. 


